This came out when I update , how can i solve it ?

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
头像
Rerven
帖子: 75
注册时间: 2005-04-22 16:46
送出感谢: 0
接收感谢: 0

This came out when I update , how can i solve it ?

#1

帖子 Rerven » 2005-11-27 23:06

Like this below :
E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
what does it mean?

I would like to install XFCE environment , I use GUI installer to get it.
when I type in the terminal , the error is listed below , help me out!
sudo ./xfce4-4.2.3.2-installer.bin
Verifying file integrity... OK.
Extracting the installer... OK.
Checking for usable C compiler... gcc
Checking for usable C++ compiler... g++
Checking for GNU make... make
Checking for package config tool... pkg-config
Checking for GLib (GModule) >= 2.2.0... not found, see /home/mrt/.xfce4.installer-log for details
Cleaning up... OK.
I didint come across these problems since last installation. I have to ask Great guys to help me out!

I'll appreciate all of ur help!
头像
Rerven
帖子: 75
注册时间: 2005-04-22 16:46
送出感谢: 0
接收感谢: 0

#2

帖子 Rerven » 2005-11-27 23:08

the xfce4.installer-log is listed below:
##
## Started installation of xfce4 at 22:54h
##
## Visit http://forum.os-cillation.com/ if you
## have problems using this installer.
##

# Environment variables
PATH is set to "/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin:/bin:/usr/bin:/usr/local/ssl/bin:/usr/local/bin:/opt/openssl/bin:/usr/local/openssl/bin:/usr/pkg/bin:/usr/ucb:/usr/X11R6/bin:/usr/X11R6/bin:/usr/openwin/bin:/usr/local/bin:/opt/local/bin:/usr/pkg/bin:/opt/gnome2/bin:/opt/gnome/bin:/opt/xfce4/bin:/opt/xfce/bin:/home/mrt/local/bin:/home/mrt/xfce/bin:/home/mrt/xfce4/bin"
PKG_CONFIG_PATH is set to ":/usr/lib/pkgconfig:/usr/lib/pkgconfig"

## Checking for usable C compiler
gcc --version
/tmp/xfce4-4.2.3.2-installer/bootstrap.sh: line 37: gcc: command not found
## Checking for usable C++ compiler
g++ --version
/tmp/xfce4-4.2.3.2-installer/bootstrap.sh: line 58: g++: command not found
## Checking for GNU make
gmake --version
make --version
GNU Make 3.80
Copyright (C) 2002 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE.

## Checking for package config tool
pkg-config --version
0.19

## Checking for GLib (GModule) >= 2.2.0
pkg-config --atleast-version=2.2.0 glib-2.0 gmodule-2.0
!! Please install GLib 2.2.0 or above and the GLib development files. It is
!! important that you install GModule, which is part of GLib as well. GLib
!! can be downloaded from http://www.gtk.org/.
头像
oneleaf
论坛管理员
帖子: 10235
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 106 次

#3

帖子 oneleaf » 2005-11-28 0:02

1 你在安装的时候打开了新立得。
2 直接通过新立得安装Xface
头像
Rerven
帖子: 75
注册时间: 2005-04-22 16:46
送出感谢: 0
接收感谢: 0

#4

帖子 Rerven » 2005-11-28 0:18

oneleaf 写了:1 你在安装的时候打开了新立得。
2 直接通过新立得安装Xface
Actually. i shut synaptic down.. If i install xfce with synaptic , its version is 4.2.1, i just wanna new version 4.2.3 ... I downloaded GUI installer from XFCE website..I remember last installation is based on old 4.2.2 version.. Maybe should I install some database or dependancies ??
How about ???
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#5

帖子 eexpress » 2005-11-28 0:34

install GLib 2.2.0 or above
http://www.debian.org/distrib/packages
● 鸣学
回复

回到 “办公、图像、机械电子设计等”