当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : kylix 安装之后运行注册出错...
帖子发表于 : 2005-12-04 18:11 
头像

注册: 2005-08-02 11:52
帖子: 24
地址: 南宁
送出感谢: 0 次
接收感谢: 0 次
请看图,如果解决?


附件:
13.jpg
13.jpg [ 108.63 KiB | 被浏览 728 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-12-06 7:24 
头像

注册: 2005-08-02 11:52
帖子: 24
地址: 南宁
送出感谢: 0 次
接收感谢: 0 次
自己顶一下,各位帮帮忙啊!


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-12-14 8:55 
头像

注册: 2005-08-02 11:52
帖子: 24
地址: 南宁
送出感谢: 0 次
接收感谢: 0 次
acal@linux:~/kylix3> ./registerkylix
/home/acal/kylix3/pro/bin/kreg: relocation error: /home/acal/kylix3/pro/bin/libwine.borland.so: symbol errno, version GLIBC_2.0 not defined in file libc.so.6 with link time reference
acal@linux:~/kylix3>


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-12-23 21:30 

注册: 2005-12-23 20:52
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
我也碰到了同样的问题,现在还未解决。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-01-07 19:58 
头像

注册: 2005-08-02 11:52
帖子: 24
地址: 南宁
送出感谢: 0 次
接收感谢: 0 次
没有人知道怎么解决吗?


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-01-07 20:11 
头像

注册: 2005-04-08 18:08
帖子: 339
地址: Chongqing
送出感谢: 0 次
接收感谢: 0 次
可以与软件发行商取得联系


_________________
目前是 tinkpad r400 上的 debian 用户
my blog Trust Dating


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-01-07 20:13 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10116
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 128
export LD_ASSUME_KERNEL=2.4.21
./registerkylix

不过,不喜欢Kylix,使用这个,不如直接使用JAVA.
写的程序不稳定,长时间跑,会有问题。

顺便提一下,运行 startdelphi 也要前面的输出。

主要是屏蔽 NPTL 和 thread-local storage.


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-01-07 20:58 
头像

注册: 2005-08-02 11:52
帖子: 24
地址: 南宁
送出感谢: 0 次
接收感谢: 0 次
oneleaf 说详细一点好吗?

export LD_ASSUME_KERNEL=2.4.21
./registerkylix

? 不明白... :cry:


页首
 用户资料  
 
9 楼 
 文章标题 : OK! :) 已经解决!
帖子发表于 : 2006-01-09 16:58 
头像

注册: 2005-08-02 11:52
帖子: 24
地址: 南宁
送出感谢: 0 次
接收感谢: 0 次
谢谢!版主!


附件:
Kylix3.jpg
Kylix3.jpg [ 223.34 KiB | 被浏览 669 次 ]

页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-01-10 8:27 
头像

注册: 2005-08-02 11:52
帖子: 24
地址: 南宁
送出感谢: 0 次
接收感谢: 0 次
kylix3 注册成功了,运行也正常,但编译的时候不响应,怎样解决?


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-05-10 13:18 
头像

注册: 2006-04-29 20:10
帖子: 175
地址: 北京·昌平
送出感谢: 0 次
接收感谢: 0 次
解决Kylix3-BCB在MandrakeLinux9.1和RedHat9.0等新版Linux不能编译的补丁 版本: 1.0
发布时间: 2003年04月09日
软件描述:

此补丁解决Kylix3-BCB在MandrakeLinux9.1和RedHat9.0等新版Linux不能编译的问题。

使用方法:

1、解压:tar zxvf kylix3libpatch_mdk9.1_rhl9.tar.gz

2、将解出来的3个文件:crt1.o,libc.so,libpthread.so拷贝到$(BCB)/lib/obj中($(BCB)指你的Kylix3的安装目录)

3、新建一工程,点击菜单Project->Options...->Directories/Conditionals,将Include Path:设为/usr/include行头,
如:/usr/include:$(BCB)/include/stlport:$(BCB)/include:$(BCB)/include/vcl

4、点击“OK”保存,再按Ctrl+F9编译工程,一切OK,又可以用C++写Linux应用了。

COOL!


是一个类似于patch的东东:http://kylix.linuxaid.com.cn/xoops2/modules/mydownloads/visit.php?cid=8&lid=9


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2006-05-10 13:19 
头像

注册: 2006-04-29 20:10
帖子: 175
地址: 北京·昌平
送出感谢: 0 次
接收感谢: 0 次
再看看这个说法,似乎不需要安装上面的东东也可以:
I think it's not good to overwrite the files in /usr/include, because they're part of the glibc package. Overwritting them will cause trouble to other programs those rely on glibc!

The following is the method I'm using. Use it at your own risk and good luck.

Installing Kylix 3 in Redhat version > 7.2
prepared by Henry Leung <henryl@net-yan.com>


The Borland Kylix 3 is designed to run on glibc 2.1, therefore it's certified to operate on Redhat Linux 7.2. For version greater than 7.2, the glibc package have been upgraded to glibc 2.2 or greater, therefore it will generate errors during compilation.
To solve this problem, we need to install a compatible version of glibc, i.e. Compat-glibc. Besides, we also need to change the include path and library path in the project options. The following is the procedures:

Install the package Xfree86-devel. It contains libX11.so, and Kylix needs it.

Get the software package compat-glibc-6.2-2.1.3.2 from Redhat 7.2 CD, or from ftp websites. Install the package:
rpm -ivh compat-glibc-6.2-2.1.3.2.rpm
Execute the Kylix installation program, using -m argument for non-rpm install, as many versions of rpm have problem in relocating the software package:
sh ./setup.sh -m
Complete the registration and copy the registration file to your home directory. Then execute:
startbcb
When Kylix comes up, DO NOT open any project yet. You need to change the default settings. Set the include path and the library path to the compatible version of glibc:
Click Project – Options – Directories/Conditions
In the Include Path field, replace /usr/include with /usr/i386-glibc21-linux/include. Also move this entry to the top of the list.
In the Library Path field, replace /usr/lib with /usr/i386-glibc21-linux/lib. Again move the entry to the top.

Additional notes for Redhat 9
Kylix has compatibility problem with RH9 kernel. One workaround is to use
the following when calling Kylix:

export LD_ASSUME_KERNEL=2.2.5; startbcb

Now the installation is complete and try to run a simple program for testing. Good luck.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Bing [Bot] 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译