[问题]windows分区的文件和文件夹的中文名显示乱码,怎么办?(已经解决)

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
头像
oliver
帖子: 775
注册时间: 2005-10-05 11:31
送出感谢: 0
接收感谢: 0
联系:

[问题]windows分区的文件和文件夹的中文名显示乱码,怎么办?(已经解决)

#1

帖子 oliver » 2005-12-07 11:35

按照快速设置指南设置好系统,本地环境也按照上头设置好了。
可是为什么windows分区的文件和文件夹的中文名称依旧显示乱码呢?如何设置才能够解决这个问题呢?
上次由 oliver 在 2005-12-07 13:18,总共编辑 1 次。
luozi8
帖子: 17
注册时间: 2005-12-03 17:02
来自: 北京
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 luozi8 » 2005-12-07 12:24

其实方法很简单,呵呵:

把原来/etc/fstab中的内容:
例如:
/dev/hda1 /media/hda1 vfat defaults 0 0
改成:
/dev/hda1 /media/hda1 vfat defaults,iocharset=utf8 0
0
也就是每行加上:,iocharset=utf8就行。

另外建议发问前先在站内手搜一下
向前,向前,向前!
OS: Ubuntu 5.10
CPU: AMD sempron 2500++
RAM:512M DDR
Gcard: 6200
HARDDISK: 160G
我是新手:) 谢谢指教!
头像
oliver
帖子: 775
注册时间: 2005-10-05 11:31
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 oliver » 2005-12-07 13:04

我按照您的指点修改了,但是问题依旧。

我贴上我的fstab内容:

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda6 / reiserfs notail 0 1
/dev/hda1 /media/hda1 ntfs defaults,iocharset=utf8 0 0
/dev/hda5 /media/hda5 vfat defaults,iocharset=utf8 0 0
/dev/hda8 /media/hda8 vfat defaults,iocharset=utf8 0 0
/dev/hda7 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hda8 /media/windows vfat utf8,umask=000 0 0


这个是修改以后的。抱歉,起事我事先有搜索,我的搜索词为“乱码”,诸如此类,但是都没有搜索到 ,抱歉,拜托您继续指点下~


luozi8 写了:其实方法很简单,呵呵:

把原来/etc/fstab中的内容:
例如:
/dev/hda1 /media/hda1 vfat defaults 0 0
改成:
/dev/hda1 /media/hda1 vfat defaults,iocharset=utf8 0
0
也就是每行加上:,iocharset=utf8就行。

另外建议发问前先在站内手搜一下
: :(
头像
oneleaf
论坛管理员
帖子: 10230
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 103 次

#4

帖子 oneleaf » 2005-12-07 13:12

系统使用UTF-8的字符集。
头像
oliver
帖子: 775
注册时间: 2005-10-05 11:31
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 oliver » 2005-12-07 13:17

utf8 改为 utf-8以后问题问题就解决了。非常感谢~
oneleaf 写了:系统使用UTF-8的字符集。
之殇
帖子: 18
注册时间: 2005-06-12 11:46
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 之殇 » 2005-12-08 19:01

我的改成这样后,再次启动就看不到windows下的分区了, :shock:
哪儿有问题?
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda9 / ext3 defaults,errors=remount-ro 0 1
/dev/hda1 /media/hda1 vfat defaults,iocharset=utf-8 0 0
/dev/hda5 /media/hda5 vfat defaults,iocharset=utf-8 0 0
/dev/hda6 /media/hda6 vfat defaults,iocharset=utf-8 0 0
/dev/hda7 /media/hda7 ext3 defaults 0 2
/dev/hda8 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
linux for human beings
头像
laborer
帖子: 1016
注册时间: 2005-10-25 11:15
送出感谢: 0
接收感谢: 1 次
联系:

#7

帖子 laborer » 2005-12-08 19:10

utf8,不是utf-8
hreiser@oakland:~$ killall -9 wife
police@oakland:~$ sudo find / -user hreiser
court@oakland:~$ sudo mv /home/hreiser /jail/
court@oakland:~$ sudo usermod -d /jail/hreiser -s "/usr/sbin/chroot /jail/" hreiser
回复

回到 “办公、图像、机械电子设计等”