apache2安装apache2-mpm-worker时遇到问题

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
sanool
帖子: 26
注册时间: 2005-08-21 10:31
送出感谢: 0
接收感谢: 0
联系:

apache2安装apache2-mpm-worker时遇到问题

#1

帖子 sanool » 2005-12-29 14:21

apache2的mpm是prefork模式,支持PHP4的。

然后我想把apache2改成worker模式,毕竟这是2。0的特色。
可以当我
apt-get install apache2-mpm-worker时
发现/etc/apache2/mod-enable/下的php4.load php4.conf被删除了

也就是说改成worker之后,apache2就不支持PHP了。
无奈重新安装PHP4,可是也没反应,最后只要安装PHP5。
可是安装PHP5时 发现系统自动删除了apache2-mpm-worker,
于是PHP是可以用了 但APACHE2就回到了prefork模式。

望解惑
http://www.lupaworld.com
LUPA开源社区
yufengyue
帖子: 4
注册时间: 2010-09-19 17:36
送出感谢: 0
接收感谢: 0

Re: apache2安装apache2-mpm-worker时遇到问题

#2

帖子 yufengyue » 2010-09-20 17:42

我的也是这个问题,按照网上说的方法安装了worker模式,死活加载不上,还是prefork模式,郁闷中呢,难道就没有人知道吗? :em20
xstarcd
帖子: 28
注册时间: 2008-11-21 17:18
送出感谢: 0
接收感谢: 0

Re: apache2安装apache2-mpm-worker时遇到问题

#3

帖子 xstarcd » 2011-05-29 11:49

安裝 Apache2 Mpm Worker 會移除 Apache2 Mpm prefork 和 PHP5 Module 。
这是正常的,在线程模式下,不能用mod_php了,要用fastcgi。
回复

回到 “办公、图像、机械电子设计等”