还有最后一个问题-ThinkPad 600E 怎么也弄不出声来!(已搞定)

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
bighan
帖子: 28
注册时间: 2005-05-11 12:08
送出感谢: 0
接收感谢: 0

还有最后一个问题-ThinkPad 600E 怎么也弄不出声来!(已搞定)

#1

帖子 bighan » 2005-06-04 23:59

本本用的是CS4232声卡,我几乎把所有的LINUX发行版都安过一遍,没有一个能支持的! :evil:
在GOOGLE上搜索了几天,用下面的方法虽然把音量控制器的小图标给调出来了,但还是不能发声:

1. copy the below and save to /etc/init.d/sound
------------------------------------
#!/bin/sh
#soundscript

case $1 in

start)
echo "Start sound ..."
/sbin/modprobe ad1848
/sbin/modprobe uart401
/sbin/modprobe cs4232
;;

stop)
echo "Stop sound ..."
rmmod cs4232
rmmod uart401
rmmod ad1848
;;
*)
echo "Usage: $0 {start|stop}"
exit 1
;;

esac
exit 0
------------------------------------------

2. copy the below and copy to /etc/modutils/sound
------------------------------
alias sound-slot-0 cs4232
alias sound-service-0-3 cs4232
alias sound-service-0-0 cs4232
options sound dmabuf=1
options cs4232 io=0x530 irq=5 dma=1 dma2=0 isapnp=0 \
mpuio=0x330 mpuirq=5 \
synthio=0x338 synthirq=9
options opl3 io=0x388
options wavefront io=0x338 irq=9
------------------------------------------

3. delete from /etc/modutils all sndconfig, alsa-base, etc
4. run updates-modules
5. softlink /etc/init.d/sound to S79sound in all /etc/rc[2-5].d
directories. I have also delete all the S20alsa links.

谁能帮我一下,万分感谢!

=============================

还是用上面的方法,只是忘了起动。 :)
头像
oneleaf
论坛管理员
帖子: 10218
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 102 次

#2

帖子 oneleaf » 2005-06-05 10:31

当净其意如虚空,远离妄想及诸取,令心所向皆无碍
bighan
帖子: 28
注册时间: 2005-05-11 12:08
送出感谢: 0
接收感谢: 0

#3

帖子 bighan » 2005-06-06 2:44

呵呵~~原来已经有解决方案了,不过我现在也弄出声来了,是从官方论坛上看到的。声音效果还不错。
wwwlion
帖子: 62
注册时间: 2005-05-31 9:20
送出感谢: 0
接收感谢: 0

#4

帖子 wwwlion » 2005-06-07 0:55

bighan 写了:呵呵~~原来已经有解决方案了,不过我现在也弄出声来了,是从官方论坛上看到的。声音效果还不错。


真是幸福呀,不知道我那个Sony srx99是否支持,由于没有光驱,一直不敢实验。
lb_ok
帖子: 26
注册时间: 2006-07-20 16:25
送出感谢: 0
接收感谢: 0

#5

帖子 lb_ok » 2006-07-20 16:53

请问怎样解决声卡问题?

我也是600E
lb_ok
帖子: 26
注册时间: 2006-07-20 16:25
送出感谢: 0
接收感谢: 0

#6

帖子 lb_ok » 2006-07-25 9:00

oneleaf 写了:http://www.ubuntu.org.cn/docs/UserDocumentation/HardwareSupport/Documentation/document.2005-06-05.9348894186/document_view


这个链接已经看不到了,就问有新的链接吗?

试了几个方法都没能把我的本本 IBM Thinkpad 600E搞出声音来 :shock:
pxydb
帖子: 5
注册时间: 2007-12-10 18:19
送出感谢: 0
接收感谢: 0

#7

帖子 pxydb » 2007-12-10 21:33

IBM 600E 笔记本的声卡设置问题!
http://forum.ubuntu.org.cn/weblog_entry ... 29be51df1b
回复

回到 “办公、图像、机械电子设计等”