刷新字体缓存出错,该如何办?

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

刷新字体缓存出错,该如何办?

#1

帖子 yongyi » 2005-06-08 13:11

我修改fonts.conf,但结果不满意,于是把原来备份的覆盖一下。
然后再刷新字体缓存,就出错了:

代码: 全选

yongyi@yongyi:~$ sudo fc-cache -f
Fontconfig error: line 1: xml declaration not at start of external entity
Fontconfig error: Cannot load default config file


并且,回不到以前的效果了。应该怎么处理?
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
头像
longmjshen
帖子: 94
注册时间: 2005-10-18 13:55
送出感谢: 0
接收感谢: 0

#2

帖子 longmjshen » 2005-11-16 22:36

opera 和你一样

baoyu@ubuntu:~$ opera
Fontconfig error: line 2: xml declaration not at start of external entity
Fontconfig error: Cannot load default config file
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#3

帖子 eexpress » 2005-11-17 13:50

fonts.conf的格式不对吧。比较一下吧。
● 鸣学
zdho
帖子: 26
注册时间: 2005-07-22 11:53
送出感谢: 0
接收感谢: 0

#4

帖子 zdho » 2005-12-01 2:19

对阿 ,,,我也是这样的清况阿 ,,,,好郁闷阿 ,,,,
求各位帮帮我阿~
头像
nmvr2600
帖子: 215
注册时间: 2005-11-01 18:23
送出感谢: 0
接收感谢: 0

#5

帖子 nmvr2600 » 2005-12-01 10:41

eexpress 写了:fonts.conf的格式不对吧。比较一下吧。

同意这个说法 8)
建议改动的时候最好有个基础,然后每次更改一小部分,如果你不明白那些配置的含义的话。保存后,开个新窗口就可以看到效果了。 :wink:
kdekid
帖子: 32
注册时间: 2005-11-25 11:57
送出感谢: 0
接收感谢: 0

#6

帖子 kdekid » 2005-12-01 11:03

代码: 全选

Fontconfig error: line 2: xml declaration not at start of external entity 

这句话的意思是 xml 定义没有从external entity开始,应该是xml格式的文件错误。你检查一下文件的第一行,必须不能是空行,也不能有空格。文件的开头就必须是:

代码: 全选

<?xml version="1.0"?>
zdho
帖子: 26
注册时间: 2005-07-22 11:53
送出感谢: 0
接收感谢: 0

#7

帖子 zdho » 2005-12-01 14:25

goood!!!
6楼的朋友可能说到问题上去了,,,,真的没有多大可能第一行就报错,,
我想也是第一句前有空格或者是空行的问题,,
我检查过够发现第一句前的确有一个空格,,但我调整好后,,保存,,,退出,
再打开 fonts.conf 的话那个空格依旧存在,,,,,
郁闷的要死了,,,,求求大家继续为我们想想办法~
kdekid
帖子: 32
注册时间: 2005-11-25 11:57
送出感谢: 0
接收感谢: 0

#8

帖子 kdekid » 2005-12-01 15:50

检查一下你系统的encoding是什么。如果是utf-8,一般没什么问题。试试新建一个文件,然后把原来的文件内容复制一份过去。如果不是utf-8,试试先把encoding改成utf-8(例如zh_CN.UTF-8),然后再重新建立一次fonts.conf。
回复

回到 “办公、图像、机械电子设计等”