[问题]局域网内传输速度过慢

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
头像
xtayfool
帖子: 218
注册时间: 2005-09-17 10:16
送出感谢: 0
接收感谢: 0

[问题]局域网内传输速度过慢

#1

帖子 xtayfool » 2006-01-10 12:43

100Mbps的局域网,从别人的电脑上拖东西过来,传输速度小于5MB/s。以前使用Windows时,速度达到60Mbps以上,现在拖相同大小的东西,明显感觉速度慢了好多。硬盘灯在闪,而以前拖东西的时候是一直在亮。


请问ubuntu是不是对网络连接速度做了限制,现在无论从多快的网站上下载东西,都超不过5MB/s
上次由 xtayfool 在 2006-01-10 21:27,总共编辑 1 次。
头像
Tenyears
帖子: 2245
注册时间: 2005-06-30 15:46
来自: 成都
送出感谢: 0
接收感谢: 0

#2

帖子 Tenyears » 2006-01-10 14:45

MB?Mb?
没有限制
Humanity to others // 己所不欲,勿施与人
Laptop: ThinkPad X220 --- Win7 Home / Ubuntu 12.04
Desktop: Win7/Ubuntu 12.04
Server: Ubuntu12.04
头像
xtayfool
帖子: 218
注册时间: 2005-09-17 10:16
送出感谢: 0
接收感谢: 0

#3

帖子 xtayfool » 2006-01-10 21:28

没说清楚,不好意思
我发觉在Windows下常用Mbps计算,在Ubuntu网络监视器中使用MB/s.


已经对原来帖子作了纠正
GPX-ZERO
帖子: 38
注册时间: 2005-08-04 14:37
来自: 中国香港
送出感谢: 0
接收感谢: 0

#4

帖子 GPX-ZERO » 2006-01-10 21:51

sudo ethtool eth0
Speed項是什麼?
头像
xtayfool
帖子: 218
注册时间: 2005-09-17 10:16
送出感谢: 0
接收感谢: 0

#5

帖子 xtayfool » 2006-01-10 22:26

我的sudo ethtool eth0 显示:

Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full,100baseT/Half 100baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full,100baseT/Half 100baseT/Full
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: MII
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: pumbg
Wake-on: d
Current message level: 0x00000001 (1)
Link detected: yes
jjheng
帖子: 36
注册时间: 2005-09-29 17:07
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 jjheng » 2006-01-11 9:51

如果是用ssh传文件的话这个速度也差不多。
头像
xtayfool
帖子: 218
注册时间: 2005-09-17 10:16
送出感谢: 0
接收感谢: 0

#7

帖子 xtayfool » 2006-01-11 11:27

应该可以更快的
头像
Tenyears
帖子: 2245
注册时间: 2005-06-30 15:46
来自: 成都
送出感谢: 0
接收感谢: 0

#8

帖子 Tenyears » 2006-01-11 16:28

7.2MB和5MB,差距很小了。
你用的samba还是ssh?这两个速度都不快。与系统无关。
Humanity to others // 己所不欲,勿施与人
Laptop: ThinkPad X220 --- Win7 Home / Ubuntu 12.04
Desktop: Win7/Ubuntu 12.04
Server: Ubuntu12.04
头像
xtayfool
帖子: 218
注册时间: 2005-09-17 10:16
送出感谢: 0
接收感谢: 0

#9

帖子 xtayfool » 2006-01-11 22:52

在用samba,难道是samba的问题?
传输速度嘛,当然是希望越快越好了。
头像
Tenyears
帖子: 2245
注册时间: 2005-06-30 15:46
来自: 成都
送出感谢: 0
接收感谢: 0

#10

帖子 Tenyears » 2006-01-12 10:27

samba是反向工程的产物,有缺陷是难免的。
Humanity to others // 己所不欲,勿施与人
Laptop: ThinkPad X220 --- Win7 Home / Ubuntu 12.04
Desktop: Win7/Ubuntu 12.04
Server: Ubuntu12.04
atfa
帖子: 88
注册时间: 2005-08-22 11:13
送出感谢: 0
接收感谢: 0

#11

帖子 atfa » 2006-01-13 9:54

我的系统真奇怪,ethtool eth1显示出下面的内容

代码: 全选

        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Advertised link modes:  1000baseT/Full
为什么网卡支持的速度最大才100M,广告的/推荐的(?)速度是1000M?不理解阿
tsrjzq
帖子: 27
注册时间: 2005-10-31 18:46
送出感谢: 0
接收感谢: 0

#12

帖子 tsrjzq » 2006-01-16 16:49

是不是DMA传输没打开?打开即可,我记得默认是关闭的
头像
xtayfool
帖子: 218
注册时间: 2005-09-17 10:16
送出感谢: 0
接收感谢: 0

#13

帖子 xtayfool » 2006-01-17 22:07

开了的,用hdparm -t /dev/hdx 测试,平均速度在50MB/s以上
回复

回到 “办公、图像、机械电子设计等”