ubuntu花屏--附贴图,xorg文件,有详细问题报告,大家看看了

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
★璇玑★
帖子: 58
注册时间: 2006-01-11 0:15
送出感谢: 0
接收感谢: 1 次

ubuntu花屏--附贴图,xorg文件,有详细问题报告,大家看看了

#1

帖子 ★璇玑★ » 2006-01-11 0:47

装了不久5.10的..
一直没什么问题..
刚才在图形登陆界面是屏幕水平一道一道的..
就象树皮了...
大家有碰过这种问题吗?
登陆到Gnome后,
一样的问题,本来截了图想贴上来...
结果,在windows下查看图片,根本没有问题...
我可不重装.麻烦..
还有我的机子对Ctrl+Alt_+Fn弹出的终端,
反应很慢,ls就让她死掉...

虽然我的屏幕花屏,
但是截下来的图很正常,
底下我看到板油的一个土,
与我情况相似..
大家看看

这是我从grub中recovery进入,
得到东西..
xorg.conf文件
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/CID"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
# paths to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load "GLcore"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "Device"
Identifier "ATI Technologies, Inc. Radeon Mobility 9000 (M6 LY)"
Driver "ati"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies, Inc. Radeon Mobility 9000 (M6 LY)"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1400x1050"
EndSubSection
SubSection "Display"
Depth 4
Modes "1400x1050"
EndSubSection
SubSection "Display"
Depth 8
Modes "1400x1050"
EndSubSection
SubSection "Display"
Depth 15
Modes "1400x1050"
EndSubSection
SubSection "Display"
Depth 16
Modes "1400x1050"
EndSubSection
SubSection "Display"
Depth 24
Modes "1400x1050"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
EndSection

Section "DRI"
Mode 0666
EndSection
----------------------xresprobe ati
id:
res: 1400x1050
freq:
disptype: lcd/lvds
我在windowns下查到的硬件信息
PCMCIA: Richoh R/RL/5C476 or Compatible CardBus Controller
Monitor: IBM ThinkPad 1400*1050 LCD panel
显卡:ATI Mobility Radeon
大家帮我看看,
我可不再
想用windows了,
老用盗版,
怪不好意思的

有一点要声明的,
我安装后,用了几次,没什么不正常的...
以后,都是这样了,不管我重起多少次
附件
t_123_886.gif
上次由 ★璇玑★ 在 2006-01-11 16:48,总共编辑 4 次。
★璇玑★
帖子: 58
注册时间: 2006-01-11 0:15
送出感谢: 0
接收感谢: 1 次

#2

帖子 ★璇玑★ » 2006-01-11 10:41

是不是分辨绿的问题啊.
我的是1400*1050的吧,
刷新频率不记得了...
现在只能从recovery 登陆根用户..
大家帮我看看...
头像
ttand
帖子: 1743
注册时间: 2005-08-22 14:05
来自: 离开北京
送出感谢: 1 次
接收感谢: 3 次

#3

帖子 ttand » 2006-01-11 10:41

可能是刷新率 没有设置好
我的机子可以 使用87hz
但是使用它就会出现花纹
★璇玑★
帖子: 58
注册时间: 2006-01-11 0:15
送出感谢: 0
接收感谢: 1 次

#4

帖子 ★璇玑★ » 2006-01-11 11:06

请问在哪个文件内设置刷新
Xconfig?
★璇玑★
帖子: 58
注册时间: 2006-01-11 0:15
送出感谢: 0
接收感谢: 1 次

#5

帖子 ★璇玑★ » 2006-01-11 15:51

大家帮我看看了..
先谢谢了.......
★璇玑★
帖子: 58
注册时间: 2006-01-11 0:15
送出感谢: 0
接收感谢: 1 次

#6

帖子 ★璇玑★ » 2006-01-11 16:45

硬是进去了,
抓了几张图,
大家看看....
我想这不是重装能解决的问题,
以前装过5.10,开机就是这样.
这次走运,
用了几次,才爆发...........

还得靠大家帮忙啊............
附件
Screenshot-1.png
头像
catinsnow
帖子: 773
注册时间: 2005-08-02 7:23
来自: 上海
送出感谢: 0
接收感谢: 1 次

#7

帖子 catinsnow » 2006-01-11 16:55

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 31.5 - 80
VertRefresh 50-60

EndSection
这样试试呢.具体参数可以查看x的log.
或者你装ati官方的fglrx驱动试试.
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
★璇玑★
帖子: 58
注册时间: 2006-01-11 0:15
送出感谢: 0
接收感谢: 1 次

#8

帖子 ★璇玑★ » 2006-01-11 17:01

这样试试呢.具体参数可以查看x的log.
或者你装ati官方的fglrx驱动试试.
谢谢了...我试试..
这句是什么意思呢?[/quote]
头像
catinsnow
帖子: 773
注册时间: 2005-08-02 7:23
来自: 上海
送出感谢: 0
接收感谢: 1 次

#9

帖子 catinsnow » 2006-01-11 17:07

参数是指定扫描频率,可以限定使用的刷新率.但这个参数并不是精确匹配你的机器的,但一般不会影响.x的log一般会显示检测到的参数.
fglrx是ati官方的驱动.
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
★璇玑★
帖子: 58
注册时间: 2006-01-11 0:15
送出感谢: 0
接收感谢: 1 次

#10

帖子 ★璇玑★ » 2006-01-11 17:14

我刚才试过,
还和原来一样啊....
我的电脑是IBM A30的
下什么版本的驱动呢...我只在win下看到显卡:ATI Mobility Radeon
Monitor: IBM ThinkPad 1400*1050 LCD panel
好难啊...........
头像
catinsnow
帖子: 773
注册时间: 2005-08-02 7:23
来自: 上海
送出感谢: 0
接收感谢: 1 次

#11

帖子 catinsnow » 2006-01-11 17:23

代码: 全选

sudo apt-get install xorg-driver-fglrx  linux-restricted-modules-686
如果是386内核,686改为386.
编辑xorg.conf文件,

代码: 全选

 Driver "ati" 
改为

代码: 全选

 Driver "fglrx" 
重启试试.
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
★璇玑★
帖子: 58
注册时间: 2006-01-11 0:15
送出感谢: 0
接收感谢: 1 次

#12

帖子 ★璇玑★ » 2006-01-11 17:24

thank you...
我试试...
★璇玑★
帖子: 58
注册时间: 2006-01-11 0:15
送出感谢: 0
接收感谢: 1 次

#13

帖子 ★璇玑★ » 2006-01-11 17:38

已经正常,
谢谢你的帮助... :lol:
下次如果再坏了,就用驱动了....
回复

回到 “办公、图像、机械电子设计等”