关闭永中后出现的问题,请高手指教!!

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
yiyid
帖子: 51
注册时间: 2007-03-08 13:44
送出感谢: 0
接收感谢: 0
联系:

关闭永中后出现的问题,请高手指教!!

#1

帖子 yiyid » 2007-11-14 11:14

关闭后在在终端下输入:eio 出现下面的错误

Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Exception in thread "main" java.lang.InternalError: Can't connect to X11 window server using ':0.0' as the value of the DISPLAY variable.
at sun.awt.X11GraphicsEnvironment.initDisplay(Native Method)
at sun.awt.X11GraphicsEnvironment.access$000(Unknown Source)
at sun.awt.X11GraphicsEnvironment$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at sun.awt.X11GraphicsEnvironment.<clinit>(Unknown Source)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(Unknown Source)
at sun.awt.X11.XToolkit.<clinit>(Unknown Source)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at java.awt.Toolkit$2.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Toolkit.getDefaultToolkit(Unknown Source)
at emo.system.ShellMethods.showSplash(Unknown Source)
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

xhost: unable to open display ":0.0"


执行其他的程序则是
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified
hujy
帖子: 218
注册时间: 2006-05-25 10:13
来自: 明州
送出感谢: 0
接收感谢: 0

#2

帖子 hujy » 2007-11-14 18:38

重装x-window-system-core,试试。
yiyid
帖子: 51
注册时间: 2007-03-08 13:44
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 yiyid » 2007-11-14 18:57

没法还是同样的问题。
头像
masonliu
帖子: 450
注册时间: 2007-04-10 14:51
送出感谢: 1 次
接收感谢: 1 次

javar环境不对吧

#4

帖子 masonliu » 2007-11-15 21:11

好像你没有安永中自带java基本都这样。
yiyid
帖子: 51
注册时间: 2007-03-08 13:44
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 yiyid » 2007-11-16 23:46

我用的源里面的JAVA版本。但是永中可以运行一次不会出任何问题的。再次运行的时候就不能运行任何程序了
回复

回到 “办公、图像、机械电子设计等”