[问题]ubuntu 5.10中文显示的问题

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
airland
帖子: 14
注册时间: 2006-01-21 0:56
送出感谢: 0
接收感谢: 0

[问题]ubuntu 5.10中文显示的问题

#1

帖子 airland » 2006-01-21 0:59

安装时使用的是英文系统
希望能够正常显示中文,有中文输入法即可。全部都是按照新手指南里面来做的

现在的问题是:所有内容为中文的文本文件,打开后(用vi,gedit)都是乱码,不知何故?如何解决?要解决这个问题还需提供哪些信息?请大虾们赐教!
我的locale是:
LANG=en_GB.UTF-8
LC_CTYPE=zh_CN.UTF-8
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=

另外,通过修改/etc/fstab,中文目录可以正常显示,别的中文显示目前都没问题,就是中文文本文件打开都是乱码,如下所示:
ÖÁÉÙ¶Œ¿Ž¹ý5±éµÄ£¬¶øÇÒÏÖÔÚÒªÊÇ·ÅÔÚÎÒÑÛÇ°»¹ÄÜŒÌÐø×Ì×ÌÓÐζµØ¿ŽÏÂÈ¥¡£²»Žú±íÒÕÊõ¶à

ºÃ°¡£¬ŸÍÊǺÿŽ

ÅÅÃû²»·ÖÏȺó¡£
xk.leng
帖子: 57
注册时间: 2006-01-09 22:53
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 xk.leng » 2006-01-21 9:34

LANG=zh_CN.UTF-8
LC_CTYPE=zh_CN.UTF-8
LC_NUMERIC="zh_CN.UTF-8"
LC_TIME="zh_CN.UTF-8"
LC_COLLATE="zh_CN.UTF-8"
LC_MONETARY="zh_CN.UTF-8"
LC_MESSAGES="zh_CN.UTF-8"
LC_PAPER="zh_CN.UTF-8"
LC_NAME="zh_CN.UTF-8"
LC_ADDRESS="zh_CN.UTF-8"
LC_TELEPHONE="zh_CN.UTF-8"
LC_MEASUREMENT="zh_CN.UTF-8"
LC_IDENTIFICATION="zh_CN.UTF-8"
LC_ALL=

:lol: :lol:
airland
帖子: 14
注册时间: 2006-01-21 0:56
送出感谢: 0
接收感谢: 0

#3

帖子 airland » 2006-01-21 13:51

请问,怎样才能修改成您这样的呢?
我的 /etc/environment采用快速设置指南里面的:
LANGUAGE="en_US:en"
LC_CTYPE=zh_CN.UTF-8
LANG=en_GB.UTF-8
GST_ID3_TAG_ENCODING=GBK


xk.leng 写了:LANG=zh_CN.UTF-8
LC_CTYPE=zh_CN.UTF-8
LC_NUMERIC="zh_CN.UTF-8"
LC_TIME="zh_CN.UTF-8"
LC_COLLATE="zh_CN.UTF-8"
LC_MONETARY="zh_CN.UTF-8"
LC_MESSAGES="zh_CN.UTF-8"
LC_PAPER="zh_CN.UTF-8"
LC_NAME="zh_CN.UTF-8"
LC_ADDRESS="zh_CN.UTF-8"
LC_TELEPHONE="zh_CN.UTF-8"
LC_MEASUREMENT="zh_CN.UTF-8"
LC_IDENTIFICATION="zh_CN.UTF-8"
LC_ALL=

:lol: :lol:
airland
帖子: 14
注册时间: 2006-01-21 0:56
送出感谢: 0
接收感谢: 0

#4

帖子 airland » 2006-01-21 16:08

哪位大虾指教一下?
真的很着急,谢谢
头像
catinsnow
帖子: 773
注册时间: 2005-08-02 7:23
来自: 上海
送出感谢: 0
接收感谢: 1 次

#5

帖子 catinsnow » 2006-01-21 16:14

没有这样用过,不过看过程你好像一直没有生成过中文locales.试试这样呢:

代码: 全选

sudo locale-gen zh_CN zh_CN.GBK zh_CN.GB18030 zh_CN.UTF-8
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
airland
帖子: 14
注册时间: 2006-01-21 0:56
送出感谢: 0
接收感谢: 0

#6

帖子 airland » 2006-01-21 17:13

试了,不行

如果在登陆时选择语言为中文,则locale变为:
LANG=zh_CN.UTF-8
LC_CTYPE=zh_CN.UTF-8
LC_NUMERIC="zh_CN.UTF-8"
LC_TIME="zh_CN.UTF-8"
LC_COLLATE="zh_CN.UTF-8"
LC_MONETARY="zh_CN.UTF-8"
LC_MESSAGES="zh_CN.UTF-8"
LC_PAPER="zh_CN.UTF-8"
LC_NAME="zh_CN.UTF-8"
LC_ADDRESS="zh_CN.UTF-8"
LC_TELEPHONE="zh_CN.UTF-8"
LC_MEASUREMENT="zh_CN.UTF-8"
LC_IDENTIFICATION="zh_CN.UTF-8"
LC_ALL=

这样就可以显示中文文本文件了,但是此时系统编成中文的了,和我的需求不一致。如何才能在英文系统中正确显示中文的文本文件呢?

看来主要是LANG=zh_CN.UTF-8的作用,有没有办法不改变系统语言而单独修改LANG?
appa
帖子: 22
注册时间: 2006-03-04 21:58
送出感谢: 0
接收感谢: 0

#7

帖子 appa » 2006-03-05 10:41

airland 写了:试了,不行

如果在登陆时选择语言为中文,则locale变为:
LANG=zh_CN.UTF-8
LC_CTYPE=zh_CN.UTF-8
LC_NUMERIC="zh_CN.UTF-8"
LC_TIME="zh_CN.UTF-8"
LC_COLLATE="zh_CN.UTF-8"
LC_MONETARY="zh_CN.UTF-8"
LC_MESSAGES="zh_CN.UTF-8"
LC_PAPER="zh_CN.UTF-8"
LC_NAME="zh_CN.UTF-8"
LC_ADDRESS="zh_CN.UTF-8"
LC_TELEPHONE="zh_CN.UTF-8"
LC_MEASUREMENT="zh_CN.UTF-8"
LC_IDENTIFICATION="zh_CN.UTF-8"
LC_ALL=

这样就可以显示中文文本文件了,但是此时系统编成中文的了,和我的需求不一致。如何才能在英文系统中正确显示中文的文本文件呢?

看来主要是LANG=zh_CN.UTF-8的作用,有没有办法不改变系统语言而单独修改LANG?



我也希望用英文系统,但是目录的中文能够显示。
luan_sheng
帖子: 21
注册时间: 2006-03-20 7:54
送出感谢: 0
接收感谢: 0

#8

帖子 luan_sheng » 2006-03-21 20:03

之所以出现乱码是因为你没有安装中文字体的原因。只要装了中文字体。如果你用kubuntu,可以这样设置:

由于牵涉到SimSun版权,所以如果有版权需求的朋友不要使用。

http://www.linuxfans.org/nuke/modules.p ... o&did=2488

安装步骤:
1.把下载到的字体都放入 /usr/share/fonts 目录下由于牵涉到SimSun版权,所以如果有版权需求的朋友不要使用。

http://www.linuxfans.org/nuke/modules.p ... o&did=2488

安装步骤:
1.把下载到的字体都放入 /usr/share/fonts 目录下
2.重起X-window
3.字体设置里都选用 Vera Sans YuanTi 即可。等宽和终端字体要用 Vera Sans YuanTi Mono

下载8个字体文件对应:普通/粗体/斜体/粗斜 等宽/非等宽 两套字体
也可以这样安装,在KDE下:
设置本地local环境:
sudo dpkg-reconfigure locales

确保 zh_CN.UTF-8 被选择,同时也默认local为 zh_CN.GBK

system settings->Appearance->Fonts->字体设置里都选用 Vera Sans YuanTi
即可。等宽和终端字体要用 Vera Sans YuanTi Mono 。
2.重起X-window
3.字体设置里都选用 Vera Sans YuanTi 即可。等宽和终端字体要用 Vera Sans YuanTi Mono

下载8个字体文件对应:普通/粗体/斜体/粗斜 等宽/非等宽 两套字体
也可以这样安装,在KDE下:
设置本地local环境:
sudo dpkg-reconfigure locales

确保 zh_CN.UTF-8 被选择,同时也默认local为 zh_CN.GBK

system settings->Appearance->Fonts->字体设置里都选用 Vera Sans YuanTi
即可。等宽和终端字体要用 Vera Sans YuanTi Mono 。
回复

回到 “办公、图像、机械电子设计等”