当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 我的同一硬盘下的FAT文件分区在UBUNTU下中文文件名全是问号“?”
帖子发表于 : 2006-01-21 22:06 

注册: 2006-01-19 10:33
帖子: 62
送出感谢: 0 次
接收感谢: 0 次
怎么才能看到中文文件名哦


是系统启动就自动挂载了的


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-01-22 11:37 

注册: 2006-01-19 10:33
帖子: 62
送出感谢: 0 次
接收感谢: 0 次
但是我另外一个硬盘,也就是/dec/hdb的就没这个问题


只有/dev/hda的VFAT分区显示不了中文文件名,怎么办阿


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-01-22 19:03 

注册: 2006-01-21 0:56
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
把你的/etc/fstab文件贴出来看看


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-01-25 11:59 

注册: 2006-01-16 16:35
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
改/etc/fstab下的配置

把你vfat分区的挂载选项

defualt改成

iocharset=utf8,umask=0

就好了


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-03-01 10:16 
头像

注册: 2006-02-22 16:31
帖子: 70
地址: 湖南长沙
送出感谢: 0 次
接收感谢: 0 次
注意你挂载硬盘的时候charset的值,一般要和你的local相同


_________________
HP 2510P


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-03-07 16:19 

注册: 2006-03-07 16:12
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
我的也出现了同样的问题,挂载上的fat32分区中中文以问号显示,但是fstab中为什么没有这个的信息?
内容如下:
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hdb3 / ext3 defaults,errors=remount-ro 0 1
/dev/hdb8 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
谁能帮帮忙,怎么解决,谢了


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-07-04 10:12 
头像

注册: 2008-06-10 12:30
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
Erica 写道:
我的也出现了同样的问题,挂载上的fat32分区中中文以问号显示,但是fstab中为什么没有这个的信息?
我想在mtab里吧
代码:
sudo gedit /etc/mtab


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译