[求助]又进不了X windows,紧急求助!

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
xiaobingyu
帖子: 10
注册时间: 2006-01-23 18:41
送出感谢: 0
接收感谢: 0

[求助]又进不了X windows,紧急求助!

#1

帖子 xiaobingyu » 2006-01-24 0:14

请大家帮忙看看是什么问题,一开始还是好的,后来装了一些字体,视频,音频的解码器,再重启X-windows的时候,就进不去了,提示信息:
I cannot start the X server(your graphic interface). It is likely that it si not up correctly Would you like to view the X server output to diagnose the problem?

大家知道是什么原因吗?我已经第二次重装系统了,上一次一次性更新了很多东西之后,也出现这种情况,只好重装系统。现在又出现了,我想知道大概是什么原因,总不能说重装系统是解决这个问题的唯一途径吧。

Xorg.conf我保留了一份历史备份,没有发生变化。

Xorg.0.log很长,最后的一些信息是:

couldn't init font path element unix/:7100,removing from list!

Fatal server error:
could not open default font 'fixed'
the X server's font paths might be misconfigured, remote font server(s) mayebe unreachable, and/or local fonts may not be installed or are not configured correctly.

请大家给出一些提示,或者解决方案,多谢,多谢!
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-01-24 10:53

字体的问题。有个xorg的配置dpkg-reconfigure xserver-xorg,
xorgconfig,或者update,upgrade
● 鸣学
xiaobingyu
帖子: 10
注册时间: 2006-01-23 18:41
送出感谢: 0
接收感谢: 0

#3

帖子 xiaobingyu » 2006-01-24 14:35

我 dpkg-reconfigure xserver-xorg 没有用,因为xorg.conf一直没有变化,而一开始它是可以正常启动的。

后来,找了N个小时,终于找到了答案,原来在xorg.conf里面,FontPath "unix/: 7100"所指定的local font server没有能够包含所有启动时所需要字体。可以到FontPath "/usrlib/X11/fonts/" 这个备份路径下面找一找,但我的系统里面竟然什么没都有。 后来我把它的值改为 "/usr/X11R6/lib/X11/fonts/"之后,就可以正常启动了。但并不是把所有的FontPath全部改掉,首先应该先到"/usr/X11R6/lib/X11/fonts/"下看看里面含有哪些字体文件夹。

希望能够对其它遇到这个问题的朋友有所帮助。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2006-01-26 23:30

你这个是从hoary升级到breezy的问题。x系统字体路径本来就是改了的。
● 鸣学
回复

回到 “办公、图像、机械电子设计等”