当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 22 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 每次启动的时候都要校正系统的时钟,怎样才能禁用呢
帖子发表于 : 2005-06-15 13:57 

注册: 2005-06-13 11:13
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
我的网络不能直接连接国外网站,所以每次都会在同步系统始终的地方卡住,每次都要用ctrl+c来打断
能不能禁用呢?
谢谢


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-06-17 19:25 

注册: 2005-06-17 17:18
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
不会吧
一般是在.cn的 网站更新的吧
或者你可以选择国内的镜像


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-06-17 19:29 
头像

注册: 2005-05-15 3:09
帖子: 427
送出感谢: 0 次
接收感谢: 0 次
我也会在同步的地方停住,不过很快就FAIL过去了。


_________________
琴声如我


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-06-17 19:59 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
是不是在日期时间那选择了与INTETNET时间(类似这个,现在没GNOME了)同步啊?


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-06-19 0:21 
头像

注册: 2005-05-15 3:09
帖子: 427
送出感谢: 0 次
接收感谢: 0 次
我现在发觉这个同步很难搞,因为一同步成功,我的系统时间就会慢8小时,只有失败时才会正常!!!


_________________
琴声如我


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-06-19 11:14 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
就是说同步失败反而时间是正常的,那倒不如设为不要同步就好了。


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-06-19 12:02 
头像

注册: 2005-05-15 3:09
帖子: 427
送出感谢: 0 次
接收感谢: 0 次
我研究了一晚了,后来还是不得不用UTC。我的系统在启动时,从屏幕上可以看到,先从BIOS中读取时钟作为下一步启动项目的参考,过了几步(包括mount硬盘)后,就会到设置硬件时钟这一步,紧接着就是NTP时钟同步了,上网google了一下,发现好像所有Linux都会有这一步。好了, 抱着这一个同步结果,直到关机 ,也有一步是把系统时钟保存到硬件上,这样硬件时钟好像被设置了两次。这两次设置用的都是hwclock来设置,我们可以在终端下用hwclock命令来查看系统时钟,用hwclock -w来把当前系统时钟保存到硬件上。在用UTC的时候,也可以直接在图形界面下保存时钟,不过它在保存时会黑屏一会儿。


_________________
琴声如我


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2005-06-19 12:14 
头像

注册: 2005-05-15 3:09
帖子: 427
送出感谢: 0 次
接收感谢: 0 次
如果想在启动时不同步,可以把ntpdate服务禁用,但偶不懂如何禁用,但是找到了/etc/default/ntpdate文件,内容如下:
# servers to check
#NTPSERVERS="pool.ntp.org"
NTPSERVERS="ntp.ubuntulinux.org"
#
# additional options for ntpdate
#NTPOPTIONS="-v"
NTPOPTIONS="-u"
其中ntp.ubuntulinux.org就是同步到的服务器,只要把它去了,留空,就是
# servers to check
#NTPSERVERS="pool.ntp.org"
NTPSERVERS=""
#
# additional options for ntpdate
#NTPOPTIONS="-v"
NTPOPTIONS="-u"
那么在开机时就不会同步时钟了,开机不知快了多少!
如果还想同步,一是可以换了你想同步到的服务器,上GOOGLE可以查“NTP 系统时钟”找到想关的网页,里面有介绍这个服务器的,还有很多这样的服务器列表呢;二是在GNOME下在系统时间设置里开启NTP定时与网络时钟同步。


_________________
琴声如我


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2005-06-19 12:42 
头像

注册: 2005-05-15 3:09
帖子: 427
送出感谢: 0 次
接收感谢: 0 次
好像这个问题已经解决,BIOS的时钟不会相差8小时了,但在linux下用hwclock查看,比用UTC上表示的还是有8小时时差!


_________________
琴声如我


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2005-06-19 16:52 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
GOVO 写道:
好像这个问题已经解决,BIOS的时钟不会相差8小时了,但在linux下用hwclock查看,比用UTC上表示的还是有8小时时差!

我没用UTC就是这样差8小时时差的。这样,W和L的时间都一样的。


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2005-06-21 10:54 

注册: 2005-06-11 11:29
帖子: 61
送出感谢: 0 次
接收感谢: 0 次
可以使用以下命令永远禁止
sudo chmod -x /etc/init.d/ntpdate
当需要同步的时候就使用
sudo chmod +x /etc/init.d/ntpdate


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2005-08-08 8:48 

注册: 2005-07-23 13:07
帖子: 15
地址: heilongjiang
送出感谢: 0 次
接收感谢: 0 次
用update-rc.d移去NTPupdate服务,


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2005-08-16 19:15 
头像

注册: 2005-08-14 21:55
帖子: 58436
地址: 长沙
送出感谢: 4
接收感谢: 272
你想得出。
Bavon 写道:
可以使用以下命令永远禁止
sudo chmod -x /etc/init.d/ntpdate
当需要同步的时候就使用
sudo chmod +x /etc/init.d/ntpdate


这样才正确
yfms 写道:
用update-rc.d移去NTPupdate服务,


_________________
● 鸣学


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-02-01 13:07 

注册: 2005-12-28 16:23
帖子: 233
送出感谢: 0 次
接收感谢: 0 次
sudo update-rc.d -n -f NTPupdate remove


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-02-01 14:47 

注册: 2005-12-28 16:23
帖子: 233
送出感谢: 0 次
接收感谢: 0 次
好像时间还是相差8个小时哦。如何让linux和win的时间一样捏?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 22 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译