当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]急!卸载kde4.0后,再装怎么也装不上了。
帖子发表于 : 2008-01-11 22:36 
头像

注册: 2007-05-05 23:30
帖子: 562
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get --puge remove kdebase-workspace kdebase-kde4 kdebase-runtime,然后apt-get clean,然后,sudo apt-get install kdebase-workspace kdebase-kde4 kdebase-runtime
但是提示
引用:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
kdebase-kde4: 依赖: dolphin-kde4 (>= 4:4.0.0-0ubuntu1~gutsy1~ppa1) 但是它将不 会被安装
依赖: kappfinder-kde4 (>= 4:4.0.0-0ubuntu1~gutsy1~ppa1) 但是它将不会被安装
依赖: kdebase-bin-kde4 (>= 4:4.0.0-0ubuntu1~gutsy1~ppa1) 但是它 将不会被安装
依赖: kdepasswd-kde4 (>= 4:4.0.0-0ubuntu1~gutsy1~ppa1) 但是它将 不会被安装
依赖: kfind-kde4 (>= 4:4.0.0-0ubuntu1~gutsy1~ppa1) 但是它将不会 被安装
依赖: konqueror-nsplugins-kde4 (>= 4:4.0.0-0ubuntu1~gutsy1~ppa1) 但是它将不会被安装
依赖: konqueror-kde4 (>= 4:4.0.0-0ubuntu1~gutsy1~ppa1) 但是它将 不会被安装
依赖: konsole-kde4 (>= 4:4.0.0-0ubuntu1~gutsy1~ppa1) 但是它将不 会被安装
依赖: kwrite-kde4 (>= 4:4.0.0-0ubuntu1~gutsy1~ppa1) 但是它将不会被安装
依赖: libkonq5 (>= 4:4.0.0-0ubuntu1~gutsy1~ppa1) 但是它将不会被 安装
kdebase-runtime: 依赖: kdelibs5 (>= 4:4.0.0-0ubuntu1~gutsy1~ppa1) 但是它将不会被安装
依赖: libclucene0 (>= 0.9.16a-1) 但是它将不会被安装
依赖: libopenexr2c2a (>= 1.2.2) 但是它将不会被安装
依赖: libsoprano4 但是它将不会被安装
依赖: kdebase-runtime-bin-kde4 (= 4:4.0.0-0ubuntu1~gutsy1~ppa1) 但是它将不会被安装
kdebase-workspace: 依赖: kdebase-workspace-bin (>= 4:4.0.0-0ubuntu1~gutsy1~ppa1) 但是它将不会被安装
依赖: klipper-kde4 (>= 4:4.0.0-0ubuntu1~gutsy1~ppa1) 但是它将不会被安装
依赖: ksysguard-kde4 (>= 4:4.0.0-0ubuntu1~gutsy1~ppa1) 但是它将不会被安装
依赖: kwin-kde4 (>= 4:4.0.0-0ubuntu1~gutsy1~ppa1) 但是它将 不会被安装
依赖: systemsettings-kde4 (>= 4:4.0.0-0ubuntu1~gutsy1~ppa1) 但是它将不会被安装
E: 无法安装的软件包

怎么办?以前的kde3.5也不成样子了。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-01-11 22:47 
头像

注册: 2006-12-22 18:53
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
我添加源以后,直接无法安装。
不知道什么原因

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
kdebase-kde4: 依赖: kdebase-bin-kde4 (>= 4:4.0.0-0ubuntu1~gutsy1~ppa1) 但是它将不会被安装
依赖: konqueror-kde4 (>= 4:4.0.0-0ubuntu1~gutsy1~ppa1) 但是它将不会被安装
E: 无法安装的软件包


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-01-11 22:50 
头像

注册: 2007-05-05 23:30
帖子: 562
送出感谢: 0 次
接收感谢: 0 次
我已经解决了,你把那些依赖的包,全添加到install后面去吧。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-01-11 22:52 
头像

注册: 2006-10-21 12:03
帖子: 1746
地址: Shanghai
送出感谢: 0 次
接收感谢: 0 次
软件包的 release 版本号混乱所致,可能是因为发布人员还没有完全更新好,或者又有新的进来。
比如:A-1.0 依赖 B-1.0
但是由于更新,B 升级到了 2.0
而 A 还来不及 rebuild 一下,所以就出这种问题了.......
可想而知,deb 安装其实很依赖于打包者发布的时间,甚至顺序.......
这种问题一般而言,过一段时间运行一下 update 即可~


_________________
.

私人空间
附有 Magic Linux 2.1 最新开发日志~
引用:


미안하다, 사랑한다




欢迎来 #xfce-cn 中文频道~~


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-01-11 23:01 

注册: 2007-05-13 10:59
帖子: 164
送出感谢: 0 次
接收感谢: 0 次
用aptitude安装一般就能解决 :lol:


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-01-11 23:09 
头像

注册: 2006-12-22 18:53
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
lyz_new 写道:
用aptitude安装一般就能解决 :lol:


呵呵,问题解决了。谢谢


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译