[问题]我安装KDE4的时候竟然发生这样的错误

KDE桌面环境
回复
头像
SecretZero
帖子: 1670
注册时间: 2007-08-30 5:39
送出感谢: 0
接收感谢: 0
联系:

[问题]我安装KDE4的时候竟然发生这样的错误

#1

帖子 SecretZero » 2008-02-23 0:13

apt-get install kde4
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
kde4: 依赖: kde4-amusements (>= 3.2~gutsy1) 但是它将不会被安装
依赖: kdeaccessibility-kde4 (>= 4:4.0.0) 但是它将不会被安装
依赖: kdeadmin-kde4 (>= 4:4.0.0) 但是它将不会被安装
依赖: kdeartwork-kde4 (>= 4:4.0.0) 但是它将不会被安装
依赖: kdemultimedia-kde4 (>= 4:4.0.0) 但却无法安装它
依赖: kdenetwork-kde4 (>= 4:4.0.0) 但却无法安装它
依赖: kdeutils-kde4 (>= 4:4.0.0) 但却无法安装它
E: 无法安装的软件包
深度,值得深入!
http://bbs.deepin.org/?u=348684

最新的综艺魔法相册
http://www.77studio.net/?fromuid=344
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

#2

帖子 leeaman » 2008-02-23 0:18

会不会是你的源搞错了?
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
头像
SecretZero
帖子: 1670
注册时间: 2007-08-30 5:39
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 SecretZero » 2008-02-23 2:02

我用得是官方中国源阿。


555555555555我再次换了官方主服务器得源也是这样阿。
深度,值得深入!
http://bbs.deepin.org/?u=348684

最新的综艺魔法相册
http://www.77studio.net/?fromuid=344
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

#4

帖子 leeaman » 2008-02-23 11:09

试试 update upgrade再装看看
贴你的源文件出来看看
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
头像
SecretZero
帖子: 1670
注册时间: 2007-08-30 5:39
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 SecretZero » 2008-02-23 11:56

leeaman 写了:试试 update upgrade再装看看
贴你的源文件出来看看
我换了Kubunt主页上推荐的源,update再安装就成功了。
是不是ubuntu默认的源不全呢?

楼上,谢谢了。 :D
深度,值得深入!
http://bbs.deepin.org/?u=348684

最新的综艺魔法相册
http://www.77studio.net/?fromuid=344
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

#6

帖子 leeaman » 2008-02-23 12:04

换源要update一下的,源一般对个人用户只有同步快慢而已吧,一般应该全的,何况官方源呢
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
菜鸟在学习。
帖子: 2
注册时间: 2015-08-29 10:42
送出感谢: 0
接收感谢: 0

Re: [问题]我安装KDE4的时候竟然发生这样的错误

#7

帖子 菜鸟在学习。 » 2015-08-29 11:12

root@bogon:~# apt-get install kde-full
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
kdenetwork : 依赖: krdc (>= 4:4.8.4-1) 但是它将不会被安装
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。
root@bogon:~#


我也是同样的问题,还是没法解决,能够告诉一下具体怎么做。
poloshiao
论坛版主
帖子: 18273
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1948 次

Re: [问题]我安装KDE4的时候竟然发生这样的错误

#8

帖子 poloshiao » 2015-08-29 12:06

kdenetwork : 依赖: krdc (>= 4:4.8.4-1) 但是它将不会被安装
請提供 作業系統及版本
如果能加上登入桌面 更好
回复

回到 “Kubuntu”