[讨论]来诺进来,我提交的Bug 167765(关于KDE41一些程序不能输入中文的问题)

KDE桌面环境
头像
kofshower
帖子: 1343
注册时间: 2007-03-13 11:23
送出感谢: 0
接收感谢: 0
联系:

[讨论]来诺进来,我提交的Bug 167765(关于KDE41一些程序不能输入中文的问题)

#1

帖子 kofshower » 2008-08-02 12:41

正在修正,是qt4的问题

代码: 全选

Version:            (using KDE 4.1.0)
Installed from:    Ubuntu Packages

Plasma is a cool guy in KDE4.And with it ,we can create some useful Plasmoid.But these widgets have a problem.You cann't input any chinese char in it.For example,one widget can use to help us write articles in twriter.But when I use fcitx or scim(input method),I found there is nothing after i type a word.What 's the problem.
  regard


------- Additional Comment #1 From Roy Qu 2008-08-01 07:44 -------
I confirm this bug.
My system is OpenSuse 11, KDE 4.1 Factory.


------- Additional Comment #2 From Roy Qu 2008-08-01 07:46 -------
Forgotted.
My locale is zh_CN.UTF-8.


------- Additional Comment #3 From Jason Stubbs 2008-08-01 09:12 -------
Does this issue only occur with the twitter applet or does it affect all applets? For example, does the notes applet behave correctly?


------- Additional Comment #4 From Jason Stubbs 2008-08-02 04:15 -------
Just noticed in the Qt 4.4.1 changelog:

- QGraphicsProxyWidget
    * [208773] Input methods now work properly for embedded widgets.

Can you try with Qt 4.4.1 please?


------- Additional Comment #5 From Jiaqi Hu 2008-08-02 05:55 -------
I updated qt to 4.4.1.
It became possible to input with SCIM in widgets again.


------- Additional Comment #6 From Jason Stubbs 2008-08-02 06:08 -------
So it was an upstream issue that has been fixed then. Good to hear. :)


------- Additional Comment #7 From Hunch 2008-08-02 06:22 -------
thank you for reply.
-----------------------------------------------------------------
it affect all applets like the notes applet
yes,i think so
-----------------------------------------------------------------
Can you try with Qt 4.4.1 please?
thanks,i will try it again.


------- Additional Comment #8 From Hunch 2008-08-02 06:46 -------
thank you for reply.
-----------------------------------------------------------------
it affect all applets like the notes applet
yes,i think so
-----------------------------------------------------------------
Can you try with Qt 4.4.1 please?
thanks,i will try it again.
----------------------------------------------------------------
here is my env.
LANG=zh_CN.UTF-8
GNOME_KEYRING_PID=6472
KDE_SESSION_UID=1000
KDEDIRS=/usr/lib/kde4
XCURSOR_PATH=/usr/lib/kde4/share/icons::~/.icons:/usr/share/icons:/usr/share/pixmaps:/usr/X11R6/lib/X11/icons
HOME=/home/hunch
LANGUAGE=en_US

我那个时候代码跟踪到libplasma,基本确定是里面所使用api的问题。原来之前没有用过qt,昨天刚刚看了一遍
上次由 kofshower 在 2008-08-02 12:46,总共编辑 1 次。
"We are all in the mud, but some of us are looking at the stars." (Oscar Wilde)
We are not born for ourselves.
人生天地间,并非为自己
Homepage:http://sites.google.com/site/polarisnotme/
来诺
帖子: 494
注册时间: 2007-01-13 1:02
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 来诺 » 2008-08-02 12:44

头像
kofshower
帖子: 1343
注册时间: 2007-03-13 11:23
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 kofshower » 2008-08-02 12:55

代码: 全选

libQtCore.so.4.3.4
:oops:
上次由 kofshower 在 2008-08-02 13:10,总共编辑 1 次。
"We are all in the mud, but some of us are looking at the stars." (Oscar Wilde)
We are not born for ourselves.
人生天地间,并非为自己
Homepage:http://sites.google.com/site/polarisnotme/
来诺
帖子: 494
注册时间: 2007-01-13 1:02
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 来诺 » 2008-08-02 12:59

我是4.4.0
来诺
帖子: 494
注册时间: 2007-01-13 1:02
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 来诺 » 2008-08-02 13:06

头像
kofshower
帖子: 1343
注册时间: 2007-03-13 11:23
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 kofshower » 2008-08-02 13:08

yup,i see
libqt4-core (4.4.0-1ubuntu5~hardy1)
from http://packages.ubuntu.com/zh-cn/hardy- ... ibqt4-core
maybe i need compile it from source.
Here it is.
http://trolltech.com/download?target=ft ... 4.1.tar.gz
上次由 kofshower 在 2008-08-02 13:15,总共编辑 1 次。
"We are all in the mud, but some of us are looking at the stars." (Oscar Wilde)
We are not born for ourselves.
人生天地间,并非为自己
Homepage:http://sites.google.com/site/polarisnotme/
来诺
帖子: 494
注册时间: 2007-01-13 1:02
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 来诺 » 2008-08-02 13:15

这个还是4.4.0,intrepid 倒是有4.4.1的了
头像
kofshower
帖子: 1343
注册时间: 2007-03-13 11:23
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 kofshower » 2008-08-02 13:22

来诺 写了:这个还是4.4.0,intrepid 倒是有4.4.1的了
./configure -phonon -fontconfig -xcursor -opengl -verbose -qt3support
"We are all in the mud, but some of us are looking at the stars." (Oscar Wilde)
We are not born for ourselves.
人生天地间,并非为自己
Homepage:http://sites.google.com/site/polarisnotme/
来诺
帖子: 494
注册时间: 2007-01-13 1:02
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 来诺 » 2008-08-02 13:26

能不能加上intrepid的源,然后升级QT4?有没有危险?
头像
kofshower
帖子: 1343
注册时间: 2007-03-13 11:23
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 kofshower » 2008-08-02 13:34

可以,没有危险。只要只升级qt4和相关依赖。也可以从我上面的网址直接下载deb和依赖包

我自己编译有其他用处。
对了现在libplasma2和KDE41的组件又更新了。
我感觉现在整个KDE41的设计搞的他的plugin问题好多。
尤其是kwin的plugin。所以我干脆不开那个了。
apt的管理功能最好加强点,加上大包的功能。最好是一个树。我现在没用用gnome,他老是升级gnome的组件做什么
"We are all in the mud, but some of us are looking at the stars." (Oscar Wilde)
We are not born for ourselves.
人生天地间,并非为自己
Homepage:http://sites.google.com/site/polarisnotme/
来诺
帖子: 494
注册时间: 2007-01-13 1:02
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 来诺 » 2008-08-02 14:07

解决了一个,来了新的一个,
System Tray 罢工了, 不会更新了
一个程序开起来, 不会出现,然后把这个System Tray删掉,重新建一个,才能看到。。
-----------------------------------
貌似是时好时坏。。。。。
上次由 来诺 在 2008-08-02 15:24,总共编辑 1 次。
头像
kofshower
帖子: 1343
注册时间: 2007-03-13 11:23
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 kofshower » 2008-08-02 15:23

来诺 写了:解决了一个,来了新的一个,
System Tray 貌似罢工了, 不会更新了
一个程序开起来, 不会出现,然后把这个System Tray删掉,重新建一个,才能看到。。
我暂时没有这个问题,下次重启或是logout的时候我看看。刚刚编译完。你帮我看看如果卸载的话libqt4-core,会删除几个依赖。
我刚刚试了下好像有okular ,kmilo,ksudo这三个,不知道有漏了么,谢谢~
附件
1.jpeg
上次由 kofshower 在 2008-08-02 22:40,总共编辑 2 次。
"We are all in the mud, but some of us are looking at the stars." (Oscar Wilde)
We are not born for ourselves.
人生天地间,并非为自己
Homepage:http://sites.google.com/site/polarisnotme/
来诺
帖子: 494
注册时间: 2007-01-13 1:02
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 来诺 » 2008-08-02 15:28

The following actions will resolve these dependencies:

Remove the following packages:
kdesudo-kde4
kmilo-kde4
kopete-kde4
kubuntu-kde4-desktop
libqca2
okular-kde4
speedcrunch

对了,你图上那个System Tray里的无线状态是什么程序?Knetworkmanager?

Google Reader 也是1000+, 还好我没有乱订的习惯。。。嘿嘿
头像
kofshower
帖子: 1343
注册时间: 2007-03-13 11:23
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 kofshower » 2008-08-02 15:40

来诺 写了:The following actions will resolve these dependencies:

Remove the following packages:
kdesudo-kde4
kmilo-kde4
kopete-kde4
kubuntu-kde4-desktop
libqca2
okular-kde4
speedcrunch

对了,你图上那个System Tray里的无线状态是什么程序?Knetworkmanager?
是Knetworkmanager。我确认kopete-kde4我已经卸载。okular-kde4依赖的是libqca2。speedcrunch是你装的一个计算器吧。至于kubuntu-kde4-desktop这个,我没有卸载,就是说搞定了。我刚刚卸载libqt4-core的时候连带卸了上面3个
"We are all in the mud, but some of us are looking at the stars." (Oscar Wilde)
We are not born for ourselves.
人生天地间,并非为自己
Homepage:http://sites.google.com/site/polarisnotme/
来诺
帖子: 494
注册时间: 2007-01-13 1:02
送出感谢: 0
接收感谢: 0
联系:

#15

帖子 来诺 » 2008-08-02 15:46

我是直接aptitude install kubuntu-kde4-desktop的,speedcrunch估计是那时候装上去的
回复

回到 “Kubuntu”