当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]KDE 4.1.0中无法调用sudo kate, 必须调用sudo /usr/lib/kde4/bin/kate
帖子发表于 : 2008-08-31 11:01 

注册: 2006-11-27 1:00
帖子: 188
送出感谢: 0 次
接收感谢: 0 次
1. KDE 4.1.0中无法调用sudo kate, 必须调用sudo /usr/lib/kde4/bin/kate

怎么回事,难道不给root用kate???

2. 不小心把多桌面的窗口给去掉了,怎么找回来?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-08-31 11:38 

注册: 2006-09-11 22:47
帖子: 2841
送出感谢: 0 次
接收感谢: 4
Alt-F2, 然后输入 kdesudo kate 就可以了。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-09-01 14:36 

注册: 2006-11-27 1:00
帖子: 188
送出感谢: 0 次
接收感谢: 0 次
poet 写道:
Alt-F2, 然后输入 kdesudo kate 就可以了。



还是说没找到命令


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-09-01 19:32 
头像

注册: 2008-07-14 22:42
帖子: 8078
地址: Beijing
送出感谢: 0 次
接收感谢: 0 次
这么麻烦干什么。。。
启动器
sudo /usr/lib/kde4/bin/kate


_________________
Ubuntu User


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-09-01 20:44 

注册: 2005-10-15 18:20
帖子: 309
送出感谢: 0 次
接收感谢: 0 次
*ubuntu下kde4的安装路径比较奇怪
kate在gentoo下的话,会是在/usr/kde/4.1/bin下。
kde本身既有lib又有bin,居然被一股脑装在lib下,不太合理


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-09-01 22:45 

注册: 2007-01-13 1:02
帖子: 494
送出感谢: 0 次
接收感谢: 0 次
三翻领 写道:
*ubuntu下kde4的安装路径比较奇怪
kate在gentoo下的话,会是在/usr/kde/4.1/bin下。
kde本身既有lib又有bin,居然被一股脑装在lib下,不太合理



听说是为了不和KDE3.5搞混了


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-09-01 23:42 

注册: 2005-10-15 18:20
帖子: 309
送出感谢: 0 次
接收感谢: 0 次
gentoo下,/use/kde下有3.5,4.1,4.0(如果安装过)之分,这样很清除
倒是qt有点乱
qt3在/usr/qt/3目录下分lib、bin之类,而qt4的lib、bin全部归入系统的大分类下,显得没有调理


页首
 用户资料  
 
8 楼 
 文章标题 : Re: [问题]KDE 4.1.0中无法调用sudo kate, 必须调用sudo /usr/lib/kde4/bin/kate
帖子发表于 : 2008-09-01 23:47 
头像

注册: 2005-11-06 1:51
帖子: 1795
地址: 七彩云世界
送出感谢: 0 次
接收感谢: 0 次
gulch 写道:
1. KDE 4.1.0中无法调用sudo kate, 必须调用sudo /usr/lib/kde4/bin/kate

怎么回事,难道不给root用kate???

2. 不小心把多桌面的窗口给去掉了,怎么找回来?


kate-kde4不在 root 的系统路径中。。。
在 /etc/environment  或 /root/.bash 的 PATH 中添加

/usr/lib/kde4/bin/;

结果像这样:PATH="/usr/local/sbin:/usr/local/bin:.........:/usr/lib/kde4/bin"
没有 /root/.bash 中没有 PATH的话,
新加一个吧。


_________________
佛出寺,求索真世界 For_Truth:Free_Open_Share
OPEN GPG KEY:03D18D95


页首
 用户资料  
 
9 楼 
 文章标题 : Re: [问题]KDE 4.1.0中无法调用sudo kate, 必须调用sudo /usr/lib/kde4/bin/
帖子发表于 : 2008-09-06 13:40 
头像

注册: 2006-10-21 12:03
帖子: 1746
地址: Shanghai
送出感谢: 0 次
接收感谢: 0 次
fortruth 写道:
gulch 写道:
1. KDE 4.1.0中无法调用sudo kate, 必须调用sudo /usr/lib/kde4/bin/kate

怎么回事,难道不给root用kate???

2. 不小心把多桌面的窗口给去掉了,怎么找回来?


kate-kde4不在 root 的系统路径中。。。
在 /etc/environment  或 /root/.bash 的 PATH 中添加

/usr/lib/kde4/bin/;

结果像这样:PATH="/usr/local/sbin:/usr/local/bin:.........:/usr/lib/kde4/bin"
没有 /root/.bash 中没有 PATH的话,
新加一个吧。



好办法~

另:装在 /usr/lib/kde4/ 里面主要就是为了不和 kde3 的东西冲突。(除非就像 fedora 那样子,给每个程序加"4"后缀)


_________________
.

私人空间
附有 Magic Linux 2.1 最新开发日志~
引用:


미안하다, 사랑한다




欢迎来 #xfce-cn 中文频道~~


页首
 用户资料  
 
10 楼 
 文章标题 : Re: [问题]KDE 4.1.0中无法调用sudo kate, 必须调用sudo /usr/lib/kde4/bin/kate
帖子发表于 : 2008-10-04 10:20 

注册: 2007-12-13 23:34
帖子: 523
送出感谢: 0 次
接收感谢: 0 次
很多kde4的程序只能用程序名打开,不能用sudo 程序名 打开应该怎么解决呢?


页首
 用户资料  
 
11 楼 
 文章标题 : Re: [问题]KDE 4.1.0中无法调用sudo kate, 必须调用sudo /usr/lib/kde4/bin/kate
帖子发表于 : 2008-10-04 11:22 

注册: 2007-12-13 23:34
帖子: 523
送出感谢: 0 次
接收感谢: 0 次
zzd@ubuntu:~$ which kate
/usr/lib/kde4/bin//kate

修改之后还是不能用sudo kate 啊


页首
 用户资料  
 
12 楼 
 文章标题 : Re: [问题]KDE 4.1.0中无法调用sudo kate, 必须调用sudo /usr/lib/kde4/bin/kate
帖子发表于 : 2008-10-28 16:53 

注册: 2006-11-27 1:00
帖子: 188
送出感谢: 0 次
接收感谢: 0 次
dongfanglu 写道:
zzd@ubuntu:~$ which kate
/usr/lib/kde4/bin//kate

修改之后还是不能用sudo kate 啊


visudo,好像里面可以修改


页首
 用户资料  
 
13 楼 
 文章标题 : Re: [问题]KDE 4.1.0中无法调用sudo kate, 必须调用sudo /usr/lib/kde4/bin/kate
帖子发表于 : 2008-11-03 22:00 

注册: 2007-05-23 14:37
帖子: 174
送出感谢: 0 次
接收感谢: 0 次
升到8.10以后怎么样了?有人试过在线升级麽?我现在进行中。


页首
 用户资料  
 
14 楼 
 文章标题 : Re: [问题]KDE 4.1.0中无法调用sudo kate, 必须调用sudo /usr/lib/kde4/bin/kate
帖子发表于 : 2008-11-03 22:02 

注册: 2007-05-23 14:37
帖子: 174
送出感谢: 0 次
接收感谢: 0 次
不过舍不得啊,kde3晶莹剔透的感觉,kde4太靠近windows vista的风格了。。。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译