当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : apt-get or adept?
帖子发表于 : 2008-09-06 21:50 

注册: 2007-05-23 14:37
帖子: 174
送出感谢: 0 次
接收感谢: 0 次
Oftenly I tried adept and apt-get upgrade with different outcomings. Usually adept will suggest more upgrade options while apt-get upgrade just hints that there are something not upgraded and these information is likely to be missed if you just key "apt-get update & upgrade" as an everyday routine work. So if you are using kubuntu, I think it's a better idea to use adept other than apt-get upgrade.


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-09-06 22:20 

注册: 2006-09-11 22:47
帖子: 2841
送出感谢: 0 次
接收感谢: 4
Nope, you should only use adept when it's absolutely necessary. Since there is a very high risk of crash for adapt while apt-get never crashed on my computer.

Usually, you can just update everything with apt-get, and decide if you really need those things you cannot update with apt-get, then update the remaining with adept.


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-09-06 22:21 

注册: 2008-07-15 15:00
帖子: 81
送出感谢: 0 次
接收感谢: 0 次
哈哈哈,哈哈!!!!!!!!!!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-09-06 22:34 

注册: 2007-05-23 14:37
帖子: 174
送出感谢: 0 次
接收感谢: 0 次
Thanks to poet. Anyway it seems apt-get does keep back some critical packages. Just as below after I installed KDE4.01 and ran upgrade once:
引用:
The following packages have been kept back:
bind9-host dnsutils language-support-writing-en libbind9-30 libisccfg30 linux-generic linux-headers-generic
linux-image-generic linux-restricted-modules-generic ssl-cert
0 upgraded, 0 newly installed, 0 to remove and 10 not upgraded.

Do not know why. But hints from apt-get tell a lot.

And what's so funny, can you share with us Professor BugMeNot?
[/quote]


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-09-07 19:22 

注册: 2006-09-11 22:47
帖子: 2841
送出感谢: 0 次
接收感谢: 4
lenin 写道:
Thanks to poet. Anyway it seems apt-get does keep back some critical packages. Just as below after I installed KDE4.01 and ran upgrade once:
Do not know why. But hints from apt-get tell a lot.
And what's so funny, can you share with us Professor BugMeNot?


I think the "man apt-get" is very descriptive:

"New versions of currently installed packages that cannot be upgraded without changing the install status of another package will be left at their current version."

So apt-get will not upgrade those packages by default. As adept may break something after an upgrade.

btw: apt-get dist-upgrade will upgrade more packages than apt-get upgrade, you try.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译