为什么KDE不能够和gnome共存呢?

KDE桌面环境
头像
feeling
帖子: 175
注册时间: 2006-04-29 20:10
来自: 北京·昌平
送出感谢: 0
接收感谢: 0
联系:

为什么KDE不能够和gnome共存呢?

#1

帖子 feeling » 2006-05-15 15:25

我想安装KDE,结果apt-get将现有的gnome相关软件包都给删除了。
人生若只如初见,何事秋风悲画扇?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-05-15 16:05

?有这事了?
● 鸣学
头像
feeling
帖子: 175
注册时间: 2006-04-29 20:10
来自: 北京·昌平
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 feeling » 2006-05-16 10:14

哦,不是apt-get主动删除的,而是提示有冲突、是否要删除这个、安装那个什么的。
人生若只如初见,何事秋风悲画扇?
头像
renex
帖子: 269
注册时间: 2006-04-29 21:45
来自: Shanghai
送出感谢: 0
接收感谢: 0

#4

帖子 renex » 2006-05-16 10:57

具体说下什么包,好像没有这种事情吧,我都在kde里装了好些gnome程序
头像
feeling
帖子: 175
注册时间: 2006-04-29 20:10
来自: 北京·昌平
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 feeling » 2006-05-16 13:30

代码: 全选

root@ym:/etc/apt# apt-get install kubuntu-desktop
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  kubuntu-desktop: 依赖: adept 但是它将不会被安装
                   依赖: foomatic-db-hpijs 但是它将不会被安装
                   依赖: hplip-base 但是它将不会被安装
                   依赖: kde-guidance 但是它将不会被安装
                   依赖: kwin 但是它将不会被安装
                   依赖: openoffice.org2-kde 但是它将不会被安装
E: 无法安装的软件包
人生若只如初见,何事秋风悲画扇?
头像
feeling
帖子: 175
注册时间: 2006-04-29 20:10
来自: 北京·昌平
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 feeling » 2006-05-16 13:33

代码: 全选

root@ym:/etc/apt# apt-get install openoffice.org2-kde
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  openoffice.org2-kde: 依赖: openoffice.org2-core (> 1.9.129)
E: 无法安装的软件包
root@ym:/etc/apt# apt-get install openoffice.org2-core
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  openoffice.org-l10n-en-us: 依赖: openoffice.org-common (>= 2.0.2) 但是它将不会被安装 或
                                     language-support-en 但是它将不会被安装
                             依赖: openoffice.org-common (< 2.0.3) 但是它将不会被安装 或
                                     language-support-en 但是它将不会被安装
                             冲突: openoffice.org2-l10n-en-us
  openoffice.org2-core: 依赖: openoffice.org2-common (> 1.9.129)
                        依赖: openoffice.org-debian-files (>= 1.1.4-3+2ubuntu4) 但是它将不 会被安装
E: 无法安装的软件包
人生若只如初见,何事秋风悲画扇?
头像
feeling
帖子: 175
注册时间: 2006-04-29 20:10
来自: 北京·昌平
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 feeling » 2006-05-16 13:48

这个又是什么意思呢?

代码: 全选

root@ym:~# del openoffice.org-common
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  openoffice.org-l10n-en-us: 依赖: openoffice.org-common (>= 2.0.2) 但是它将不会被安装 或
                                     language-support-en 但是它将不会被安装
                             依赖: openoffice.org-common (< 2.0.3) 但是它将不会被安装 或
                                     language-support-en 但是它将不会被安装
  openoffice.org-l10n-zh-cn: 依赖: openoffice.org-common (>= 2.0.2) 但是它将不会被安装 或
                                     language-support-zh 但是它将不会被安装
                             依赖: openoffice.org-common (< 2.0.3) 但是它将不会被安装 或
                                     language-support-zh 但是它将不会被安装
  openoffice.org-l10n-zh-tw: 依赖: openoffice.org-common (>= 2.0.2) 但是它将不会被安装 或
                                     language-support-zh 但是它将不会被安装
                             依赖: openoffice.org-common (< 2.0.3) 但是它将不会被安装 或
                                     language-support-zh 但是它将不会被安装
E: 无法安装的软件包
人生若只如初见,何事秋风悲画扇?
头像
feeling
帖子: 175
注册时间: 2006-04-29 20:10
来自: 北京·昌平
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 feeling » 2006-05-16 14:02

代码: 全选

root@ym:~# get x-common
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
下列软件包将被【卸载】:
  acpi-support anjuta appres at-spi beforelight bitmap blt bluefish bug-buddy dbus
  dia-common dia-gnome editres eog epiphany-browser evince evolution fcitx file-roller
  firefox flashplayer-mozilla freeglut3 fstobdf gaim gcalctool gconf-editor gdm
  gdm-themes gedit gimp gimp-print gimp-python gksu gnome-about
  gnome-accessibility-themes gnome-applets gnome-applets-data gnome-control-center
  gnome-core gnome-cups-manager gnome-desktop-environment gnome-games gnome-gv
  gnome-icon-theme gnome-keyring gnome-mag gnome-media gnome-netstatus-applet
  gnome-nettool gnome-panel gnome-power-manager gnome-session gnome-system-monitor
  gnome-system-tools gnome-terminal gnome-themes gnome-themes-extras gnome-utils
  gnome-volume-manager gnomemeeting gnumeric gnumeric-common gs-common gs-esp gsfonts-x11
  gstreamer0.10-plugins-base gstreamer0.10-x gstreamer0.8-misc gstreamer0.8-vorbis
  gstreamer0.8-x gtk2-engines-clearlooks gtk2-engines-crux gtk2-engines-highcontrast
  gtk2-engines-industrial gtk2-engines-lighthouseblue gtk2-engines-mist
  gtk2-engines-pixbuf gtk2-engines-redmond95 gtk2-engines-smooth
  gtk2-engines-spherecrystal gtk2-engines-thinice gtk2-engines-ubuntulooks gtkhtml3.8
  gucharmap hal iceauth ico kdelibs-bin kdelibs4c2 language-selector libaa1 libarts1c2
  libatspi1.0-0 libaudio2 libbonoboui2-0 libcairo2 libdmx1 libedataserverui1.2-6
  libeel2-2 libexo0.3-0 libfontenc1 libfs6 libgail-common libgail17 libgd2-noxpm
  libgimp2.0 libgksu1.2-0 libgksuui1.0-0 libgl1-mesa libgl1-mesa-dri libglade2-0 libglew1
  libglu1-mesa libglut3 libgnome-desktop-2 libgnome-keyring0 libgnome2-canvas-perl
  libgnomecanvas2-0 libgnomecupsui1.0-1 libgnomeprint2.2-0 libgnomeprintui2.2-0
  libgnomeui-0 libgoffice-1 libgtk1.2 libgtk2-perl libgtk2.0-0 libgtk2.0-bin
  libgtk2.0-common libgtkhtml2-0 libgtkhtml3.8-15 libgtksourceview1.0-0 libgtkspell0
  libgucharmap4 libgutenprintui2-1 libice6 liblaunchpad-integration0 liblpint-bonobo0
  libmagick9 libmetacity0 libnautilus-burn2 libnautilus-extension1 libopal-2.2.0
  libopenh323-1.15.3c2 libpanel-applet2-0 libpango1.0-0 libpango1.0-common
  libpoppler0c2-glib libpoppler1-glib libpt-1.8.3c2 libpt-plugins-alsa libpt-plugins-v4l
  libqt3-mt librsvg2-2 librsvg2-common libscim8c2a libsdl1.2debian libsdl1.2debian-alsa
  libsexy2 libsm6 libstartup-notification0 libtotem-plparser0 libvte4 libwmf0.2-7
  libwnck18 libx11-6 libxau6 libxaw7 libxcursor1 libxdamage1 libxdmcp6 libxext6
  libxfcegui4-3 libxfixes3 libxfont1 libxft2 libxi6 libxinerama1 libxkbfile1
  libxklavier10 libxmu6 libxmuu1 libxp6 libxpm4 libxrandr2 libxrender1 libxres1 libxss1
  libxt6 libxtrap6 libxtst6 libxv1 libxxf86dga1 libxxf86misc1 libxxf86vm1 listres
  mesa-utils metacity mozilla-firefox-locale-zh-cn mozilla-firefox-locale-zh-tw nautilus
  nautilus-cd-burner notification-daemon oclock planner powermanagement-interface
  python-epydoc python-gd python-glade2 python-gst0.10 python-gtk2
  python-launchpad-integration python-tk python-unit python-vte python2.4-cairo
  python2.4-epydoc python2.4-gd python2.4-glade2 python2.4-gtk2 python2.4-tk
  python2.4-unit qterm rdesktop rhythmbox rss-glx scim scim-chewing scim-gtk2-immodule
  scim-modules-socket scim-modules-table scim-pinyin scim-tables-zh smproxy sodipodi
  sound-juicer ssh-askpass-gnome synaptic tangerine-icon-theme tk8.4 totem
  totem-gstreamer ttf-arphic-ukai ttf-arphic-uming ttf-kochi-gothic ttf-kochi-mincho
  ttf-thai-tlwg ubuntu-artwork unifont update-manager viewres vino wine x-ttcidfont-conf
  x-window-system-core x11-common x11perf xauth xbase-clients xbiff xcalc xclipboard
  xclock xconsole xcursorgen xditview xdpyinfo xdriinfo xev xeyes xf86dga xfce4-terminal
  xfd xfonts-100dpi xfonts-75dpi xfonts-base xfonts-scalable xfonts-utils xfontsel xgamma
  xgc xhost xinit xkbutils xkeyboard-config xkill xload xlogo xlsatoms xlsclients
  xlsfonts xmag xman xmessage xmms xmodmap xmore xorg-driver-fglrx xpmutils xprop xrandr
  xrdb xrefresh xsane xscreensaver xscreensaver-data xscreensaver-gl xserver-xorg
  xserver-xorg-core xserver-xorg-driver-all xserver-xorg-driver-apm
  xserver-xorg-driver-ark xserver-xorg-driver-ati xserver-xorg-driver-chips
  xserver-xorg-driver-cirrus xserver-xorg-driver-cyrix xserver-xorg-driver-dummy
  xserver-xorg-driver-fbdev xserver-xorg-driver-glint xserver-xorg-driver-i128
  xserver-xorg-driver-i740 xserver-xorg-driver-i810 xserver-xorg-driver-imstt
  xserver-xorg-driver-mga xserver-xorg-driver-newport xserver-xorg-driver-nsc
  xserver-xorg-driver-nv xserver-xorg-driver-rendition xserver-xorg-driver-s3
  xserver-xorg-driver-s3virge xserver-xorg-driver-savage xserver-xorg-driver-sis
  xserver-xorg-driver-sisusb xserver-xorg-driver-tdfx xserver-xorg-driver-tga
  xserver-xorg-driver-trident xserver-xorg-driver-tseng xserver-xorg-driver-v4l
  xserver-xorg-driver-vesa xserver-xorg-driver-vga xserver-xorg-driver-via
  xserver-xorg-driver-vmware xserver-xorg-input-all xserver-xorg-input-elographics
  xserver-xorg-input-evdev xserver-xorg-input-synaptics xserver-xorg-input-wacom xset
  xsetmode xsetpointer xsetroot xsm xstdcmap xterm xtrap xutils xvidtune xvinfo
  xvncviewer xwd xwininfo xwud yelp zenity
下列【新】软件包将被安装:
  x-common
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 363 个软件包,有 0 个软件未被升级。
需要下载 19.3kB 的软件包。
解压缩后将会空出 789MB 的空间。
您希望继续执行吗?[Y/n]n
中止执行。
人生若只如初见,何事秋风悲画扇?
ltkun
帖子: 1335
注册时间: 2006-01-10 19:09
送出感谢: 0
接收感谢: 0

#9

帖子 ltkun » 2006-05-16 15:08

kde和gnome我同时都装了 不可能不能共存的
mars4117
帖子: 14
注册时间: 2006-03-20 16:28
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 mars4117 » 2006-05-16 18:36

我也两个都装了,可以共存的
头像
feeling
帖子: 175
注册时间: 2006-04-29 20:10
来自: 北京·昌平
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 feeling » 2006-05-17 9:19

是不是跟我之前升级过gnome有关啊!?
之前有几个软件包出现问题,重新安装时更新了相关的许多软件包。
人生若只如初见,何事秋风悲画扇?
tninja
帖子: 9
注册时间: 2006-05-17 0:36
送出感谢: 0
接收感谢: 0

#12

帖子 tninja » 2006-05-17 23:57

我的情况跟你一样,也是装不了kubuntu,前面有一次gnome出了问题修复过,估计跟这个有关系。
头像
feeling
帖子: 175
注册时间: 2006-04-29 20:10
来自: 北京·昌平
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 feeling » 2006-05-18 9:13

tninja 写了:我的情况跟你一样,也是装不了kubuntu,前面有一次gnome出了问题修复过,估计跟这个有关系。
可找到同志了,眼泪哗哗的...

我也是之前升级过gnome,然后就这样了。
人生若只如初见,何事秋风悲画扇?
tninja
帖子: 9
注册时间: 2006-05-17 0:36
送出感谢: 0
接收感谢: 0

克服debian的软件包依赖问题

#14

帖子 tninja » 2006-05-18 17:05

ubuntu上安装kubuntu和xubuntu成功!

前几天一直都想装kubuntu,但apt一直报告要装的话就要卸载整个gnome和相关软件,这我可不干。昨天看了poptang的kubuntu以后实在忍不住,就仔细研究一下是为什么:明明X能启动为何kubuntu和ubuntu不能共存?别人都能共存的。仔细检查以后发现我原先的x-common包等被替换成了x11-common,而kde依赖于x-common,现在还没法替换回来(不然要删除很多包)。debian的依赖关系检查非常严格,明明x11-common包括x-common的功能,但apt就是不让装kde。于是我就去查修改依赖关系的文章,果然找到一篇,要从.deb文件入手。
http://www.linuxsir.org/bbs/showthread.php?t=251027
下载了kde的关键包libxcomposite1,类似上文所述方法修改其依赖为x11-common并重新打包,先dpkg -i后,apt-get install kubuntu-desktop,一切顺利,成功!
意犹未尽,把本来不能装的xubuntu也装上了。
头像
feeling
帖子: 175
注册时间: 2006-04-29 20:10
来自: 北京·昌平
送出感谢: 0
接收感谢: 0
联系:

Re: 克服debian的软件包依赖问题

#15

帖子 feeling » 2006-05-22 13:28

tninja 写了:ubuntu上安装kubuntu和xubuntu成功!

前几天一直都想装kubuntu,但apt一直报告要装的话就要卸载整个gnome和相关软件,这我可不干。昨天看了poptang的kubuntu以后实在忍不住,就仔细研究一下是为什么:明明X能启动为何kubuntu和ubuntu不能共存?别人都能共存的。仔细检查以后发现我原先的x-common包等被替换成了x11-common,而kde依赖于x-common,现在还没法替换回来(不然要删除很多包)。debian的依赖关系检查非常严格,明明x11-common包括x-common的功能,但apt就是不让装kde。于是我就去查修改依赖关系的文章,果然找到一篇,要从.deb文件入手。
http://www.linuxsir.org/bbs/showthread.php?t=251027
下载了kde的关键包libxcomposite1,类似上文所述方法修改其依赖为x11-common并重新打包,先dpkg -i后,apt-get install kubuntu-desktop,一切顺利,成功!
意犹未尽,把本来不能装的xubuntu也装上了。
不错!
我就没这么聪明了,老老实实的卸载掉了之前更新的内容,然后安装了kubuntu、xfce两个桌面。
人生若只如初见,何事秋风悲画扇?
回复

回到 “Kubuntu”