无线网络连接不上,但在ubuntu下却能连接上。

KDE桌面环境
回复
fengran
帖子: 3
注册时间: 2008-11-21 4:42
送出感谢: 0
接收感谢: 0

无线网络连接不上,但在ubuntu下却能连接上。

#1

帖子 fengran » 2008-11-25 11:45

各位好,

我的机子是东芝L40,网卡 AR5007eg,对于Linux没什么了解。我在装ubuntu8.10时,由于声卡和网卡不能用,在论坛上看了几个帖子,很快就一切正常。前两天由于贪恋kubuntu的新的kde4.1版本,就换成了kubuntu,可是没想到换了之后我虽然按照以前的方法安装驱动,但还是上不了网。我按照的方法如会员 wubinghui888 所写:
无线网卡类型为Atheros AR5007EG Wireless Network Adapter,
先在受限的驱动里将无线网卡的选中状态去除,重启之后。
sudo apt-get install build-essential (如果原先的无线网卡系统没有自动安装驱动可以省去此步骤)
下载驱动http://snapshots.madwifi.org/special/madwifi-ng-r2756+ar5007.tar.gz
之后再tar xfz madwifi-ng-r2756+ar5007.tar.gz
cd madwifi-ng-r2756+ar5007
make
sudo make install
sudo modprobe ath_pci
sudo reboot

这一系列操作在ubuntu下没有问题,重启后就能上网了,但是在kubuntu下如果停止系统自带的网卡硬件驱动,我的电脑就找不到无线网络,一旦把系统里的硬件驱动(atheros的驱动)重新激活,我的网卡就能找到网络,但却无法配置网络密码及ip地址。图标显示在尝试着链接,但就连接不上。但如果转到windows系统里就能连接上。为什么它找到了网络却连接不上呢?不知道各位有什么方法?
我装的是madwifi-hal-0.10.5.6-20081105,谢谢了。
或者各位能否向我推荐一个方便好用的网络配置软件?能让我连上网。
由于只能用windows上网,不能够在kubuntu下下载和更新软件。真是很麻烦。

还有就是声卡,在ubuntu下我只用在mixer下面调一下设置就可以了,但在kunbu下面调了也没用,不知谁能帮帮我。

再一次感谢
头像
jimhu
帖子: 1322
注册时间: 2006-01-25 22:29
来自: 上海
送出感谢: 0
接收感谢: 0
联系:

Re: 无线网络连接不上,但在ubuntu下却能连接上。

#2

帖子 jimhu » 2008-11-26 19:45

Kubuntu附带的Knetworkmanager简直就是灾难。

这个东西不能设置静态IP地址,不能加入任何加密的WPA无线网络。。。其他的我也没有测试过,Bug也早就提交了,不知道开发人员在想什么,这么致命的错误居然可以安然存在这么久。
* MACBOOK MB063CH/B
OS:Snow Leopard/XP
* AMD X2 3600+/2G RAM/160GB+500GB Seagate/7300GT
OS:Arch/Vista

Kubuntu User #18899

=================================
Full Circle中文杂志 | Ubuntu社区独立发行的电子月刊
http://www.freeearth.org.cn
回复

回到 “Kubuntu”