当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [求助]无法用APT和adept installer 安装程序
帖子发表于 : 2009-02-10 21:59 

注册: 2007-07-08 10:31
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
在一次安装DEB包中意外死机之后,现在无法用APT和adept installer 安装任何程序。
尝试安装程序时会出现如下的错误信息:

1)adept installer:
--------------------------------------------------------
下载失败.
已附上错误列表. 对该错误的恢复功能尚未实现. 如果出现 404错误, 尝试获取安装包列表(见"源代码"标签)并重试操作可能有助于解决问题.

错误:
APT Error. Context:
Package download failed,
我无法找到对应 ooobasis3.0-core03 软件包的文件。在这种情况下您可能需要手动修正这个软件包。,
: ,
: ,
: ,
:
----------------------------------------------------------

2)APT:
----------------------------------------------------------
mooli@mooli-laptop:~$ sudo apt-get install unrar ”安装任何包结果都一样
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
E: 软件包 ooobasis3.0-core03 需要重新安装,但是我无法找到相应的安装文件。
----------------------------------------------------------

请教大家怎么解决!


最后由 mooli 编辑于 2009-02-11 22:03,总共编辑了 2 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: [求助]无法用APT和adept installer 安装程序
帖子发表于 : 2009-02-10 22:02 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
aptitude update
aptitude reinstall ooobasis3.0-core03


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: [求助]无法用APT和adept installer 安装程序
帖子发表于 : 2009-02-11 22:00 

注册: 2007-07-08 10:31
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
非常感谢BigSnake.NET兄的帮助!
问题仍然存在。好像在我的计算机里已经找不到“软件包: ooobasis3.0-core03”,虽然它已经被部分安装了!(真奇怪!)
我想可不可以(怎么样)干脆把安装了一半的“软件包: ooobasis3.0-core03”删除掉。(既然用不了这个包,我可以删除吧,这个逻辑应该可行)
请抽空帮帮忙!嘿嘿!

----------------------------------------------------------------------------------------------------------------------------------
mooli@mooli-laptop:~$ sudo aptitude show ooobasis3.0-core03
软件包: ooobasis3.0-core03
状态: 部分安装
自动安装:
版本号: 3.0.0-9
优先级: 不可用
部分: 不可用
维护者: OpenOffice.org
未压缩尺寸: 152k
依赖于: ooobasis3.0-core01
描述: Office core module for OpenOffice.org 3.0
Copyright: 1999-2007 by OpenOffice.org Office core module for OpenOffice.org
3.0
----------------------------------------------------------------------------------------------------------------------------------



----------------------------------------------------------------------------------------------------------------------------------
mooli@mooli-laptop:~$ sudo aptitude download ooobasis3.0-core03
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
正在读取扩展状态文件
正在初始化软件包状态... 完成
E: ooobasis3.0-core03 版本 3.0.0-9 没有可下载的文件;也许它是一个本地软件包或者过期的软件包?
----------------------------------------------------------------------------------------------------------------------------------



----------------------------------------------------------------------------------------------------------------------------------
mooli@mooli-laptop:~$ sudo aptitude reinstall ooobasis3.0-core03
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
正在读取扩展状态文件
正在初始化软件包状态... 完成
下列软件包将被“重新安装”:
ooobasis3.0-core03
下列软件包将被“删除”:
( 省略)
0 个软件包被升级,新安装0 个, 1 个被重新安装, 16 个将被删除, 同时 49 个将不升级。
需要获取 0B 的存档。 解包后将释放 58.2MB。
您要继续吗?[Y/n/?] y
E: 我无法找到对应 ooobasis3.0-core03 软件包的文件。在这种情况下您可能需要手动修正这个软件包。
正在编辑扩展状态信息... 完成
E: 我无法找到对应 ooobasis3.0-core03 软件包的文件。在这种情况下您可能需要手动修正这个软件包。
E: 内部错误:无法生成下载软件包列表

----------------------------------------------------------------------------------------------------------------------------------


页首
 用户资料  
 
4 楼 
 文章标题 : Re: [求助]无法用APT和adept installer 安装程序
帖子发表于 : 2009-02-16 10:30 

注册: 2007-07-08 10:31
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
怎么弄啊! :em20


页首
 用户资料  
 
5 楼 
 文章标题 : Re: [求助]无法用APT和adept installer 安装程序
帖子发表于 : 2009-04-17 23:51 

注册: 2008-10-31 22:12
帖子: 6546
系统: 践兔
送出感谢: 18
接收感谢: 25
代码:
sudo apt-get remove ooobasis3.0-core03
sudo apt-get -f install


_________________
代码:
] ls -ld //


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译