当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 郁闷,libqt4-core版本问题[已解决]
帖子发表于 : 2009-03-05 20:03 
头像

注册: 2008-04-26 12:41
帖子: 10974
送出感谢: 11
接收感谢: 38
virtualbox用的libqt4-core和libqt4-gui是4.3.4版本的(8.04上),但是为了装lyx 1.6.1的deb包,不得不装上了依赖的libqt4-core和libqt4-gui的4.4.4版本deb包。
现在lyx是可以正常运行,但是virtualbox运行提示不能处理混合版本的libqt4库,界面起不来,如何解决? :em20


_________________
[新手必读]wubi安装常见问题(FAQ)
[分享]装双系统的同学必看——Windows与Linux系统共享交换分区的方法
kde下唯美的暗黑内透主题(无需编译)
无穷老机上的Trinity Desktop Environment


最后由 photor 编辑于 2009-03-26 21:09,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 郁闷,libqt4-core版本问题
帖子发表于 : 2009-03-22 11:16 
头像

注册: 2008-04-26 12:41
帖子: 10974
送出感谢: 11
接收感谢: 38
这么久了,真的没人知道? :em20


_________________
[新手必读]wubi安装常见问题(FAQ)
[分享]装双系统的同学必看——Windows与Linux系统共享交换分区的方法
kde下唯美的暗黑内透主题(无需编译)
无穷老机上的Trinity Desktop Environment


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 郁闷,libqt4-core版本问题
帖子发表于 : 2009-03-22 11:52 
头像

注册: 2007-10-23 12:54
帖子: 1689
送出感谢: 0 次
接收感谢: 13
首先 vbox 的依赖是 >= 4.3.4,并不排斥 4.4 ,完全可以把整个 libqt4 升级避免出现混合。

其次 lyx 的依赖是 >= 4.4.0,并不需要 4.4.4,不明白从哪里混源装上的。

最后,两者的依赖交点是 >= 4.4.0,这个在 hardy 的源里是存在的。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 郁闷,libqt4-core版本问题
帖子发表于 : 2009-03-26 21:06 
头像

注册: 2008-04-26 12:41
帖子: 10974
送出感谢: 11
接收感谢: 38
已经搞定了……感谢!
首帖里写错了,是4.4.0版的。我的lyx 1.6.1是自己下载deb包装的,结果出现如上问题。
后来把源hardy-backports勾上了,将全套libqt4升级成4.4.0就解决了。
不过不敢一直用这个“不支持的更新”,怕有其它毛病,又把它去掉了,反正问题已经解决 :em09


_________________
[新手必读]wubi安装常见问题(FAQ)
[分享]装双系统的同学必看——Windows与Linux系统共享交换分区的方法
kde下唯美的暗黑内透主题(无需编译)
无穷老机上的Trinity Desktop Environment


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译