当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : koffice-kde4不能满足依赖关系
帖子发表于 : 2009-04-20 21:59 

注册: 2008-10-31 22:12
帖子: 6546
系统: 践兔
送出感谢: 18
接收感谢: 25
出错信息:
代码:
tusooa@tusooa-laptop:~$ sudo apt-get install koffice-kde4
[sudo] password for tusooa:                             
正在读取软件包列表... 完成                               
正在分析软件包的依赖关系树                               
正在读取状态信息... 完成                                 
koffice-kde4 已经是最新的版本了。                       
您可能需要运行“apt-get -f install”来纠正下列错误:       
下列的软件包有不能满足的依赖关系:                       
  koffice-kde4: 依赖: kpresenter-kde4 (>= 1:1.9.99.9-0ubuntu1) 但是它将不会被安装                                                                             
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。                                                           
tusooa@tusooa-laptop:~$ sudo apt-get install kpresenter-kde4                   
正在读取软件包列表... 完成                                                     
正在分析软件包的依赖关系树                                                     
正在读取状态信息... 完成                                                       
下列软件包是自动安装的并且现在不再被使用了:                                   
  libglib-perl python-gst0.10 libntfs10 kdevelop-doc kivio-data jfsutils       
  libgfortran3 libboost-program-options1.34.1 ttf-kannada-fonts python-numeric 
  xutils libgnome2-perl python-pyorbit python-gconf libmaildir4 python2.5-dbg   
  libsuitesparse-3.1.0 python2.5-dev libglide2 libavformat52 libamrnb3         
  python-gtkhtml2 xfsprogs libamrwb3 libgnome2-vfs-perl python-sexy             
  ttf-telugu-fonts python-vte libvte9 libgtk2-perl libgtkhtml2-0               
  python-launchpad-integration libblas3gf ntfsprogs liblapack3gf               
  gnome-icon-theme ttf-oriya-fonts libpoppler-qt2 libcairo-perl                 
  ttf-bengali-fonts libvte-common librsvg2-common libpqxx-2.6.9ldbl             
  libgnome2-canvas-perl kpresenter-data libpoppler-glib3 xutils-dev             
使用'apt-get autoremove'来删除它们                                             
建议安装的软件包:                                                             
  koffice-doc-html-kde4                                                         
推荐安装的软件包:                                                             
  libkscan1-kde4                                                               
下列【新】软件包将被安装:                                                     
  kpresenter-kde4                                                               
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 1 个软件未被升级。                                                                             
有 1 个软件包没有被完全安装或卸载。                                             
需要下载 0B/403kB 的软件包。                                                   
解压缩后会消耗掉 1581kB 的额外空间。                                           
(正在读取数据库 ... 系统当前总共安装有 225573 个文件和目录。)                   
正在解压缩 kpresenter-kde4 (从 .../kpresenter-kde4_1%3a1.9.99.9-0ubuntu1_i386.deb) ...                                                                         
dpkg:处理 /var/cache/apt/archives/kpresenter-kde4_1%3a1.9.99.9-0ubuntu1_i386.deb (--unpack)时出错:                                                           
 正试图覆盖“/usr/share/pixmaps/kpresenter.xpm”,它属于软件包 kpresenter-data   
dpkg-deb: 子进程 paste 被信号(Broken pipe)终止了                               
在处理时有错误发生:                                                           
 /var/cache/apt/archives/kpresenter-kde4_1%3a1.9.99.9-0ubuntu1_i386.deb         
E: Sub-process /usr/bin/dpkg returned an error code (1)                         
tusooa@tusooa-laptop:~$ sudo apt-get -f install
正在读取软件包列表... 完成                     
正在分析软件包的依赖关系树                     
正在读取状态信息... 完成                       
正在更正依赖关系... 完成
下列软件包是自动安装的并且现在不再被使用了:
  libglib-perl python-gst0.10 libntfs10 kdevelop-doc kivio-data jfsutils
  libgfortran3 libboost-program-options1.34.1 ttf-kannada-fonts python-numeric
  xutils libgnome2-perl python-pyorbit python-gconf libmaildir4 python2.5-dbg
  libsuitesparse-3.1.0 python2.5-dev libglide2 libavformat52 libamrnb3
  python-gtkhtml2 xfsprogs libamrwb3 libgnome2-vfs-perl python-sexy
  ttf-telugu-fonts python-vte libvte9 libgtk2-perl libgtkhtml2-0
  python-launchpad-integration libblas3gf ntfsprogs liblapack3gf
  gnome-icon-theme ttf-oriya-fonts libpoppler-qt2 libcairo-perl
  ttf-bengali-fonts libvte-common librsvg2-common libpqxx-2.6.9ldbl
  libgnome2-canvas-perl kpresenter-data libpoppler-glib3 xutils-dev
使用'apt-get autoremove'来删除它们
将会安装下列额外的软件包:
  kpresenter-kde4
建议安装的软件包:
  koffice-doc-html-kde4
推荐安装的软件包:
  libkscan1-kde4
下列【新】软件包将被安装:
  kpresenter-kde4
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 1 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B/403kB 的软件包。
解压缩后会消耗掉 1581kB 的额外空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 225573 个文件和目录。)
正在解压缩 kpresenter-kde4 (从 .../kpresenter-kde4_1%3a1.9.99.9-0ubuntu1_i386.deb) ...
dpkg:处理 /var/cache/apt/archives/kpresenter-kde4_1%3a1.9.99.9-0ubuntu1_i386.deb (--unpack)时出错:
 正试图覆盖“/usr/share/pixmaps/kpresenter.xpm”,它属于软件包 kpresenter-data
dpkg-deb: 子进程 paste 被信号(Broken pipe)终止了
在处理时有错误发生:
 /var/cache/apt/archives/kpresenter-kde4_1%3a1.9.99.9-0ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
tusooa@tusooa-laptop:~$
怎么解决

PS:刚才服务器500错误了500 - Internal Server Error


_________________
代码:
] ls -ld //


页首
 用户资料  
 
2 楼 
 文章标题 : Re: koffice-kde4不能满足依赖关系
帖子发表于 : 2009-05-02 18:39 
头像

注册: 2006-10-21 12:03
帖子: 1746
地址: Shanghai
送出感谢: 0 次
接收感谢: 0 次
等待源更新.... - -


_________________
.

私人空间
附有 Magic Linux 2.1 最新开发日志~
引用:


미안하다, 사랑한다




欢迎来 #xfce-cn 中文频道~~


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译