当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 所有软件皆是这样安装不上的
帖子发表于 : 2009-09-07 16:14 

注册: 2009-07-11 9:40
帖子: 106
送出感谢: 0 次
接收感谢: 0 次
csq@csq:~$ sudo su
root@csq:/home/csq# apt-get install ntfs-3g
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
ntfs-3g 已经是最新的版本了。
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
language-pack-kde-zh-hans: 依赖: language-pack-kde-zh-hans-base (>= 1:9.10+20090826) 但是它将不会被安装
依赖: language-pack-zh-hans-base (>= 1:9.10+20090826) 但是它将不会被安装
language-pack-kde-zh-hant: 依赖: language-pack-kde-zh-hant-base (>= 1:9.10+20090826) 但是它将不会被安装
依赖: language-pack-zh-hant-base (>= 1:9.10+20090826) 但是它将不会被安装
language-pack-zh-hans: 依赖: language-pack-zh-hans-base (>= 1:9.10+20090826) 但是它将不会被安装
language-pack-zh-hant: 依赖: language-pack-zh-hant-base (>= 1:9.10+20090826) 但是它将不会被安装

E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
root@csq:/home/csq#

以上是Kubuntu9.10 alpha5的系统
我用apt-get 安装软件都会有这个问题,请教下老鸟们,这个问题怎么解决呢?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 所有软件皆是这样安装不上的
帖子发表于 : 2009-09-07 16:17 
头像

注册: 2008-02-03 18:53
帖子: 665
送出感谢: 0 次
接收感谢: 1
源混了, 9.04就只能用9.04的源,楼主应是混用过源。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 所有软件皆是这样安装不上的
帖子发表于 : 2009-09-07 16:17 

注册: 2009-07-11 9:40
帖子: 106
送出感谢: 0 次
接收感谢: 0 次
现在我Windows分区“挂”不上。
这个问题解决不了,什么事情也作不了
之前Fedora11也是这样的问题。
要怎么解决这个依赖问题呢?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 所有软件皆是这样安装不上的
帖子发表于 : 2009-09-07 16:18 

注册: 2009-07-11 9:40
帖子: 106
送出感谢: 0 次
接收感谢: 0 次
我的是9.10的alternative的光盘刻起来安装的阿
怎么会混源呢
难道是我要的软件都不支持9.10?没道理啊


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 所有软件皆是这样安装不上的
帖子发表于 : 2009-09-07 16:23 

注册: 2009-07-11 9:40
帖子: 106
送出感谢: 0 次
接收感谢: 0 次
再举个例子

csq@csq:~$ sudo apt-get install mplayer
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
language-pack-kde-zh-hans: 依赖: language-pack-kde-zh-hans-base (>= 1:9.10+20090826) 但是它将不会被安装
依赖: language-pack-zh-hans-base (>= 1:9.10+20090826) 但是它将不会被安装
language-pack-kde-zh-hant: 依赖: language-pack-kde-zh-hant-base (>= 1:9.10+20090826) 但是它将不会被安装
依赖: language-pack-zh-hant-base (>= 1:9.10+20090826) 但是它将不会被安装
language-pack-zh-hans: 依赖: language-pack-zh-hans-base (>= 1:9.10+20090826) 但是它将不会被安装
language-pack-zh-hant: 依赖: language-pack-zh-hant-base (>= 1:9.10+20090826) 但是它将不会被安装
mplayer: 依赖: mplayer-skin
依赖: mplayer-nogui 但是它将不会被安装
依赖: libesd-alsa0 (>= 0.2.35) 但是它将不会被安装 或
libesd0 (>= 0.2.35)
依赖: libfaac0 (>= 1.26) 但是它将不会被安装
依赖: libjack0 (>= 0.116.1) 但是它将不会被安装
依赖: liblircclient0 但是它将不会被安装
依赖: liblzo2-2 但是它将不会被安装
依赖: libopenal1 但是它将不会被安装
依赖: libsvga1
依赖: libswscale0 (>= 3:0.svn20090303-1) 但是它将不会被安装 或
libswscale-extra-0 (>= 3:0.svn20090303-1) 但是它将不会被安装


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 所有软件皆是这样安装不上的
帖子发表于 : 2009-09-07 16:24 
头像

注册: 2008-02-03 18:53
帖子: 665
送出感谢: 0 次
接收感谢: 1
提示
代码:
apt-get -f install


杯具了,如果源没混,等高手吧


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 所有软件皆是这样安装不上的
帖子发表于 : 2009-09-07 17:23 
头像

注册: 2005-08-01 9:14
帖子: 3666
送出感谢: 0 次
接收感谢: 0 次
为什么现在人都不看提示呢 :em23


_________________
Gedanken ohne Inhalt sind leer .Anschauungen ohne Begriffe sind blind.


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 所有软件皆是这样安装不上的
帖子发表于 : 2009-09-07 17:44 
头像

注册: 2008-04-14 23:29
帖子: 2114
地址: 曾也在NB大学呆过
送出感谢: 3
接收感谢: 10
hethe 写道:
为什么现在人都不看提示呢 :em23

现代人有几个会在买了东西后看说明书的?


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 所有软件皆是这样安装不上的
帖子发表于 : 2009-09-07 17:47 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
引用:
现代人有几个会在买了东西后看说明书的?

某家是古人,某每次买新东西,总是索要说明书,使用之前一定会看几遍说明书。。。结果某被淘汰了。。。 :em19

楼主可以把源表贴出来瞧瞧,看下有没有混源。某的台机也是用AlterCD新装的Kub910,格式化分区全新安装的,用的是杭洲源。 :em02


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译