当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 不能更换指针主题,有谁碰到过这种情况吗(已解决)
帖子发表于 : 2006-09-02 21:41 

注册: 2006-09-01 21:41
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
现象如下:
更换指针主题后重启:
1。登录后在splash screen发现指针被正确更换
2。进入桌面,指针恢复成默认的黑色
3。点注销,发现指针是之前设定的主题,点取消回到桌面,指针又恢复默认

不知道哪个程序引起的,郁闷阿
4。新发现。在帮助中心的窗口范围内也是正常的


代码:
解决方法:
因为发现新建用户没有问题,且指针在进入kde环境后才出现上述问题,故比较两个用户.kde/share/config,目录里配置。发现解决方法.
1.打开~/.kde/share/config/kcminputrc
2。[Mouse]段原来为
[Mouse]
Acceleration=2
MouseButtonMapping=RightHanded
ReverseScrollPolarity=false
Threshold=4
cursorTheme=PolarCursorTheme-Blue

删除仅留下cursorTheme行
然后就ok了


最后由 kcsn 编辑于 2006-09-05 12:17,总共编辑了 4 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-09-02 21:44 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
在 .Xdefault里面设置是最可靠的。你的情况没碰到过。


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-09-02 22:59 

注册: 2006-09-01 21:41
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
出现情况很飘,有时候在kde程序窗口范围会正常,但是到其他地方总是不正常

我说的不正常,就是指针和在gdm(我比较喜欢gdm)或kdm(我试过问题照旧)里的指针一样,但是进gnome就没辙问题。

请问你说的.Xdefault在哪


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-09-02 23:12 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
你编辑一次 .Xdefaults,可以增加一个主题设置。

! ---| X11 settings |--- {{{
Xcursor.theme: redglass
!Xcursor.theme: Chameleon-Pearl-Large-0.5
!Xcursor.theme: blueprint-cursor-theme
!Xcursor.theme: jimmac
!Xcursor.theme: jimmac_new
!Xcursor.theme: Grounation
!Xcursor.theme: mac_os_x_like_cursors
Xcursor.size: 64
!}}}

下次启动x,就会得到一个完整的 .Xdefaults文件了。


_________________
● 鸣学


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-09-03 13:43 

注册: 2006-09-01 21:41
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
i will google it


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-09-03 14:55 

注册: 2006-09-01 21:41
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
可以参考一下这篇文章
http://wiki.archlinux.org/index.php/X11_Cursors

但是我还是没解决我的问题
我发现我在/usr/share/icons/里面找不到我现在出现的指针主题(黑色的),因此我感觉问题应该不是出在这里


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-09-03 15:04 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
~/.icon也有啊。看置顶的debian手册里面有说明没。中文的。


_________________
● 鸣学


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-09-03 15:24 

注册: 2006-09-01 21:41
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
~/.icon是用户的,/usr/share/icons是同用的,我知道

现在发现新线索,我用新建的用户登录kde,更换指针。发现完全正常。说明。。。
还得继续研究


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-09-03 15:45 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
我都被你转晕了。你的问题到底是什么了哦。 :lol:


_________________
● 鸣学


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-09-03 17:19 

注册: 2006-09-01 21:41
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
我也晕了
算了,我现在新建了个用户,然后偷天大法~~~


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-09-03 17:21 

注册: 2006-09-01 21:41
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
你正好在,能不能看一下这个
http://forum.ubuntu.org.cn/viewtopic.php?t=7058


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译