当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 升级到Kubuntu 9.10,重启后自动进入tty2终端登录,KDM登录界面没有出现
帖子发表于 : 2009-10-31 20:15 

注册: 2008-05-07 14:30
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
今天,使用了七个小时,好不容易从Kubuntu 9.04 通过更新提醒升级到 Kubuntu 9.10 ,但是重新启动后,没有出现KDM的登录界面,只能出现终端登录,这可如何是好!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 升级到Kubuntu 9.10,重启后自动进入tty2终端登录,KDM登录界面没有出现
帖子发表于 : 2009-10-31 20:16 
头像

注册: 2008-08-20 18:33
帖子: 1484
地址: 泰达希尔
送出感谢: 0 次
接收感谢: 0 次
代码:
startx

或者
代码:
sudo kdm

试试,怀疑你显卡驱动问题根本启动不了x
你最好还是用kub9.10重新装下把,ub9.10升级都有一堆问题,何况kub了。


_________________
qiibeta@twitter.com

我是心之所在,你好,世界

I,KDE


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 升级到Kubuntu 9.10,重启后自动进入tty2终端登录,KDM登录界面没有出现
帖子发表于 : 2009-10-31 20:26 

注册: 2008-05-07 14:30
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
谢了!好像确实是图形界面闪了一下,可能是尝试后失败了,才到终端的。ubuntu 这次升级可不怎么顺利。哎,更新的太多太大了,兼容性问题暴露了。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 升级到Kubuntu 9.10,重启后自动进入tty2终端登录,KDM登录界面没有出现
帖子发表于 : 2009-10-31 20:49 

注册: 2008-10-31 17:45
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
还是新安装吧,升级出来或多或少都有问题的


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 升级到Kubuntu 9.10,重启后自动进入tty2终端登录,KDM登录界面没有出现
帖子发表于 : 2009-10-31 21:37 

注册: 2008-05-07 14:30
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
确实是显卡驱动的问题,
输入:startx
出现了一堆信息,其中有两条错误:
(EE) Failed to load module "ati" (module does not exist, 0)
(EE) No drivers available

难道升级还会把之前的安装的驱动给删了?


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 升级到Kubuntu 9.10,重启后自动进入tty2终端登录,KDM登录界面没有出现
帖子发表于 : 2009-10-31 23:59 

注册: 2008-10-31 22:12
帖子: 6546
系统: 践兔
送出感谢: 18
接收感谢: 25
代码:
sudo ldconfig

或者
代码:
sudo dpkg-reconfig* xserver-xorg


_________________
代码:
] ls -ld //


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 升级到Kubuntu 9.10,重启后自动进入tty2终端登录,KDM登录界面没有出现
帖子发表于 : 2009-11-01 15:07 

注册: 2008-05-07 14:30
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
请问6楼的tusooa,兄台:

引用:
代码:
sudo dpkg-reconfig* xserver-xorg


这是什么意思呀? 是不是命令有误?

输入: sudo ldconfig
没有任何反应。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 升级到Kubuntu 9.10,重启后自动进入tty2终端登录,KDM登录界面没有出现
帖子发表于 : 2009-11-01 16:48 

注册: 2008-05-07 14:30
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
:em11 问题基本是解决了!

问题出在了xorg.conf 文件中:
代码:
Section "Device"
   Identifier   "ATI Radeon 9600"
   Driver          "ati"
   Option          "XAANoOffscreenPixmaps"
   Option          "AccelMethod"    "EXA"
   Option          "ColorTiling"    "on"
   Option          "AccelDFS"       "true"
   Option          "DMAForXv"       "true"
   Option          "GARTSize"       "128"
   BusID           "PCI:1:0:0"
EndSection


之前使用的是 “ati” 开源驱动,可这次升级后那个软件包就没有了,改成“radeon”就行了!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译