当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 刚装的kubuntu10.4下,dragon player有声音没有图像
帖子发表于 : 2010-08-27 13:36 

注册: 2007-08-26 10:35
帖子: 294
地址: 上海
送出感谢: 0 次
接收感谢: 0 次
装了个mplayer也是一样,avi和rmvb都是一样。
复制了一段用mplayer播放的日志:
代码:
[aaron@BesTV:~/video]$ mplayer \[古墓迷途\].Back.in.Time.2008.CN.DVDRip.Xvid-XTM.cd1.avi
MPlayer SVN-r1.0~rc3+svn20090426-4.4.3 (C) 2000-2009 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing [古墓迷途].Back.in.Time.2008.CN.DVDRip.Xvid-XTM.cd1.avi.
AVI file format detected.
[aviheader] Video stream found, -vid 0
[aviheader] Audio stream found, -aid 1
VIDEO:  [XVID]  624x336  12bpp  25.000 fps  1881.3 kbps (229.6 kbyte/s)
Clip info:
 Software: VirtualDubMod 1.5.10.1 (Build 2366/Release)
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
[VO_TDFXFB] Can't open /dev/fb0: Permission denied.
[VO_3DFX] Unable to open /dev/3dfx.
Opening video filter: [screenshot]
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
AO: [pulse] Init failed: Connection refused
Failed to initialize audio driver 'pulse'
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
[mpeg4 @ 0x8f3bc00]Invalid and inefficient vfw-avi packed B frames detected
VDec: vo config request - 624 x 336 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.86:1 - prescaling to correct movie aspect.
[swscaler @ 0x850900]No accelerated colorspace conversion found.
[swscaler @ 0x850900]using unscaled yuv420p -> rgb24 special converter
VO: [xv] 624x336 => 624x336 Planar YV12
A:   1.8 V:   1.8 A-V: -0.000 ct: -0.006  46/ 46  5%  1%  0.9% 0 0
Exiting... (Quit)



页首
 用户资料  
 
2 楼 
 文章标题 : Re: 刚装的kubuntu10.4下,dragon player有声音没有图像
帖子发表于 : 2010-08-28 12:07 

注册: 2010-08-28 12:05
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
可能是wincodes解码器没安装。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 刚装的kubuntu10.4下,dragon player有声音没有图像
帖子发表于 : 2010-08-30 9:31 

注册: 2007-08-26 10:35
帖子: 294
地址: 上海
送出感谢: 0 次
接收感谢: 0 次
后来发现是切换双屏造成的,单屏模式下播放没问题。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 刚装的kubuntu10.4下,dragon player有声音没有图像
帖子发表于 : 2010-08-30 13:02 

注册: 2007-08-26 10:35
帖子: 294
地址: 上海
送出感谢: 0 次
接收感谢: 0 次
又发现,双屏状态下也可以,两个屏幕都调分辨率为1024*768就可以。在向上调高分辨率就不行了。但我的最高分辨率是1280*800和1280*1024。

不仅如此,双屏的调节也要tnnd分步来,一个调高之后,确定,再调高另一个。不然就自动注销让你重新登录。

下次换个发行版试试。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 刚装的kubuntu10.4下,dragon player有声音没有图像
帖子发表于 : 2010-09-06 15:03 

注册: 2010-08-27 16:03
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
刚发帖子,有两个解决办法,我是安装了realplayer的Linux版本,这样你多了一个播放器,但是,dragon player也可以播放了。要不就安装wincodes的解码库。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译