安装kde时出现的包依赖问题

KDE桌面环境
回复
easing
帖子: 18
注册时间: 2006-08-11 17:27
送出感谢: 0
接收感谢: 0
联系:

安装kde时出现的包依赖问题

#1

帖子 easing » 2006-12-22 12:44

这是它的显示:
sudo apt-get install kubuntu-desktop
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
dirmngr: 依赖: libpth2 但是它将不会被安装
gnupg-agent: 依赖: libpth2 但是它将不会被安装
gpgsm: 依赖: libpth2 但是它将不会被安装
kubuntu-desktop: 依赖: adept 但是它将不会被安装
依赖: amarok 但是它将不会被安装
依赖: bogofilter 但是它将不会被安装
依赖: example-content 但是它将不会被安装
依赖: gtk2-engines-gtk-qt 但是它将不会被安装
依赖: gwenview 但是它将不会被安装
依赖: k3b 但是它将不会被安装
依赖: kaffeine-xine 但是它将不会被安装
依赖: katapult 但是它将不会被安装
依赖: kde-guidance 但是它将不会被安装
依赖: kde-systemsettings 但是它将不会被安装
依赖: kdebluetooth 但是它将不会被安装
依赖: kdenetwork-filesharing 但是它将不会被安装
...........
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

最主要的是这个libpth.so库,好像是它阻止了后面的程序无法安装。这是它的显示:
正在解压缩 libpth2 (从 .../libpth2_2.0.1-2.1_i386.deb) ...
dpkg:处理 /var/cache/apt/archives/libpth2_2.0.1-2.1_i386.deb (--unpack)时出错: 正试图覆盖“/usr/lib/libpth.so.20.0.21”,它属于软件包 zhcon-dubuntu
dpkg-deb: 子进程 paste 被信号(Broken pipe)终止了
在处理时有错误发生:
/var/cache/apt/archives/libpth2_2.0.1-2.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

请问怎么解决,谢谢!
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 zhan » 2006-12-22 12:53

卸载 zhcon-dubuntu 然后再安装。
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
easing
帖子: 18
注册时间: 2006-08-11 17:27
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 easing » 2006-12-22 15:02

多谢。
zhan 写了:卸载 zhcon-dubuntu 然后再安装。
回复

回到 “Kubuntu”