当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 死活安装不了plasma-desktop
帖子发表于 : 2016-06-16 21:57 
头像

注册: 2009-01-18 23:26
帖子: 296
送出感谢: 4
接收感谢: 0 次
sudo apt-get install plasma-desktop
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
plasma-desktop : 依赖: kactivities 但是它将不会被安装
依赖: plasma-workspace 但是它将不会被安装
推荐: kinfocenter 但是它将不会被安装
推荐: kscreen 但是它将不会被安装
推荐: ksysguard 但是它将不会被安装
推荐: powerdevil 但是它将不会被安装


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 死活安装不了plasma-desktop
帖子发表于 : 2016-06-16 22:20 
头像

注册: 2011-03-20 13:12
帖子: 4551
地址: 山东省寿光县
系统: Debian
送出感谢: 106
接收感谢: 1009
执行以下指令将结果全部复制贴上来
代码:
cat /etc/os-release
cat /etc/apt/sources.list
cat /etc/apt/sources.list.d/*


_________________
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 死活安装不了plasma-desktop
帖子发表于 : 2016-06-17 6:41 
头像

注册: 2009-01-18 23:26
帖子: 296
送出感谢: 4
接收感谢: 0 次
1.cat /etc/os-release
NAME="Ubuntu"
VERSION="16.04 LTS (Xenial Xerus)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 16.04 LTS"
VERSION_ID="16.04"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
UBUNTU_CODENAME=xenial


2.cat /etc/apt/sources.list
# added by the release upgrader
# deb cdrom:[Lubuntu 16.04 LTS _Xenial Xerus_ - Release amd64 (20160420)]/ xenial main multiverse restricted universe
#
# deb cdrom:[Lubuntu 15.10 _xenial Werewolf_ - Release amd64 (20151021)]/ xenial main multiverse restricted universe
# deb cdrom:[Lubuntu 15.10 _xenial Werewolf_ - Release amd64 (20151021)]/ xenial main multiverse restricted universe
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://mirrors.sohu.com/ubuntu/ xenial main restricted
deb-src http://mirrors.sohu.com/ubuntu/ xenial main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://mirrors.sohu.com/ubuntu/ xenial-updates main restricted
deb-src http://mirrors.sohu.com/ubuntu/ xenial-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://mirrors.sohu.com/ubuntu/ xenial universe
deb-src http://mirrors.sohu.com/ubuntu/ xenial universe
deb http://mirrors.sohu.com/ubuntu/ xenial-updates universe
deb-src http://mirrors.sohu.com/ubuntu/ xenial-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://mirrors.sohu.com/ubuntu/ xenial multiverse
deb-src http://mirrors.sohu.com/ubuntu/ xenial multiverse
deb http://mirrors.sohu.com/ubuntu/ xenial-updates multiverse
deb-src http://mirrors.sohu.com/ubuntu/ xenial-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.

deb http://mirrors.sohu.com/ubuntu/ xenial-security main restricted
deb-src http://mirrors.sohu.com/ubuntu/ xenial-security main restricted
deb http://mirrors.sohu.com/ubuntu/ xenial-security universe
deb-src http://mirrors.sohu.com/ubuntu/ xenial-security universe
deb http://mirrors.sohu.com/ubuntu/ xenial-security multiverse
deb-src http://mirrors.sohu.com/ubuntu/ xenial-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu xenial partner
# deb-src http://archive.canonical.com/ubuntu xenial partner


# deb http://ppa.launchpad.net/gnome3-team/gn ... ing/ubuntu xenial main
# deb-src http://ppa.launchpad.net/gnome3-team/gn ... ing/ubuntu xenial main


deb http://ppa.launchpad.net/joe-yasi/kde5/ubuntu xenial main

deb-src http://ppa.launchpad.net/joe-yasi/kde5/ubuntu xenial main

deb http://ppa.launchpad.net/canonical-qt5- ... 551/ubuntu xenial main

deb-src http://ppa.launchpad.net/canonical-qt5- ... 551/ubuntu xenial main

3.cat /etc/apt/sources.list.d/*
deb http://ppa.launchpad.net/c.falco/mame/ubuntu xenial main
# deb-src http://ppa.launchpad.net/c.falco/mame/ubuntu xenial main
deb http://ppa.launchpad.net/c.falco/mame/ubuntu xenial main
# deb-src http://ppa.launchpad.net/c.falco/mame/ubuntu xenial main
# deb http://ppa.launchpad.net/dolphin-emu/ppa/ubuntu xenial main
# deb-src http://ppa.launchpad.net/dolphin-emu/ppa/ubuntu xenial main
# deb http://ppa.launchpad.net/dolphin-emu/ppa/ubuntu xenial main
# deb-src http://ppa.launchpad.net/dolphin-emu/ppa/ubuntu xenial main
deb http://ppa.launchpad.net/glennric/dolphin-emu/ubuntu xenial main
# deb-src http://ppa.launchpad.net/glennric/dolphin-emu/ubuntu xenial main
# deb-src http://ppa.launchpad.net/glennric/dolphin-emu/ubuntu xenial main
deb http://ppa.launchpad.net/glennric/dolphin-emu/ubuntu xenial main
# deb-src http://ppa.launchpad.net/glennric/dolphin-emu/ubuntu xenial main
# deb-src http://ppa.launchpad.net/glennric/dolphin-emu/ubuntu xenial main
deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu xenial main
# deb-src http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu xenial main
deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu xenial main
# deb-src http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu xenial main
deb http://ppa.launchpad.net/wine/wine-builds/ubuntu xenial main
# deb-src http://ppa.launchpad.net/wine/wine-builds/ubuntu xenial main
# deb-src http://ppa.launchpad.net/wine/wine-builds/ubuntu xenial main
deb http://ppa.launchpad.net/wine/wine-builds/ubuntu xenial main
# deb-src http://ppa.launchpad.net/wine/wine-builds/ubuntu xenial main
# deb-src http://ppa.launchpad.net/wine/wine-builds/ubuntu xenial main


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 死活安装不了plasma-desktop
帖子发表于 : 2016-06-17 7:35 

注册: 2009-08-04 16:33
帖子: 17155
送出感谢: 21
接收感谢: 1856
http://www.noobslab.com/2016/05/upgrade ... -5-in.html
Upgrade/Install Latest KDE Plasma 5 in Kubuntu 16.04/Ubuntu 16.04 Xenial
By Umair Riaz at May 30, 2016

Ubuntu 16.04 Xenial
To install latest KDE Plasma 5 desktop in Ubuntu 16.04 Xenial open Terminal (Press Ctrl+Alt+T) and copy the following commands in the Terminal:
代码:
sudo add-apt-repository ppa:kubuntu-ppa/backports
sudo apt-get update
sudo apt-get install kubuntu-desktop


Kubuntu 16.04 Xenial
To upgrade to latest KDE Plasma 5 desktop in Kubuntu 16.04 Xenial open Terminal and copy the following commands in the Terminal:
代码:
sudo add-apt-repository ppa:kubuntu-ppa/backports
sudo apt-get update
sudo apt-get dist-upgrade


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 死活安装不了plasma-desktop
帖子发表于 : 2016-06-17 13:38 
头像

注册: 2009-01-18 23:26
帖子: 296
送出感谢: 4
接收感谢: 0 次
不行,也是依赖问题


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 死活安装不了plasma-desktop
帖子发表于 : 2016-06-17 15:07 

注册: 2009-08-04 16:33
帖子: 17155
送出感谢: 21
接收感谢: 1856
引用:
也是依赖问题

1. 養成好習慣
安裝任何套件以前
先把你的系統已安裝套件更新到最新版本
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade # 選項 新手要謹慎
再安裝新套件
可以把出現相依套件或版本不滿足情形降低到最少

2. 如果你的 /etc/apt/sources.list 下載伺服器 本身落後更新進度太久
那麼縱使你執行 1 的步驟以後 你的系統內已安裝套件 也非最新版本
2-1. 意思是 如果一直出現相依套件或版本不滿足情形
建議 更換你的 /etc/apt/sources.list 下載伺服器
2-1-1. 更換到 下述 下載伺服器名單內 任一地區的任一下載伺服器
優先選擇 最右欄位是綠色字 Up to date
https://launchpad.net/ubuntu/+archivemirrors
當然 選擇區域 / 也要考慮網路速度 Gbps/Mbps
2-1-2. 例如 當下時間
Tsinghua University
https://launchpad.net/ubuntu/+mirror/mi ... cn-archive
最右欄位是綠色字 Up to date
http://mirrors.tuna.tsinghua.edu.cn/ubuntu/
2-2. 如果還是無效 看看你是否使用 proxy
把 proxy 暫時關閉看看
引用:
不行,也是依赖问题

3. 最後 拿手鐧
先把相依套件或版本不滿足的套件 一個一個手動安裝妥當
再回頭安裝原來要安裝的套件
此時 要特別注意 版本
引用:
下列软件包有未满足的依赖关系:
plasma-desktop : 依赖: kactivities 但是它将不会被安装
依赖: plasma-workspace 但是它将不会被安装
推荐: kinfocenter 但是它将不会被安装
推荐: kscreen 但是它将不会被安装
推荐: ksysguard 但是它将不会被安装
推荐: powerdevil 但是它将不会被安装

4. @vickycq
請幫忙分析
viewtopic.php?p=3168622#p3168622


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译