kdelibs4与kdelibs4c2a的区别?

KDE桌面环境
回复
wentrue
帖子: 21
注册时间: 2007-03-09 20:20
送出感谢: 0
接收感谢: 0

kdelibs4与kdelibs4c2a的区别?

#1

帖子 wentrue » 2007-05-07 11:58

我是一个ubuntu6.10(edgy)+gnome的新手,有些涉及到KDE的问题比较疑惑,特来请教。

我下载了一个软件,有DEB包和源文件。
该软件的说明为:
requires KDE >= 3.1, QT >= 3.1 and libxml2 >= 2.5.4

我先双击DEB包安装,提示:
Dependency is not satisfiable: kdelibs4

然后我在“新立得软件包管理“里找kdelibs4(cn99的源),没找到完全匹配的,只有kdelibs4c2a,kdelibs4-dev。
于是我把两个都装了,其中的依赖关系都已帮我解决安装。为求稳妥,我把kdelibs也一并安装了。
不过我实在不知道kdelibs4、kdelibs4c2a、kdelibs都有些什么关系?看它们的说明也看不出什么。

双击DEB包,同样的问题依旧存在。
尝试用源码安装,在make时就出现了一堆问题,失败。。。

只好又回头去解决kdelibs4的问题,由于在包管理器里找不到,就直接上网搜,
在ubuntu的官方源里找到了,http://packages.ubuntulinux.org/hoary/libs/kdelibs4
只是下载速度很慢。而且是归属于Hoary版本的,依赖的包也很多,实在不知道下载安装是否真有作用?

在包管理器里同时发现了kdelibs5,好像是用于KDE4的,太没经验了,实在不了解。

需要说明的是:我要装的软件比较旧,最后一次更新在2004年1月。
wentrue
帖子: 21
注册时间: 2007-03-09 20:20
送出感谢: 0
接收感谢: 0

#2

帖子 wentrue » 2007-05-07 16:19

sign...
总算把kdelibs4下载下来,果然还是有问题。
提示libarts1没安装,估计还有很多别的依赖关系。

在新立得里查找结果发现有libarts1c2a和libarts1-dev已经安装(可能是之前安装kdelibs4c2a时装上的),
但没有发现libarts1。

实在郁闷,**c2a系列和**是什么关系?如果前者是后者的升级版,为什么对软件的支持却无法兼容?
vvvli
帖子: 441
注册时间: 2006-10-26 7:02
送出感谢: 0
接收感谢: 0

Re: kdelibs4与kdelibs4c2a的区别?

#3

帖子 vvvli » 2007-05-09 1:24

kde4还没做好,源里的能用运气就好了..用外面的死都不知道怎么死.....
回复

回到 “Kubuntu”