当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 急问,apt-get有没有办法忽略某个包引起的冲突?
帖子发表于 : 2005-11-09 1:28 
头像

注册: 2005-10-25 8:44
帖子: 233
送出感谢: 0 次
接收感谢: 0 次
splashy和kubuntu难道就没有办法共存? T_T

代码:
root@mjxian ~
# dpkg -i --auto-deconfigure splashy_0.1.5.svn4_i386.deb
dpkg:为了 splashy,正准备删除usplash ...
dpkg:好的,为了 splashy 我将删除 usplash。
(正在读取数据库 ... 系统当前总共安装有 72839 个文件和目录。)
正在解压缩 splashy (从 splashy_0.1.5.svn4_i386.deb) ...
正在抹去 kubuntu-desktop 的设置信息,只有这样我们才能删除 usplash ...
正在设置 splashy (0.1.5.svn4) ...
Searching for GRUB installation directory ... found: /boot/grub .
Testing for an existing GRUB menu.list file... found: /boot/grub/menu.lst .
Searching for splash image... none found, skipping...
Found kernel: /boot/vmlinuz-2.6.12-9-386
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done


dpkg:依赖关系问题使得 kubuntu-desktop 的配置工作不能继续:
kubuntu-desktop 依赖于 usplash;然而:
软件包 usplash还没有被安装。
dpkg:处理 kubuntu-desktop (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
kubuntu-desktop

root@mjxian ~
# apt-get install usplash
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
splashy: 冲突: usplash 但是 0.1-22 正要被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

root@mjxian ~
# apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在更正依赖关系... 完成
将会安装下列的额外的软件包:
usplash
下列软件包将被【卸载】:
splashy
下列【新】软件包将被安装:
usplash
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 1 个软件包,有 0 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 32.8kB 的软件包。
解压缩后将会空出 401kB 的空间。
您希望继续执行吗?[Y/n]n
中止执行。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-11-09 1:31 
头像

注册: 2005-10-25 8:44
帖子: 233
送出感谢: 0 次
接收感谢: 0 次
或者有没有办法让kunbuntu忽略掉对usplash对依赖性?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译