当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : kubuntu 中的 kopete 不支持 gtalk's voice call 的原因
帖子发表于 : 2007-08-28 22:03 
头像

注册: 2006-10-21 12:03
帖子: 1746
地址: Shanghai
送出感谢: 0 次
接收感谢: 0 次
一个在心里头想了很久的问题。。
就是 kubuntu 中的 kopete 不支持 gtalk 的语音对话功能。。。
是个很遗憾的事情,但原因呢?
下面来看看 #kubuntu-devel 里的开发者是怎样回答的吧~

代码:
[21:13] --> 您已经加入了频道 #kubuntu-devel (n=nihui@58.34.87.144)。
[21:13] *** 频道话题是“Welcome to #kubuntu-devel | Bugs! https://launchpad.net/~kubuntu-team/+packagebugs | KDE 4.0 beta 1 -- http://kubuntu.org/announcements/kde4-beta1.php | Tribe 5 out”。
[21:13] *** 由 Riddell 设定关于 2007年08月24日 05时58分53秒 的话题。
[21:13] *** 频道模式: 没有外部消息, 不允许颜色
[21:13] *** 频道已建立在 2006年11月26日 14时42分43秒。
[21:13] --> Lie_Ex 已经加入此频道 (n=Lie_Ex@222.71.216.98)。
[21:14] <-- Knightlust 已经离开了此服务器 ("leaving")。
[21:14] <_StefanS_> Tonio_: since the last version, I cant configure my mouse anymore. It complains about it cant create the input device
[21:17] <nihui> Riddell: Tonio_: Why doesn't the gtalk in kopete have "voice call" function?
[21:17] <Tonio_> _StefanS_: hu ?
[21:17] <nihui> may i have the reason please?
[21:17] <Tonio_> nihui: we don't build it with libjingle I guess....
[21:17] <_StefanS_> Tonio_: I can see my bt mouse, but clicking the "setup" button yields a dialog with the message that It can create the inpu tdevice
[21:18] <Tonio_> _StefanS_: need to test that toonight, no bt mouse here
[21:18] <_StefanS_> oka
[21:18] <Tonio_> nixternal: what is the malone status for "rejected" now ? is that "won't fix" or "invalid" ?
[21:19] <nihui> Tonio_: but why don't you built it with that? i think the "voice call" is really great~
[21:20] <freeflying> Tonio_: won't fix and invalid
[21:20] <Tonio_> freeflying: both ? oki
[21:20] --> viviersf 已经加入此频道 (n=cain@gw.impilinux.co.za)。
[21:20] <Tonio_> nihui: because the lib is in universe, and we try not to get too much lib in main
[21:22] <Tonio_> nihui: btw a "main" package cannot build-depend on a universe one
[21:22] <Tonio_> nihui: too late in the gutsy dev cycle to get that done, but we may consider this for gutsy+1 then
[21:22] <freeflying> Tonio_: both
[21:23] <Hobbsee> nihui: ahh, i know the answer to this.
[21:23] <Tonio_> Hobbsee: ah ? :)
[21:23] <nihui> Hobbsee: ?
[21:23] <Tonio_> nihui: also the voice support in kopete isn't really stable atm
[21:23] <Hobbsee> nihui: because gtalk only works with a particular version of libjingle, and we have a later version in ubuntu, which other things depend on.
[21:24] <Hobbsee> tha'ts the main reason that i havent put it in.
[21:24] <Hobbsee> and getting an obsolete vesrion of a library in main....even the thought of that is painful.
[21:24] <freeflying> Hobbsee: nihui wonders why other distribution supports  :)
[21:24] <Tonio_> Hobbsee: interesting
[21:25] <Tonio_> Hobbsee: so the libjingle version we have is incompatible with gtalk ?
[21:25] <Hobbsee> freeflying: because it's not commercial support, and they dont care about having multiple libraries.
[21:25] <Hobbsee> Tonio_: it was when i last checked (when it was first announced), yes
[21:25] <Tonio_> Hobbsee: okay
[21:25] <manchicken> Anybody ever got a webcam working in kubuntu before?
[21:26] <Tonio_> nihui: also according to kopete devs, they will not have a nice and stable gtalk support before kde4/phonon
[21:26] <freeflying> manchicken: webcam is not spcific to kubuntu
[21:26] <Tonio_> Hobbsee: looks like phonon is meant to support jingle, I didn't knew that
[21:26] <manchicken> freeflying: This I know.  But system76 claims this guy works under gnome, and I'm having a hard time configuring it in kubuntu.
[21:26] <freeflying> Tonio_: how dose phonon support jingle?
[21:27] <Tonio_> freeflying: no idea that was on the blog of a kopete dev
[21:27] <manchicken> Hmm...
[21:27] <Tonio_> freeflying: he was explaining that the jingle support within libjingle is a bit crackfull, and that this would change with kde4/phonon
[21:28] <freeflying> manchicken: borrow me one, I will configure it for you :)
[21:28] <freeflying> Tonio_: sounds nice


先理清一下:
Tonio_:首先,编译 kopete 的 gtalk 的 voice call 支持,必须依赖 libjingle 这个库的编译。
而 kubuntu 的 kopete 并没有依赖这个库,所以就没有语音功能了。
libjingle 这个库是 universe 的,而开发者并不想引入过多的额外库依赖。
一个 "main" 软件包不能依赖于一个 universe 软件包编译。
kubuntu 7.10 gutsy 的开发周期已经不允许那么大的变动工作了,不过可能 gusty 之后会纳入这个功能支持。

Hobbsee:gtalk 只能在一个特定版本的 libjingle 下运作,而我们在 ubuntu 中只有比较新的版本,其他软件包需要依赖新版本的库。
在 Hobbsee 最新一次核实的时候确认了,当前已有的 libjingle 版本和 gtalk 所需的是冲突的,无法使用。
其他发行版之所以可以有 voice call 功能是因为它们不是商业支持,所以它们不用关心多版本库的重叠。

Tonio_:在 kde4/phonon 之前的 gtalk 支持不是很好且不太稳定。

好了,原因很清楚了:编译语音支持需要一个陈旧版本的 libjingle,而当前是新的。同时使用多个版本可以达到目的,但是商业支持不允许这么做。

http://shuizhuyuanluo.blog.163.com/blog ... 2895625965


_________________
.

私人空间
附有 Magic Linux 2.1 最新开发日志~
引用:


미안하다, 사랑한다




欢迎来 #xfce-cn 中文频道~~


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-08-28 22:56 
头像

注册: 2005-12-08 16:53
帖子: 212
送出感谢: 0 次
接收感谢: 0 次
在频道里没看清楚你们的对话,Tonio的回答里有个概念很可能弄混了。那个libjingle根本不是什么额外的依赖,它是包含在Kopete源码里的。那个有版本冲突的东西根据对话来看其实还是实时通讯协议栈的库oRTP,它才是一个外部依赖。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-08-29 19:25 
头像

注册: 2006-10-21 12:03
帖子: 1746
地址: Shanghai
送出感谢: 0 次
接收感谢: 0 次
oRTP

似乎的确是这东西。。。
:wink:

他们还说什么 libjingle..... 怪不得我自己的系统里面没找到这个包。。 :D


_________________
.

私人空间
附有 Magic Linux 2.1 最新开发日志~
引用:


미안하다, 사랑한다




欢迎来 #xfce-cn 中文频道~~


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译