当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 关于用compiz-fusion代替kwin
帖子发表于 : 2007-11-21 15:48 
头像

注册: 2007-05-05 23:11
帖子: 694
送出感谢: 2
接收感谢: 0 次
装了compiz-fusion后,好像KDE启动时还是先启动kwin,几秒钟后才换成compiz。能不能让它直接启动compiz?


最后由 bearscafe 编辑于 2007-11-23 20:48,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-11-21 16:11 
头像

注册: 2006-06-01 11:01
帖子: 182
送出感谢: 0 次
接收感谢: 0 次
好像不能吧???kwin就是普通的x窗口……


_________________
find,sed,awk


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-11-21 16:18 
头像

注册: 2007-05-05 23:11
帖子: 694
送出感谢: 2
接收感谢: 0 次
purpleice 写道:
好像不能吧???kwin就是普通的x窗口……

不是啊,当启动了compiz后,可以ps -e一下,可以看到是没有kwin进程的。但如果不启动compiz,ps -e一下就可以看到kwin进程。compiz把kwin替换了,就像gnome下metacity被替换了一样。
我是想,既然gnome可以选择窗口管理器(metacity,sawfish等),kde应该也能吧?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-11-21 16:22 
头像

注册: 2006-06-01 11:01
帖子: 182
送出感谢: 0 次
接收感谢: 0 次
真的不太清楚!对cf不感冒!


_________________
find,sed,awk


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-11-21 16:34 
头像

注册: 2005-12-08 16:53
帖子: 212
送出感谢: 0 次
接收感谢: 0 次
KDEWM这个环境变量可以指定KDE要使用哪个窗口管理器,只要在KDE启动前这个环境变量存在就有效。

嫌麻烦直接添加到/etc/environment里就行了(KDEWM=/path/to/compiz)。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-11-21 16:40 
头像

注册: 2006-06-01 11:01
帖子: 182
送出感谢: 0 次
接收感谢: 0 次
学习了……还是千里厉害啊……


_________________
find,sed,awk


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-11-21 17:34 
头像

注册: 2007-05-05 23:11
帖子: 694
送出感谢: 2
接收感谢: 0 次
千里孤坟 写道:
KDEWM这个环境变量可以指定KDE要使用哪个窗口管理器,只要在KDE启动前这个环境变量存在就有效。

嫌麻烦直接添加到/etc/environment里就行了(KDEWM=/path/to/compiz)。


谢谢~
但发现这样一个问题:把KDEWM设为"compiz"后确实启动compiz而不是kwin了,但是任务栏却不出来了。
我试了一下,如果把KDEWM设为“metacity”或"fluxbox"就没这个问题,不知是什么原因?


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-11-21 19:49 
头像

注册: 2005-12-08 16:53
帖子: 212
送出感谢: 0 次
接收感谢: 0 次
这个恐怕得问compiz熟手,可惜自己不是。

不过您可以先尝试把kicker程序做个软链接链到~/.kde/Autostart目录下(ln -s /usr/bin/kicker ~/.kde/Autostart)。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-11-21 20:16 
头像

注册: 2007-05-05 23:11
帖子: 694
送出感谢: 2
接收感谢: 0 次
千里孤坟 写道:
这个恐怕得问compiz熟手,可惜自己不是。

不过您可以先尝试把kicker程序做个软链接链到~/.kde/Autostart目录下(ln -s /usr/bin/kicker ~/.kde/Autostart)。


哇哈哈,按照这方法试了一下,果然一切正常了。。。。。。然后,点了一下鼠标右键,面板又不见嘞~~
呵呵,看来是compiz和KDE不太适合,先凑合着用,等待KDE4.0


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-11-23 20:55 
头像

注册: 2007-05-05 23:11
帖子: 694
送出感谢: 2
接收感谢: 0 次
不知大家看没看过这个wiki,链接地址是:
代码:
http://wiki.archlinux.org/index.php/Compiz_Fusion(简体中文)#KDE.E4.B8.8B.E8.87.AA.E5.90.AF.E5.8A.A8.E6.96.B9.E6.B3.951_-_.E8.87.AA.E5.90.AF.E5.8A.A8.E9.93.BE.E6.8E.A5

我把原文粘贴一下:
引用:
KDE下自启动方法2: - 导出KDEWM变量,替代KWIN
使用这个方法可以让KDE自动以Compiz-Fusion作为窗口管理器启动。这比上面的方法启动速度要快,因为它不必加载KWIN,同时避免了窗口管理器切换时造成的黑屏。s
执行下面的命令(直接导出KDEWM="compiz --replace ccp --sm-disable"似乎不起作用):
代码:
 echo "compiz --replace ccp --sm-disable" > /usr/bin/compiz-fusion
 chmod +x /usr/bin/compiz-fusion
然后在自己的~/.bashrc中添加以下内容:
代码:
export KDEWM=compiz-fusion


哪位能帮忙解释一下 ccp --sm-disable 这个参数是做什么用的?
另外用这个方法还是不正常,而且还不稳定:有时不能 载入面板(kicker),有时能载入面板但打开窗口没有标题栏。


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-11-26 21:10 
头像

注册: 2007-01-12 21:33
帖子: 103
送出感谢: 0 次
接收感谢: 0 次
千里孤坟 写道:
KDEWM这个环境变量可以指定KDE要使用哪个窗口管理器,只要在KDE启动前这个环境变量存在就有效。

嫌麻烦直接添加到/etc/environment里就行了(KDEWM=/path/to/compiz)。

---------------------------------------------

按照这个方法,成功实现不出现kwin。
不过还是在出现床面后黑屏几秒。
并没有出现缺少面板的情况。不过有个奇怪的情况:系统托盘里的程序图标消失了,包括上次开机没有关闭的程序,尤其是音量图标……删除系统托盘之后重新添加至面板,又可以出现所有图标……真是怪异……

ls的方法没有试过。准备试一试看。有两个希望:1 不要黑屏;2 系统托盘正常


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-11-27 12:57 

注册: 2005-10-15 18:20
帖子: 309
送出感谢: 0 次
接收感谢: 0 次
个人无法忍受fusion,还是beryl中


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译