xubuntu 14.04 怎么控制显示器不自动关闭

XFCE和LXDE桌面环境
回复
头像
sh42
帖子: 97
注册时间: 2011-05-01 20:18
送出感谢: 3 次
接收感谢: 0

xubuntu 14.04 怎么控制显示器不自动关闭

#1

帖子 sh42 » 2017-06-30 15:57

我调整过电源选项,调成never都不好使。总是会自动关闭显示器,有什么好办法么。
头像
vickycq
论坛版主
帖子: 4552
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 994 次
联系:

Re: xubuntu 14.04 怎么控制显示器不自动关闭

#2

帖子 vickycq » 2017-06-30 16:07

试试 完全关闭 dpms
先运行这个临时测试一下

代码: 全选

xset s off -dpms
如果有效,创建 /etc/X11/xorg.conf.d/50-dpms.conf 加入类似以下的内容并重新启动 Xorg。

代码: 全选

Section "Monitor"
        Identifier      "HDMI-0"
        Option          "DPMS" "false"
EndSection
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
头像
sh42
帖子: 97
注册时间: 2011-05-01 20:18
送出感谢: 3 次
接收感谢: 0

Re: xubuntu 14.04 怎么控制显示器不自动关闭

#3

帖子 sh42 » 2017-07-03 16:31

这招好用!虽然我不知道什么原理,但是这招好用。但是啊,我还是想设置指定时间关闭显示器,现在没法设定,如果我想设定1小时关闭,该怎么做呢,我尝试过在power mangement里面设定,没有效果。
头像
vickycq
论坛版主
帖子: 4552
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 994 次
联系:

Re: xubuntu 14.04 怎么控制显示器不自动关闭

#4

帖子 vickycq » 2017-07-03 16:41

先恢复启用 DPMS,再在 ServerLayout 一节中设置 OffTime 等参数,单位为分钟

代码: 全选

Section "Monitor"
    Identifier "HDMI-0"
    Option "DPMS" "true"
EndSection

Section "ServerLayout"
    Identifier "ServerLayout0"
    Option "OffTime"     "60"
EndSection
还有其它参数:https://wiki.archlinux.org/index.php/Di ... _Signaling
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
回复

回到 “Xubuntu & Lubuntu”