当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请教一条关于引导LXDE时出现的怪事。
帖子发表于 : 2010-05-14 3:39 
头像

注册: 2008-03-30 11:05
帖子: 32
地址: China
送出感谢: 0 次
接收感谢: 0 次
我本来是打算装Lubuntu的,我把一个1G的U盘制作成LiveUSB来启动,
启动本来是一切正常的,看到了启动时拉动的字幕,本来就很兴奋的感觉,
可是还没到过渡画面就出现问题了,直接黑屏。。
我的显示器是CRT 17" ,是没有显示超出分辨率或者刷新率的字样,可是无论用GRUB还是SYSLINUX都是无法启动到Xwindow,然后我就开始怀疑系统是有成功启动了的,我就<C-F1>,然后奇迹般的屏幕跳到了tty1,奇怪奇怪。。
命令行可以看到,证明系统是正常的,可是为什么就是启动不了X?
我就在命令行下输入startx,拉出了一大堆英文,然后又直接黑屏了。。
这一连串的错误令我不得不放弃了Lubuntu,因为我足足重复尝试了2个多小时,在Google和baidu上不断的搜索,怎么找也找不到关于Lubuntu的资料。
放弃了。
然后我又用Debian-LXDE.img写入到U盘,尝试安装Debian(我主要是想用LXDE,哪个系统都不是关键。)
但是同样的Debian的启动出现了Lubuntu同样的错误。
我彻底绝望了。。
我跟LXDE有仇么?为什么这么耍我。。。

各位大人,有谁知道这是因为什么缘故的话,请告诉我一声,谢谢。
我现在在用gNewsense,十分的不爽,很多非GNU程序都不能安装,烦死了。可是也没办法,我手头上已经下载好的镜像也只有gNewsense了。

PS:我平时有使用LiveUSB,我平常用的是Slitaz,用的是LXDE,但是相当奇迹的是,我的电脑可以正常启动和使用,所以我又有点怀疑不是LEDE的问题了。。各位帮个忙研究一下,小燃在这里叩谢各位了。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 请教一条关于引导LXDE时出现的怪事。
帖子发表于 : 2010-05-15 1:29 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
直接用minISO装一个Ubuntu的基本CLI系统,然后装上xorg,然后再装lubuntu-desktop应该就行了。。。某直接用Lubuntu的iso刻盘安装的系统有问题。 :em09
viewtopic.php?f=77&t=260717#普度众生大慈大悲黑脸女菩萨手书的从minISO最小化定制安装Ubuntu的太监版pdf教程,需要2M水管加路由器的网络条件。iso可以从硬盘map到内存安装。


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 请教一条关于引导LXDE时出现的怪事。
帖子发表于 : 2010-05-26 3:25 
头像

注册: 2008-03-30 11:05
帖子: 32
地址: China
送出感谢: 0 次
接收感谢: 0 次
@wangdu2002
感激了~问题解决了,只是我没装Lubuntu,而是装了Ubuntu10.04。
而且我用Ubuntu10.04的LiveUSB安装同样出现问题了。
然后我换了9.10来装,结果一切顺畅,完全没问题了。。哈哈
然后我直接用9.10直接升级10.04LTS。
一个晚上时间弄好了。
成功的使用上了10.04。

可惜怪事就出现了,第一次重启就出问题了。。
像安装光盘一样出现了黑屏。
我发现了应该不是xorg之类的问题。
我尝试把默认的linux-headers-2.6.32换成了2.6.31启动。。
一切正常了!!!
原来是内核的缘故。。

所以,想再请问一下,如何把光盘中默认安装的内核替换成2.6.31?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 请教一条关于引导LXDE时出现的怪事。
帖子发表于 : 2010-05-26 14:19 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
估计是你的主板要加启动参数才行滴。。。某的本本的主板要加pci=nomsi才行,还有好多参数可以多试试。或是放狗找ppa,直接用2.6.34的最新内核。
viewtopic.php?f=120&t=160217#john.wu的ubuntu不能顺利安装或经常死机时可以考虑添加的启动参数。比如pci=nomsi、noapic、nomodeset等等之类的典型参数。


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 请教一条关于引导LXDE时出现的怪事。
帖子发表于 : 2010-05-26 20:50 
头像

注册: 2008-03-30 11:05
帖子: 32
地址: China
送出感谢: 0 次
接收感谢: 0 次
感激不尽~我尝试一下试试。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译