当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 新手求助关于网络安装Xfce的一个小小的问题(非弱智问题)
帖子发表于 : 2006-11-03 15:10 

注册: 2006-11-02 11:00
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
由于前段时间下载的ubuntu 6.10 desktop光盘出现文件缺损,只好安装了6.06的server版本,由于是刚开始学习ubuntu,安装完server版本才发现,没有UI界面,通过查询,可以使用sudo apt-get install xubuntu-desktop 直接安装xfce界面。

经过1晚上的网络安装,终于安装完成了,并且没有看到错误信息,应该是完整的下载下来了~~~

但是在root用户下,使用startx命令,出现花屏。

通过命令glxinfo | grep rendering命令,得到的结果是Error:unable to open display(null)

通过google查找,发现,这是由于显卡没有被正确识别造成的,但是没有找到解决方法,我不知道显卡没有被正确识别和我的xfce不能正常启动是否有关联,请达人帮忙解决一下~~~谢谢~~~~

另外,请问达人,如果我使用apt-get命令升级软件的时候,中途停止了,如果第二天我再继续下载,是从新开始,还是接着上次下载的文件继续下载?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-11-03 22:07 

注册: 2006-07-27 15:50
帖子: 144
送出感谢: 0 次
接收感谢: 0 次
显卡驱动装过了吗?


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-11-04 13:15 

注册: 2006-11-02 11:00
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
安装完成了,但是问题依旧啊~~~


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-11-04 17:58 

注册: 2006-03-21 10:47
帖子: 406
送出感谢: 0 次
接收感谢: 0 次
已经下载了的就保存在本地了的,接着下载未下载的。重新安装xserver-xorg试试看。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-11-04 22:47 

注册: 2006-11-02 11:00
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
从新安装的xserver-xorg的命令是什么呢?

另外我在/var/log/Xorg.log中发现如下的错误信息

(**)NVIDIA(0):Enabling RENDER acceleration
(EE)NVIDIA(0):Failefd to load the NVIDIA kernel module!
(EE)NVIDIA(0):***Aborting***
(II)UnloadModule:"nvidia"
(II)UnloadModule:"ramdal"
(II)UnloadModule:"fb"
(EE)Screen(s) found,but one have a usable configuration.Fatal server error
no screens found

从上面的信息看,问题可能是我的NVIDIA kernel module安装不正确导致的,但是如何能够从新安装这个模块呢?或者说如何重新加载这个模块呢?


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-11-04 22:50 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
用aptitude安装nvidia-glx就可以了吧。除开你xorg.conf里面有其他不正常设置。


_________________
● 鸣学


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-11-04 22:54 

注册: 2006-11-02 11:00
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
我就是通过 apt-get install ncidia-glx命令安装的显卡驱动,安装过程中没有看到错误啊。。。。

另外我在查询资料过程中发现安装nvidia的驱动,可能用到如下的命令:
linux-restricted-modules-common
nvidia-glx
nvidia-settings
nvidia-kernel-common

我想问问这些命令间的关系是什么样的?
是否是执行了nvidia-glx ,就不用再执行其他的命令了?


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-11-05 11:09 

注册: 2006-11-02 11:00
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
新手无奈,顶下


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-11-06 13:00 
头像

注册: 2006-02-20 15:15
帖子: 36
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
先试一下sudo apt-get install xserver-xorg,然后sudo dpkg-reconfigure xserver-xorg。看行不行。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-11-16 11:58 

注册: 2006-11-06 7:55
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
我试过
代码:
sudo apt-get -f install


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译