xfce 下怎么样才能让vncviewer连接

XFCE和LXDE桌面环境
回复
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

xfce 下怎么样才能让vncviewer连接

#1

帖子 xiehuoli » 2007-10-15 15:34

如题
装了xfce速度还真的是快,不过系统自带的远端桌面vnc无法连接了
调用vino-preferences 设置好也没有用
提示连接被拒绝
VNC viewer version 3.3.7 - built Mar 8 2007 21:56:52
Copyright (C) 2002-2003 RealVNC Ltd.
Copyright (C) 1994-2000 AT&T Laboratories Cambridge.
See http://www.realvnc.com for information on VNC.
vncviewer: ConnectToTcpAddr: connect: Connection refused
Unable to connect to VNC server
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2007-10-15 15:39

vncserver -fp /usr/share/fonts/X11/misc
有个bug。开服务就是。
● 鸣学
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#3

帖子 xiehuoli » 2007-10-15 15:45

EE能否详细说说
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#4

帖子 xiehuoli » 2007-10-15 16:04

安装了vncserver
运行vncserver -fp /usr/share/fonts/X11/misc
后还是不行,是不是因为vino-preferences没有开启。
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#5

帖子 eexpress » 2007-10-15 16:10

先自己跑 vncserver -fp /usr/share/fonts/X11/misc。
然后别人 vncview xxxxxxxx就可以了。
vino-preferences那里只是要打勾设置,退出就应该自动启动vncserver(这里是关键)。如果是这时候自动启动的,就不带那参数,就会没进程。

这是我知道的一个bug。如果你那里没这bug。直接vino-preferences就可以了的。应该可以看到vncserver的进程。
● 鸣学
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#6

帖子 xiehuoli » 2007-10-15 16:21

我执行vino-perferences
提示出错:
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified


(vino:6160): Gtk-WARNING **: cannot open display:

如果加sudo vino-perXXX
则别人可以连到我的root桌面
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#7

帖子 eexpress » 2007-10-15 16:26

@@@ 不知道这种情况。。

我的实践机会都很少的。没碰到这种。

你干脆就不开vino就是。反正那服务在跑。vino只是设置配置文件而已。
● 鸣学
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#8

帖子 xiehuoli » 2007-10-15 16:40

晕了,难道真的只有gnome下才能用vnc连接吗?
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#9

帖子 eexpress » 2007-10-15 16:45

fvwm下,上次一个法国佬要测试,说要找他的四川的女友,连不上。就和我测试了下,才发现这bug的。
之前,和那个什么小猪也连过2次。

没了。

没wm限制吧。只是对方是连到gnome的桌面的。另开的X。你搜索下Xforward关键词。可能配置文件里面要这个是yes。
● 鸣学
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#10

帖子 xiehuoli » 2007-10-16 14:14

搜索了好久
硬是没找到 :em06
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
onandon
帖子: 29
注册时间: 2006-02-12 18:48
送出感谢: 0
接收感谢: 0

Re: xfce 下怎么样才能让vncviewer连接

#11

帖子 onandon » 2007-10-27 0:50

xiehuoli 写了:如题
装了xfce速度还真的是快,不过系统自带的远端桌面vnc无法连接了
调用vino-preferences 设置好也没有用
提示连接被拒绝
VNC viewer version 3.3.7 - built Mar 8 2007 21:56:52
Copyright (C) 2002-2003 RealVNC Ltd.
Copyright (C) 1994-2000 AT&T Laboratories Cambridge.
See http://www.realvnc.com for information on VNC.
vncviewer: ConnectToTcpAddr: connect: Connection refused
Unable to connect to VNC server
去synaptic里面装x11vnc

我是参考下面这个设置的,这个设置的一个缺点是你在remote以前必须已经启动了xserver(简单说就是已经登录进桌面了)
http://twntwn.info/blog/ajer001/archives/1789
[XUBUNTU] VNC Server
| Posted at 四月 21, 2007 | 沒有迴響 | 沒有引用 | 1343 reads. | Size: L, M, S |
| Under Ubuntu. |

最近在玩 xubutnu,還在熟悉中。

預設的 xubuntu 不像 ubuntu 有內建的 vnc server: vino,所以也沒有像 ubuntu一樣方便的 vnc啟用辦法。如果裝 vncserver、vnc4server、tigervncserver 等,卻只能另開啟一個 screen,不是我要的。

找了一下,才發現 x11vnc 就可以搞定了。安裝:

# sudo apt-get install x11vnc

第一次執行,要先設定一下密碼:

# vncpasswd

預設位置在 ~/.vnc/passwd。

接著到選單的「設定」->「自動啟動的應用程式」裡面,加上:

x11vnc -forever -shared -rfbauth ~/.vnc/passwd

這樣,開機就會自動執行了。
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#12

帖子 xiehuoli » 2007-11-02 17:04

谢谢LS回答
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
回复

回到 “Xubuntu & Lubuntu”