[问题]请问在XUbuntu中如何配置jdk

XFCE和LXDE桌面环境
回复
multimatrix
帖子: 6
注册时间: 2007-12-22 23:47
送出感谢: 0
接收感谢: 0

[问题]请问在XUbuntu中如何配置jdk

#1

帖子 multimatrix » 2007-12-22 23:56

我的xubuntu7.10不联网,从sun下的jdk-6u3-linux-i586.bin,安装在/home/xxx/java下,然后在/etc/profile设置的JAVA_HOME,PATH和CLASS_PATH,之前用ubuntu6.06时这样做是没有问题的,但现在在xubuntu7.10上就不行,请问怎么解决
multimatrix
帖子: 6
注册时间: 2007-12-22 23:47
送出感谢: 0
接收感谢: 0

#2

帖子 multimatrix » 2007-12-23 1:28

在terminal输java -version结果如下

xxx@xxx:~$ java -version
名为 'java' 的程序可以在下列包中找到
* cacao (You will have to enable component called 'universe')
* j2re1.4 (You will have to enable component called 'multiverse')
* kaffe (You will have to enable component called 'universe')
* jamvm (You will have to enable component called 'universe')
* java-gcj-compat
* gij-4.1 (You will have to enable component called 'universe')
* gij-4.2
* sablevm (You will have to enable component called 'universe')
试试:sudo apt-get install <选定的软件包>
bash: java:找不到命令
头像
stlxv
论坛版主
帖子: 8274
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#3

帖子 stlxv » 2007-12-23 1:32

你用jdk-6u3-linux-i586.bin安装完了就能用了,不用配置
PHP是最好的语言!不服来战!
头像
windwiny
帖子: 2254
注册时间: 2007-03-13 17:26
送出感谢: 0
接收感谢: 1 次

#4

帖子 windwiny » 2007-12-23 3:02

安装 sun-java6-jre 吧
头像
hubert_star
论坛版主
帖子: 5372
注册时间: 2007-10-29 22:12
系统: OSX 10.9 + Ub 1304
来自: 江苏南京
送出感谢: 0
接收感谢: 5 次

#5

帖子 hubert_star » 2007-12-23 3:07

回楼主,你说你配置了环境还没有找到java这个命令,我只能说要不是你配的不对,就是你没有重新登录一下!!!!!
佛经说,人有八苦: 生、老、病、死、求不得、怨憎、爱别离、五阴盛 故我苦!
圣经说,人有七罪: 饕餮、贪婪、懒惰、淫欲、傲慢、嫉妒和暴怒  故我有罪!

我这篇帖子里面没有任何攻击我们伟大的中华人民共和国政府和任劳任怨的人民公仆(和本论坛高素质的版主)的文字和含义;

特此声明!

有些事,我们明知道是错的,也要去坚持,因为不甘心;有些人,我们明知道是爱的,也要去放弃,因为没结局;有时候,我们明知道没路了,却还在前行,因为习惯了。

欢迎来我的新浪微博@me
multimatrix
帖子: 6
注册时间: 2007-12-22 23:47
送出感谢: 0
接收感谢: 0

#6

帖子 multimatrix » 2007-12-23 15:50

搞定了,先前出了什么问题还不知道
stlxv 写了:你用jdk-6u3-linux-i586.bin安装完了就能用了,不用配置
还是要配的,要不输出就和上面贴的一样


在/etc/profile中添加的是如下几行:

JAVA_HOME=/home/xxx/java/jdk1.6.0_03
export PATH=$JAVA_HOME/bin:$PATH
export CLASSPATH=.:$JAVA_HOME/lib/tools.jar

谢谢各位!周末愉快!预祝圣诞快乐!新年快乐!
ww2000e
帖子: 93
注册时间: 2007-10-11 22:03
送出感谢: 1 次
接收感谢: 1 次

#7

帖子 ww2000e » 2008-09-01 21:28

一样情况 set 去掉就正常了
回复

回到 “Xubuntu & Lubuntu”