当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : t61 nvidia nvs 140m 显卡无法安装使用请高人指点
帖子发表于 : 2008-01-11 14:35 

注册: 2008-01-11 14:30
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
安装步骤如下 但是系统就是无法启用显卡



在下下载的就是NVIDIA-Linux-x86-100.14.23-pkg1.run这个文件

2、删除原驱动包

sudo apt-get --purge remove nvidia-glx

然后删除 /lib/linux-restricted-modules/2.6.22-14-generic/文件夹下面带有nvidia字样的内容,这里是内核自带的驱动。

再检查一下。

/etc/init.d/nvidia-glx

/etc/init.d/nvidia-kernel

这两个文件是否存在,删除。



3、安装要用到的软体

sudo apt-get install build-essential pkg-config xserver-xorg-dev linux-headers-`uname -r`

安装编译包



4、备份

sudo cp /etc/default/linux-restricted-modules-common /etc/default/linux-restricted-modules-common.backup

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup



5、禁止系统使用默认的驱动

sudo gedit /etc/default/linux-restricted-modules-common

在最后的双引号中添加nv nvidia_new,即“”改成“nv nvidia_new”

如果前面第二步删除完整了其实也可以不用执行这一步。



6、停止GDM进程

sudo /etc/init.d/gdm stop

按Ctrl+Alt+F1,登录后。



7、进入下好的驱动所在目录(用ls命令确认文件在不在)

sudo sh NVIDIA-Linux-x86-100.14.23-pkg1.run

安装过程中,

如果提示有旧驱动,询问是否删除旧驱动,选Yes;

如果提示缺少某某模块(modules),询问是否上网下载,选no;

如果提示编译模块,询问是否进行编译,选ok;

如果提示将要修改Xorg.conf,询问是否允许,选Yes;

接下来就是等待安装完成。



8、安装完成就回到终端,重启GDM

sudo /etc/init.d/gdm restart



ok了,当看到NV的logo后,安装成功。



如果实在不想看NVIDIA的LOGO,可以修改 /etc/X11/xorg.conf

在Section "Device"中添加Option "NoLogo" "True"



如:

Section "Device"

Identifier "通用显示卡"

Driver "nvidia"

Option "NoLogo" "True"

EndSection


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-01-11 16:22 

注册: 2006-09-17 21:14
帖子: 90
送出感谢: 0 次
接收感谢: 0 次
用最新的169驱动,把受限管理全部删除,如果有兴趣的话可以重新编译一下内核,无线网卡会好很多。

参见:

http://magicgod.javaeye.com/blog/150061

T61换内核:
http://magicgod.javaeye.com/blog/152194


页首
 用户资料  
 
3 楼 
 文章标题 : 我试试谢谢楼上的
帖子发表于 : 2008-01-11 17:06 

注册: 2008-01-11 14:30
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我试试谢谢楼上的


页首
 用户资料  
 
4 楼 
 文章标题 : 不行呀各位大哥 还是显卡不能用
帖子发表于 : 2008-01-11 18:04 

注册: 2008-01-11 14:30
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
不行呀各位大哥 还是显卡不能用


附件:
文件注释: Screenshot-受限制的驱动程序
Screenshot-受限制的驱动程序.png
Screenshot-受限制的驱动程序.png [ 13.92 KiB | 被浏览 1207 次 ]

页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-01-11 22:48 
头像

注册: 2008-01-01 17:25
帖子: 665
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
把“受限驱动管理器”整个删除

删完了之后再重新来

参考这个帖子
http://forum.ubuntu.org.cn/weblog_entry ... 7d8af7bfb9


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-01-12 2:16 

注册: 2008-01-11 14:30
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
谢谢 zhihuasz 我显卡终于好了 谢谢万分感谢


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-01-12 2:31 

注册: 2008-01-11 14:30
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
在请教个问题 虽然显卡驱动装上了 但是怎么启用3D效果呀 我一启用就说让我启用那个默认的 结果 把刚安装好的又给覆盖了 哈哈


zhihuasz 写道:
把“受限驱动管理器”整个删除

删完了之后再重新来

参考这个帖子
http://forum.ubuntu.org.cn/weblog_entry ... 7d8af7bfb9


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-02-02 19:06 

注册: 2008-01-11 18:49
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
偶也遇到此问题呀,驱动是正常安装了,NVidia的标志图片也看到了,可是在受限驱动管理器中还是老的nvidia-glx-new驱动,一旦启用就恢复回去了,新的驱动不知道在哪里启用 :(

peter-liu 写道:
在请教个问题 虽然显卡驱动装上了 但是怎么启用3D效果呀 我一启用就说让我启用那个默认的 结果 把刚安装好的又给覆盖了 哈哈


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-02-05 2:27 

注册: 2006-09-17 21:14
帖子: 90
送出感谢: 0 次
接收感谢: 0 次
请在新立得里删除所有的受限驱动管理,ubuntu 7.1管得太管了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译