当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : usb设备挂接问题
帖子发表于 : 2008-01-13 10:00 

注册: 2006-12-30 13:38
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
如果没有开电脑前将移动硬盘/摄像头之类的usb设备连接上. 开机后会出现下面的信息. 系统再也无法挂载usb设备了. 用lsusb命令.该命令直接死在那里.
如果开机时不接usb设备, 开机后接.就没有问题.

测试过的系统: feisty, gutsy

[ 15.817359] uhci_hcd 0000:00:1d.3: UHCI Host Controller
[ 15.817393] uhci_hcd 0000:00:1d.3: new USB bus registered, assigned bus number 4
[ 15.817443] uhci_hcd 0000:00:1d.3: irq 17, io base 0x00001260
[ 15.817608] usb usb4: configuration #1 chosen from 1 choice
[ 15.817651] hub 4-0:1.0: USB hub found
[ 15.817660] hub 4-0:1.0: 2 ports detected
[ 15.909541] irq 19: nobody cared (try booting with the "irqpoll" option)
[ 15.909551] [<c015b594>] __report_bad_irq+0x24/0x80
[ 15.909560] [<c0139679>] __rcu_process_callbacks+0x69/0x1d0
[ 15.909566] [<c015b852>] note_interrupt+0x262/0x2a0
[ 15.909570] [<f88866c2>] usb_hcd_irq+0x22/0x60 [usbcore]
[ 15.909590] [<c015aab0>] handle_IRQ_event+0x30/0x60
[ 15.909594] [<c015c23b>] handle_fasteoi_irq+0xbb/0xf0
[ 15.909598] [<c0106b1b>] do_IRQ+0x3b/0x70
[ 15.909602] [<c01812f1>] sys_read+0x41/0x70
[ 15.909606] [<c0105223>] common_interrupt+0x23/0x30
[ 15.909611] =======================
[ 15.909613] handlers:
[ 15.909614] [<f88866a0>] (usb_hcd_irq+0x0/0x60 [usbcore])
[ 15.909627] Disabling IRQ #19

[ 257.076000] usb 5-5: new high speed USB device using ehci_hcd and address 7
[ 272.620000] usb 5-5: device not accepting address 7, error -110
[ 272.732000] usb 5-5: new high speed USB device using ehci_hcd and address 8
[ 275.828000] NET: Registered protocol family 17
[ 279.396000] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[ 288.276000] usb 5-5: device not accepting address 8, error -110
[ 288.388000] usb 5-5: new high speed USB device using ehci_hcd and address 9
[ 294.536000] eth1: no IPv6 routers present
[ 298.812000] usb 5-5: device not accepting address 9, error -110
[ 298.924000] usb 5-5: new high speed USB device using ehci_hcd and address 10
[ 309.348000] usb 5-5: device not accepting address 10, error -110


最后由 armer_song 编辑于 2008-01-13 10:12,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-01-13 10:10 

注册: 2006-12-30 13:38
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
找到了一种解决方式: sudo rmmod ehci_hcd, 之后就可以了


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-04-25 3:11 
头像

注册: 2006-11-05 10:43
帖子: 92
送出感谢: 0 次
接收感谢: 0 次
执行sudo rmmod ehci_hcd命令后没有任何效果啊 。
结果还是一样。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译