当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]我的 DELL 蓝牙键盘在 Ubuntu 7.10 下好像不是走蓝牙模式
帖子发表于 : 2008-01-25 13:56 

注册: 2008-01-25 13:46
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
我用的是 DELL 的蓝牙无线键盘 + HP 1.2 的蓝牙棒子 (支持 HID-Proxy)

从安装到使用都很顺利,直到有一次睡一觉起来,发现无法唤醒键盘了,用 hidd --search 或 hcitool scan 皆找不到任何蓝牙装置 (不止键盘,包括我的手机也搜不到)

只得回 xp 重新适配。

但后来我发现一件怪事,就是在 ubuntu 下,我的蓝牙装置列表是空白的,而使用直接指定 MAC 的型式

代码:
hidd --connect aa:bb:cc:dd:ee:ff


仍然显示 connection timeout 错误,这时候开始怀疑我的键盘是不是走 hid proxy 虚拟通道,而不是走真正的蓝牙。

因为我还是菜鸟,不太懂得在 ubuntu 下对蓝牙装置做正确的适配,在 google 里搜到的相关解答几乎能做的都做了,都解决不了我的问题,包括定时 restart bluetooth service。

现在是很消极的,定时按一下键盘让它 keep alive,否则一但闲置,就再也找不到了,只能退回 xp 重新适配。

请问有任何解决办法吗?被这个问题搞得快疯了。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-01-25 22:28 
头像

注册: 2006-11-25 15:27
帖子: 311
地址: SZ
送出感谢: 0 次
接收感谢: 0 次
我用的是一个山寨蓝牙适配器,把它插上会在GNOME任务栏出现蓝牙图标,
手机可以和电脑正常配对和收发文件,跟在win下没什么区别。
现在我的新立得里面已经安装的和蓝牙有关的包有这些(有些是默认安装的):
bluetooth,bluez-gnome,bluez-utils,gnome-bluetooth,libbluetooth2,libbtctl4,libgnomebt0,nautilus-sendto


_________________
NoteBook: IBM X40 (1G Hz, 1.25GB, 20G+120GB)
Desktop: APU A6-3670, MSI A75A-G55, 4GB DDR3 1600 x 2
Slackware64 + Win7


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-01-26 10:52 

注册: 2008-01-25 13:46
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
谢谢 felixlu 兄,等等我看一下有没有包忘记装上的。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-01-27 14:32 

注册: 2008-01-25 13:46
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
我发现我的蓝牙键盘好像跟 dongle 配对后变为一体了…用 hidd --show 只能看到我那一只蓝牙 dongle 的 MAC,而 search 或是硬指定我的键盘 MAC 则是毫无动作

昨天试了一下,用 crontab 每 10 分钟重启一次 /etc/init.d/bluetooth,结果一觉起来,键盘又睡死了。

回到 xp ,按一下键盘…键盘上的蓝牙灯闪了一下,又唤醒了…

再求解决办法,谢谢。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译