当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 20 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : nVidia显卡驱动,编译安装完全指导
帖子发表于 : 2008-01-26 0:50 
头像

注册: 2008-01-01 17:25
帖子: 665
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
经过多次安装Ubuntu 7.10,多次安装显卡驱动169.07和169.09,目前该方法在我附近的几台机器都是100%成功(都是n卡),现总结步骤如下:



1、下载驱动(.run文件),放到自己的主目录下(/home/<yourname>),改一个比较容易敲的名字(例如:display.run)
下载的地方有很多,nVidia自己的网站可以下,不过我是偏向喜欢在mydrivers.com下。
解压时确定文件没有出错。



2、卸载所有显卡受限驱动,在“添加/删除...”里面即可完成,也可以用apt,各人喜欢。




3、卸载受限驱动管理器,在“添加/删除...”里面即可完成,也可以用apt,各人喜欢。
受限驱动管理器经常会给编译安装驱动制造麻烦,如果你不打算使用源里面的驱动,而使用自己编译的驱动,这个东西删掉无妨。



4、安装东西:
代码:
sudo apt-get install libc6-dev
sudo apt-get install gcc+
sudo apt-get install build-essential pkg-config xserver-xorg-dev linux-headers-`uname -r`

如果apt没找到,请自己到wiki找快速设置指南,添加cn99或者其他源


5、删除可能影响安装的东西。在这里提醒一下,要养成良好的习惯,删除东西前,不要嫌麻烦,最好先cd进入目录,然后再rm,以免rm命令还没敲完就碰到了回车,那麻烦就大了,极端的例子(sudo rm -rf /),千万别乱敲。

1)/lib/linux-restricted-modules/里面的内容,如果有隐藏的.nvidia-new-installer也要删掉
代码:
cd /lib/linux-restricted-modules
ls -al
sudo rm -rf *
ls -al


2)/etc/init.d/nvidia-glx这个文件(如果有)
代码:
cd /etc/init.d/
ls -al
sudo rm -rf nvidia-glx
ls -al


3)/etc/init.d/nvidia-kernel这个文件(如果有)
代码:
cd /etc/init.d/
ls -al
sudo rm -rf nvidia-kernel
ls -al



6、修改/etc/default/linux-restricted-modules-common 这个文件
代码:
sudo gedit /etc/default/linux-restricted-modules-common

把里面的
DISABLED_MODULES="" 改为
DISABLED_MODULES="nv nvidia_new"


并且备份/etc/X11/xorg.conf
代码:
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.before






7、确定一切准备完毕,只欠安装之后,按下Ctrl + Alt + F2,进入命令行,建议使用root进入,初始帐号我试过也能够安装成功。




8、关闭Gnome。
代码:
sudo /etc/init.d/gdm stop

如果命令成功,右端会有一个[OK]的提示




9、运行安装程序
代码:
sudo sh /home/<yourname>/display.run

安装过程中,首先会问你是否卸载已经安装的显卡驱动,YES。后面忘了,大概能答YES就答YES就可以了。





10、安装完成后,回到命令行,sudo reboot。如果正常,usplash启动画面过后,你就能看到nVidia的标志了。
如果不想看到nVidia的启动标志,则修改xorg.conf,在 Section "Device"段落里面加上一行:
Option "NoLogo"
下此启动你就不会看到nVidia的标志。




11、进入Gnome后,你就可以在终端输入
代码:
nvidia-settings

来设置你的显卡了




12、如果还是有问题,请到http://forum.ubuntu.org.cn发帖。


最后由 zhihuasz 编辑于 2008-01-26 1:26,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-01-26 1:09 
头像

注册: 2008-01-01 17:25
帖子: 665
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
最后贴一张桌面,祝你安装顺利成功~

安装成功后请跟个贴~~~谢谢~~~~~


附件:
Screenshot.png
Screenshot.png [ 1.36 MiB | 被浏览 5699 次 ]

页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-01-26 4:01 

注册: 2008-01-24 1:39
帖子: 52
送出感谢: 0 次
接收感谢: 0 次
我服了
我真的服了
ubuntu还是牛
连个libc6-dev都下不了,每次下这个的时候,老是提示你的系统UNSTABLE,妈X的,难道是系统碟就是UNSTABLE 的?
一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.5-0ubuntu14) 但是 2.6.1-1ubuntu9 正要被安装
E: 无法安装的软件包

能换的源我都换了
还他妈X的不行
都4点了,都说N卡容易,要是换张A卡,我估计就死在笔记本前了
这到底是怎么回事阿!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-01-26 23:15 

注册: 2006-07-07 18:11
帖子: 113
送出感谢: 0 次
接收感谢: 0 次
wwwwangccc 写道:
我服了
我真的服了
ubuntu还是牛
连个libc6-dev都下不了,每次下这个的时候,老是提示你的系统UNSTABLE,妈X的,难道是系统碟就是UNSTABLE 的?
一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.5-0ubuntu14) 但是 2.6.1-1ubuntu9 正要被安装
E: 无法安装的软件包

能换的源我都换了
还他妈X的不行
都4点了,都说N卡容易,要是换张A卡,我估计就死在笔记本前了
这到底是怎么回事阿!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!



哥们,我看过一篇文章,和你的故障一样,你看看你的更新源是不是设置错了,一定认真检查。
另外,我也被显卡折磨疯了,交流电正常,电池模式只能工作在低级图形模式,惨啊 :shock:


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-01-27 20:05 

注册: 2008-01-24 1:39
帖子: 52
送出感谢: 0 次
接收感谢: 0 次
你的问题更夸张啊,对,再好好看看


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-01-27 21:27 
头像

注册: 2008-01-01 17:25
帖子: 665
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
bigbird 写道:
wwwwangccc 写道:
我服了
我真的服了
ubuntu还是牛
连个libc6-dev都下不了,每次下这个的时候,老是提示你的系统UNSTABLE,妈X的,难道是系统碟就是UNSTABLE 的?
一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.5-0ubuntu14) 但是 2.6.1-1ubuntu9 正要被安装
E: 无法安装的软件包

能换的源我都换了
还他妈X的不行
都4点了,都说N卡容易,要是换张A卡,我估计就死在笔记本前了
这到底是怎么回事阿!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!



哥们,我看过一篇文章,和你的故障一样,你看看你的更新源是不是设置错了,一定认真检查。
另外,我也被显卡折磨疯了,交流电正常,电池模式只能工作在低级图形模式,惨啊 :shock:




即使是源提供的受限驱动,也是有很多bugs的,尤其是对新显卡的支持普遍不好。
我自己发现的问题就有:DELL 1420,8400M GS显卡,用源提供的100.xx的驱动,桌面切换的指示方格里面,有斑点的渲染错误。。。换了169.07就没问题了


169.07修正的问题:
1.增加对GeForce 8800 GT、GeForce 8800 GTS 512以及GeForce 8800M显卡的支持。
2.在运行文件中增加CUDA驱动。
3.优化对Quadro/GeForce 8系列图形处理器(GPU)模式设定支持。
4.修正了数个 X渲染问题。
5.修正了在Qt拉伸中产生的卷动ARGB X问题。
6.优化对DVI、HDMI及HDTV模型集交错支持。
7.修正GeForce 8系列图形处理器(GPU)稳定性问题。
8.修正个别GeForce 6200/7200/7300图形处理器(GPU)在多核心/多处理器系统上的稳定性问题。
9.优化某些联想笔记本热键开关支持。
10.修正了一个在vt-switching后与Compiz有关的问题。
11.优化渲染性能。
12.优化了对投影机、Chi Mei 56"DFP以及某些Gateway 19"DFP互动性。
13.增加一个监测PowerMizer状态信息的接口。
14.修正了Maya's Graph Editor中渲染瘫痪的问题。
15.优化了特定Quadro FX图形处理器(GPU上)AFR SLI与swap组的交互性。
16.修正了一个可能导致系统本盔的错误,该错误出现在未启动TurboCache支持时在GPU上重新引导XV。
17.优化GeForce 8系列图形处理器(GPU)上的显示设备侦测。
18.优化了在低分辨率例如1024x768和800x600下NVIDIA设置可用性。
19.优化在Quadro GeForce 8系列以及其它图形处理器上运行Xinerama似的GLX视觉统一。
20.增加在Quadro G8X及之后图形处理器上以Depth 30(每组件10位)运行X server的试支持。
21.解决了一项Linux kernel/工作链错误,该错误可导致在某些Intel系统下出现软件锁死错误。



169.09修正的问题:
1.修正了某些GPU上,风扇全时全速运转的错误。
2.修正了运行X.Org GLX的拓展模块时,可能引起某个驱动崩溃的漏洞。
3.改进了驱动对当前笔记本上接驳新插件的认知能力。
4.修正了惠普笔记本中的亮度调节功能。
5.修正了运行Linux/i2c计算程序驱动时,阻止核心传输程序运行的漏洞。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-01-29 20:10 

注册: 2008-01-29 19:59
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
受限驱动 update 到169.09就好了


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-01-29 22:01 
头像

注册: 2008-01-01 17:25
帖子: 665
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
我想用Ubuntu 写道:
受限驱动 update 到169.09就好了


LS的给个源地址?


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-02-01 23:32 
头像

注册: 2006-03-21 22:55
帖子: 52
送出感谢: 0 次
接收感谢: 0 次
我的是Dell 1420 x3100显卡 ,这个需要重新安装显卡驱动吗 ? 用系统自己识别的行吗?


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-02-02 0:34 
头像

注册: 2008-01-01 17:25
帖子: 665
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
blackheart 写道:
我的是Dell 1420 x3100显卡 ,这个需要重新安装显卡驱动吗 ? 用系统自己识别的行吗?


可以的话,建议你到http://linux.dell.com/wiki/index.php/Ubuntu_7.10
下载DELL定制的UBUNTU

系统用的是源里面自带的驱动,用3D桌面是没问题的

但是我的Dell 1420 8400M显卡,在桌面切换的时候,指示方块有渲染错误,所以我就换成nVidia的驱动了


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-02-03 20:47 
头像

注册: 2007-05-25 12:59
帖子: 74
送出感谢: 0 次
接收感谢: 0 次
我的是mcp73pv的板子,这么装驱动还是不成功,分辨率还是调不了啊。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-02-04 9:56 

注册: 2006-02-12 19:29
帖子: 512
送出感谢: 1
接收感谢: 0 次
自己编译的驱动还是爽多了。源里提供的驱动虽然说兼容性好,但是很多效果却体现不出来。还是自己编译的好。感谢楼主发文。


页首
 用户资料  
 
13 楼 
 文章标题 : Re: nVidia显卡驱动,编译安装完全指导
帖子发表于 : 2008-11-02 13:51 

注册: 2007-06-12 21:32
帖子: 11
地址: 東興
送出感谢: 0 次
接收感谢: 0 次
感谢楼主!
现在爽多了!~


页首
 用户资料  
 
14 楼 
 文章标题 : Re: nVidia显卡驱动,编译安装完全指导
帖子发表于 : 2008-12-17 19:54 
头像

注册: 2008-11-14 22:27
帖子: 588
送出感谢: 0 次
接收感谢: 1
顶!!!!


_________________
意识流足球的集大成者-阿森纳


页首
 用户资料  
 
15 楼 
 文章标题 : Re: nVidia显卡驱动,编译安装完全指导
帖子发表于 : 2008-12-18 9:54 

注册: 2008-11-20 7:50
帖子: 40
送出感谢: 0 次
接收感谢: 0 次
我用楼主的办法安装驱动程序时,不知什么原因把无线网卡驱动也删掉了,那位给解决一下,很急!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 20 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译