当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 耳机没声音的解决方法!!(本人实践成功)
帖子发表于 : 2008-02-18 16:05 

注册: 2007-04-29 14:47
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
案例:我的笔记本安装ubuntu 7.1之后,耳机无声而笔记本的喇叭有声音,调了半天不成功。在音量控制那栏就没有Headphone那项,没法调。


解决方法:
下载最新的Alsa驱动:
1.http://debian.cn99.com/ubuntu/pool/main ... rig.tar.gz
自己编译安装它: (1) sudo ./configure (2)sudo make (3)sudo make install

2.http://debian.cn99.com/ubuntu/pool/main ... u1_all.deb
下载安装。

3.http://debian.cn99.com/ubuntu/pool/main ... u1_all.deb
下载安装。

下载以上文件,第一个驱动需要编译,编译时不要出现错误。后两个直接安装就可以。
全部安装完,重启就解决问题。在音量控制里就会有Headphone一项。

总结:问题在于驱动,源里的驱动有点老(我的源是http://mirrors.shlug.org/),这个驱动是cn99里最新的驱动。如果你是cn99的源,可能就不会出现情况。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-02-18 18:43 
头像

注册: 2008-02-18 16:25
帖子: 140
送出感谢: 0 次
接收感谢: 0 次
我的声卡也忽然出了问题 按你的方法想升级alsa驱动 但是编译不成功……问一下你编译之前下了哪些包?谢谢


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-02-22 11:38 

注册: 2007-12-13 21:26
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
我的在运行sudo ./configure 这一行时显示如下:


checking for gcc... gcc
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.

请问各位大哥这是什么原因,谢谢!!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-02-22 13:05 
头像

注册: 2005-12-23 19:20
帖子: 1677
送出感谢: 0 次
接收感谢: 0 次
不用编译的 找到适合自己的参数 加入到 /etc/modelprof.d/alsa-base 里就Ok了 我就是这样解决的 ALC660


_________________
Kubuntu10.10& Windows 7 ultimate
Acer 4738ZG
Intel PM dual core P6100 2.00G
4G DDR1333
ATI Mobility Radeon HD5470
750G HDD
14.0 WXGA 1366×768


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Ping-Wu, poloshiao 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译