当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]求助:关于显卡驱动安装的问题!
帖子发表于 : 2008-03-11 13:14 

注册: 2008-02-02 21:14
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
我的显卡是NVIDIA 8600GT ,驱动是NV官方的 NVIDIA-Linux-x86-169.12-pkg1 .run AOC的915SW 19寸宽屏显示器
安装过程是 :
1,删除原驱动包 sudo apt-get --purge remove nvidia-glx
然后删除 /lib/linux-restricted-modules/2.6.22-14-generic/文件夹下面带有nvidia字样的3个文件夹
删除 /etc/init.d/nvidia-kernel
2,安装要用到的软件 sudo apt-get install build-essential pkg-config xserver-xorg-dev linux-headers-`uname -r`
3,备份
sudo cp /etc/default/linux-restricted-modules-common/etc/default/linux-restricted-modules-common.backup
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
4,禁止系统使用默认的驱动 sudo gedit /etc/default/linux-restricted-modules-common
在最后的双引号中添加nv nvidia_new,即“”改成“nv nvidia_new”
5,停止GDM进程 sudo /etc/init.d/gdm stop
6,登录,安装驱动 sudo sh NVIDIA-Linux-x86-169.12-pkg1.run
提示缺少kernal,询问是否上网下载,我选的 no
提示将要修改Xorg.conf,询问是否允许,我选的Yes
7,安装完成重启GDM sudo /etc/init.d/gdm restart。
8,一进系统,就弹出对话框,说系统无法识别我的 显示器和显卡,问是否运行于低级图形模式或者是自己配置,我选自己配置。由于那个 对话框的字是在太模糊我只看懂了大概。选的1440X900,勾选了宽屏。然后进入系统,看得 出依然是低级图形模式。我在 系统-系统管理-收限驱动管理器,把未启用改为启用,然后系统提示重启。
9,RESTART以后,又回到第8步,依然还是那个对话框弹出来......
晕死偶了..哪位高手知道是怎么回事么?我上个 UBUNTU系统也是显卡驱动 没有安装成功我才重装的UBUNTU,这回有安装不了。。大虾们为我一这一尘世中迷途小书童指点下吧.....................谢谢拉!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-03-11 13:32 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
把 xorg.conf 贴出来


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-03-11 13:33 

注册: 2008-03-07 17:05
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
一点不成熟的意见

我前几天装的N卡驱动 装好了 3D完美(8600GTm不知道咋地 感觉有点卡) 然后就升级7.10了

升级OK后 显卡又没有了 于是我又装 这个时候情况来了 和你的一模一样 怎么装都装不上去了


------------------------------------------------------------------------------------------
8,一进系统,就弹出对话框,说系统无法识别我的显示器和显卡,问是否运行于低级图形模式或者是自己配置,我选自己配置。由于那个对话框的字是在太模糊我只看懂了大概。选的1440X900,勾选了宽屏。然后进入系统,看得 出依然是低级图形模式。我在系统-系统管理-收限驱动管理器,把未启用改为启用,然后系统提示重启。
9,RESTART以后,又回到第8步,依然还是那个对话框弹出来......
------------------------------------------------------------------------------------------

最后 我是在 应用程序 添加删除里面 删除了关于 N卡的所有相关的 然后nv nvidia_new,即“”改成“nv nvidia_new”

然后再装 。。。。。。。。。。。。。。。。。。。OK了

希望对你有所帮助


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-03-11 17:26 

注册: 2008-02-02 21:14
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
2L 是 /etc/X11/xorg.conf 这个文件么 ??
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg
Section "Files"
EndSection

Section "Module"
Load "glx"
Load "v4l"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "cn"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "Device"
Identifier "Failsafe Device"
Boardname "NVIDIA GeForce 8 Series"
Busid "PCI:1:0:0"
Driver "nvidia"
Screen 0
Vendorname "NVIDIA"
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "True"
EndSection

Section "Monitor"
Identifier "Failsafe Monitor"
Vendorname "Generic LCD Display"
Modelname "LCD Panel 1440x900"
Horizsync 31.5-56.0
Vertrefresh 56.0 - 65.0
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "1280x768@60" 80.14 1280 1344 1480 1680 768 769 772 795 -hsync +vsync
modeline "1280x720@60" 74.48 1280 1336 1472 1664 720 721 724 746 -hsync +vsync
modeline "1280x800@60" 83.46 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
modeline "1440x900@60" 106.47 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Failsafe Device"
Monitor "Failsafe Monitor"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 1440 900
Modes "800x600@60" "1280x768@60" "800x600@56" "1280x720@60" "1280x800@60" "1440x900@60"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"
EndSection
Section "ServerFlags"
EndSection


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-03-11 17:30 

注册: 2008-02-02 21:14
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
3L 我试下你的 方法哈 ~~


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-03-11 17:45 

注册: 2008-02-02 21:14
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
x122075847 写道:
一点不成熟的意见

我前几天装的N卡驱动 装好了 3D完美(8600GTm不知道咋地 感觉有点卡) 然后就升级7.10了

升级OK后 显卡又没有了 于是我又装 这个时候情况来了 和你的一模一样 怎么装都装不上去了


------------------------------------------------------------------------------------------
8,一进系统,就弹出对话框,说系统无法识别我的显示器和显卡,问是否运行于低级图形模式或者是自己配置,我选自己配置。由于那个对话框的字是在太模糊我只看懂了大概。选的1440X900,勾选了宽屏。然后进入系统,看得 出依然是低级图形模式。我在系统-系统管理-收限驱动管理器,把未启用改为启用,然后系统提示重启。
9,RESTART以后,又回到第8步,依然还是那个对话框弹出来......
------------------------------------------------------------------------------------------

最后 我是在 应用程序 添加删除里面 删除了关于 N卡的所有相关的 然后nv nvidia_new,即“”改成“nv nvidia_new”

然后再装 。。。。。。。。。。。。。。。。。。。OK了

希望对你有所帮助

我按照你的方法试了 ,结果还是一样.。不知道是不是我没有删除干净呢?你都删除了哪些软件?


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-03-11 18:08 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
我的参考一下
代码:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Wed Nov 14 17:10:54 PST 2007

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder3)  Wed Sep 12 14:30:30 PDT 2007

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    RgbPath         "/usr/X11R6/lib/X11/rgb"
    FontPath        "/media/vartmphome/ttf-microsoft-fonts"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
#   Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Philips 190CW"
    HorizSync       30.0 - 83.0
    VertRefresh     55.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8600 GT"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "metamodes" "1440x900_60_0 +0+0;"
    Option         "AllowGLXWithComposite" "True"
    Option         "AddARGBGLXVisuals" "True"
    Option         "NoLogo" "True"
    SubSection     "Display"
        Depth       24
        Modes      "1440x900"
    EndSubSection
EndSection


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-03-11 18:15 

注册: 2008-02-02 21:14
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
对了,我想起来了,似乎在提示缺少KERNAL的时候我选了YES。。不走到 是不是这个原因哦。
7L 我是直接用你的代码替换我原来的 代码么?


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-03-11 18:17 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
igomu 写道:
对了,我想起来了,似乎在提示缺少KERNAL的时候我选了YES。。不走到 是不是这个原因哦。
7L 我是直接用你的代码替换我原来的 代码么?


当然不是, 是参考
提示缺少内核模块时要选NO, 否则不能装上


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-03-11 18:59 

注册: 2008-02-02 21:14
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
啊 ```那现在怎么办呢??我想把他彻底卸载了再重新装下,不知道要卸载哪些程序,删除哪些文件,你能告诉我不`?


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-03-11 19:47 

注册: 2008-03-07 17:05
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
看看 我3L时候说的 那个删除 在添加删除程序里面面 删除所有 带NVIDIA的

然后 按照我下面给你粘贴的来 应该就没问题了
=======================================================
装载:ubuntu N卡 驱动
先说说俺的软硬件环境
系统: ubuntu 7.0.4(7.10上面也已经安装成功)
显卡: 8600GTS
驱动 : NVIDIA-Linux-x86-100.14.11-pkg1.run ( 也适用于 100.14.19 )

Nvidia最新的驱动已经支持8系列的显卡了,由于装系统时候还没有支持因此一直没有考虑装驱动的事情(呵呵,虽然没驱动也没啥问题),前一段下了最新的驱动,但是由于本人是个菜鸟一直没学习怎么装,今天花了一个晚上把官方那个安装说明读了一遍,第一次安装遇到了一个问题,google一番之后终于成功了。

如果有人和我的软硬件差不多 ,下面的经验供参考:

官方提供的安装流程大概说的如下:
1. 当然是下载好驱动了,我用的是 NVIDIA-Linux-x86-100.14.11-pkg1.run
2. 安装之前关闭 X server,
3. 运行sh 进行安装
4. 自动安装Kernel Interface (很多人这里出问题,我也是,稍后再说)
5. 配置nvidia-config 文件并更新配置啥地............ 搞定

通常俺们这种菜鸟有几个问题搞不定,其一是安装之前要关闭X server, 其二就是那个安装Kernel Interface,驱动安装时候会自动检测是否有已经编译好的Kernel Interface了,如果没有,驱动有几个安装方式,首先它会让你选择是不是自动连接到nvidia官网进行下载(很不幸,我选择之后下载失败,说没有匹配的),这时候安装程序会让你选择是否让驱动程序为你编译产生这个Kernel Interface,如果是,那么要求你的系统中已经有 libc源码(或者说库,我也不懂具体是啥)。很多人都是在这一步挂掉了,因为系统中没有这个库的源代码。

现在我们来解决这两个问题:
1. 关闭X server:
以前论坛上有过很多人问过这个问题,可惜一直没有找到可行的答案,google几篇老外的文章之后发现其实很简单:
以root权限运行 /etc/init.d/gdm stop 即可,注意,这里最后面那个gdm是为使用gnome的人用的,如果使用kde好像是啥 kdm. 安装成功之后启用x server用这个 /etc/init.d/gdm start.
还有一种途径就是老是有人说的改变那个启动的runlevel, 就是经常看到的init 3之类的。我以前就用这个尝试,没成功。因此推荐和我一样的菜鸟用上面那个方法。

2. 安装libc:
刚才说到,驱动安装时候要安装Kernel Interface,如果采用自己编译的方式则要求系统中有libc的源码。我想一般人都是没有的,呵呵。这个时候我们可以在安装驱动之前先自己把这个源码给安装好,问题就解决了。如何安装?呵呵,更简单,强大的 apt install阿, 运行:
sudo apt-get install libc6-dev
一行命令搞定。

-----更新内容
好了,现在主要的问题都解决了,理应可以安装驱动了,但是很多时候还有一些额外工作要做。
许多时候系统安装了受限驱动之类的,例如不少人装了nvidia-glx, nvidia-glx-new,因此首先确认你是不是一定要自己手动安装驱动(你也可以等着官方升级受限驱动),如果你确定要自己安装,那么需要先删除这些受限驱动并进行一些设置。通常这可以在安装之前完成
首先卸载受限驱动
sudo apt-get remove --purge nvidia-glx nvidia-glx-new
然后删除 /lib/linux-restricted-modules/文件夹下面的内容,注意里面有一个隐藏文件.nvidia-new-installer也要删掉

再检查一下/etc/init.d/nvidia-glx and /etc/init.d/nvidia-kernel这个文件是否存在,删掉它。

最后设置禁用其他的driver驱动模块
sudo gedit /etc/default/linux-restricted-modules-common (命令行下请用vi之类的修改)
将其中的 DISABLED_MODULES="" 改为:DISABLED_MODULES="nv nvidia_new"

OK,至此应该就已经卸载了受限驱动并且设置好了,可以开始安装驱动过程了。
请注意,这里如果为了保险大家也可以在手动安装驱动之后进行以上过程,不过那需要在命令行下操作,请先确认你已经掌握了相关命令。
----更新结束。

开始安装。假设你正在看这篇帖子,同时你的驱动 xxx.run 这个文件也下载到了某一个目录如 /home/yourname/xxx.run。
Let's start.

1. 防患于未然,先装libc, 运行 sudo apt-get install libc6-dev, 下载,安装,成功。
2. ctrl + alt + F2, 这时候你应该看到黑屏,呵呵,当然现在你的x server 并没有关闭,不信?ctrl + alt + F7 , 又回来了不是?
3. 回到1 里面的黑屏,这时候应该能看到要求login的指令,用root登录,输入密码,搞定
4. ok, 现在可以关闭 X server 了,运行 /etc/init.d/gdm stop. (如果你不用gnome,,自己google一下)。看到一则关闭OK的消息。这时候X server真正关闭了。不信?再试试 ctrl + alt +F7, 没反应了把,还是黑屏!(还真试阿?再用 ctrl + alt +F2 退回去把)
5. 运行安装程序 sh /home/yourname/xxx.run 呵呵,这时候应该看到界面了,选择一下什么ok之类的就好,然后到那个下载Kernel Interface,再到自己编译界面,应该比较顺利。
6. OK,编译好了,安装完了,安装程序会询问你是否自动更新配置,对于我这样的懒人之接ok就好了。

注意这一步,其实推荐做法是不要自动配置,但是实际上驱动安装时候确实要进行相关配置,因此绝大多数时候直接让安装程序帮你设置就好。为了保险起见,可以在自动配置之后再手动check一下就好,只需要看 xorg.conf里面的
Section "Device" 下面的 Driver "XX" 是否为 Driver "nvidia" 即可, 可以用 命令 sudo nano /etc/X11/xorg.conf检查或者修改。
诸如分辨率之类可以在启动X server 之后,用 nvidia的工具修改:
gksudo nvidia-settings
这个工具是个图形界面,就不用介绍了

7. 检查以前的受限驱动是否卸载,相关驱动模块是否禁用(见上面更新部分),如果已经做过了,此步可以省略。

8. 重新启动 X server, 运行 /etc/init.d/gdm start. 如果不出意外,呵呵,应该是画面一闪,nvidia的logo出现了,然后出现图形登录界面。恭喜,你成功了!!

废话就这么多了,祝大家好运!!
最后附上一张启用特效成功的截图

-----以下为更新部分

有人反应说这样安装之后第一次启用X server没有问题,但是重启之后就刮掉了,经验证确实存在这个现象,google之后发现很多人有这个问题,经资料搜集出现这个问题的最大可能性就是没有删除以前的驱动,从而引起了一些匹配问题,发现正如楼下 “猛将兄”所言,需要删除一些东西,我发现一般的教程都没有写这个,倒是一些老外的论坛上面有提到过,它们的一般做法是安装之前把就驱动卸载掉,不论是 nvidia-glx还是nvidia-glx-new。删除办法上面已经讲过了。

这里还有一步也相当重要,很多人提到需要禁用几个driver的驱动模块, 方法是编辑/etc/default/linux-restricted-modules-common,相关操作也在上面讲过了。


---------------------以下为9月25日更新
加上100.14.19新版本的驱动安装,有两个办法可以安装,你是如上文所述,自行下载好NVIDIA-Linux-x86-100.14.19- pkg1.run,安装时候直接sh 就可以了(呵呵,废话!!)。另外一个办法就是直接让驱动自己去更新,假设已经有了11版,但是没有19版,可以在安装的时候加上更新参数 --update, 也即运行
sh NVIDIA-Linux-x86-100.14.11-pkg1.run --update
此时安装程序会自动连接到官方服务器去下载新版本然后安装。




这几天用ubuntu上网特慢,发现在解析DNS时基本卡住,搜索了一下找到了一个解决办法。
通过设置DNS缓存来提高上网速度,我自己试过了,确实是解决了我的问题。

-------------------------------------
转载地址 url: http://forum.ubuntu.org.cn/viewt ... A%E7%BD%91%E6%85%A2
-------------------------------------

论坛里面有不少关于 firefox上网慢的话题。

有的说把IPv6的协议禁用,还有的对firefox进行配置,实际使用效果都不好。

我仔细看过所谓对firefox的优化参数之后,发现它们大多只不过添加了 多线程下载网页的功能,所以实际用处不大。

不信,你可以打开终端, 同时用 w3m (文字版的互联网浏览器) 和firefox打开一个你从未访问过的网页,你会发现,其实w3m也很慢。
这就说明了,浏览慢,并不仅仅是浏览器的问题。

所有这些东西,其实只用安装一个 叫做 fasterfox 的firefox浏览器扩展插件就可以自动给你设置了。设置一些优化参数的确对加快firefox的运行,而不是浏览速度 ,有帮助。

上网慢 真正的原因,仔细观察会发现,主要在firefox 花费在解析域名 的时间上。

所以有必要设置DNS缓存。

windows下面是自动设置的,所以不用操心。

在ubuntu下面就要花费一番功夫了。

所以需要装一个 叫做 dnsmasq的软件,它能提供dns解析的功能。
当然,改造一下,也能提供dns缓存的功能。

_____________________________________
具体操作
---------------------

安装dnsmasq
命令: sudo apt-get install dnsmasq

编辑dnsmasq的配置文件
命令: sudo gedit /etc/dnsmasq.conf

找到下面这一项
#resolv-file=

用下面的一条语句替换
resolv-file=/etc/resolv.dnsmasq.conf

确保你没有更改过/etc/resolv.conf文件,如果改过,恢复原状
然后执行命令
sudo cp /etc/resolv.conf /etc/resolv.dnsmasq.conf

然后编辑resolv.conf
命令;sudo gedit /etc/resolv.conf

将其中的域名服务器全部去掉,加入以下这行
nameserver 127.0.0.1

保存,退出

执行以下命令
sudo gedit /etc/ppp/peers/dsl-provider
在 usepeerdns 前面增加 # ,也就是把这条语句覆盖掉。
以防,resolv.conf的设置被pppoe覆盖。

重启电脑。不重启,你会发现无法解析域名。所以一定要重启电脑,来达到重新启动dnsmasq的目的。
重启后, 你会发现firefox的解析速度比以前快了N个数量级。

下载libmsn.so
和libpurple.so.0.0.1
这两个文件,把 libpurple.so.0.0.1 ,拷入/usr/lib
把libmsn.so拷到/usr/lib/purple-2/就可以了。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-03-31 22:33 
头像

注册: 2008-03-07 12:19
帖子: 50
送出感谢: 0 次
接收感谢: 0 次
我的也是8系列显卡8500GT ,按照上面的方法使用官方最新驱动NVIDIA-Linux-x86_64-169.12-pkg2.run装好了驱动(CPU:AMD4000+),勾选了“启用受限制的显卡驱动”,每次登录前都会有显示nVIDIA 的 Logo ,但就是开不了compiz,提示nVIDIA没有通过!这个3D真要命,折腾了我几个晚上,到现在还在折腾中。。。。 :cry:


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译