当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 20 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 有没有兄弟在Ubuntu下用过HP LaserJet 1000的打印机
帖子发表于 : 2005-06-28 21:38 
头像

注册: 2005-04-10 16:54
帖子: 2625
地址: 温州大学
送出感谢: 0 次
接收感谢: 1
同上!

不知要如何设置


_________________
我心无畏,源自于我心无知。
图片


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-06-28 21:47 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
http://www.ubuntuforums.org/showthread. ... P+LaserJet

不知这个有没帮助?
看样子应该是有root权限才能打印。
不清楚你的情况是怎么样


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-06-28 21:52 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
哈,这帖跟你型号一样的:
http://www.ubuntuforums.org/showthread. ... P+LaserJet


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-06-28 22:08 
头像

注册: 2005-04-10 16:54
帖子: 2625
地址: 温州大学
送出感谢: 0 次
接收感谢: 1
真是太感谢兄弟了!
我写了信给HP,给回了:
Thank you for contacting HP Customer Care.

Although, many HP printers including the HP LaserJet 1000 are capable of printing from Linux, HP does not write drivers on Linux platform. We suggest that you contact the appropriate vendor for further assistance in this regard.

You may wish to visit the following URL for information on Linux PPD and model scripts:

http://h20000.www2.hp.com/bizsuppor...jectID=bpl70481

http://h20000.www2.hp.com/bizsuppor...jectID=bpl01713

Once again, thank you for contacting HP Customer Care.

看来还不如在这儿问呢!呵呵!

去看看先!!明天再做下试验,试验情况明天在此作回复!


_________________
我心无畏,源自于我心无知。
图片


最后由 firehare 编辑于 2005-06-29 13:39,总共编辑了 1 次

页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-06-28 22:12 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
嘿嘿,,HP反应这么快啊?!赞!


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
6 楼 
 文章标题 : [分享]Ubuntu下HP LaserJet 1000打印机的安装步骤
帖子发表于 : 2005-06-30 15:08 
头像

注册: 2005-04-10 16:54
帖子: 2625
地址: 温州大学
送出感谢: 0 次
接收感谢: 1
首先安装CUPS系统
$sudo apt-get install cupsys cupsomatic-ppd
$sudo apt-get install cupsys-bsd cupsys-driver-gimpprint

安装下面两个包,否则得不到PPD文件
$sudo apt-get install foomatic-bin foomatic-db

由于我是用Server命令安装的Ubuntu操作系统,所以要添加最基本的编译软件
$sudo apt-get install dpkg-dev file gcc g++
$sudo apt-get install make autoconf automake

下载foo2zjs
$wget http://home.mn.rr.com/richardsons/foo2z ... zjs.tar.gz
$make
==========以下操作现已失效============
本来是想删除的,不过由于这段对于理解比较有效暂时保留
由于在下一步中会用到getweb脚本,其中要用到unzip命令,所以安装
$sudo apt-get install zip unzip
$./getweb 1000
该命令相当于:
$wget ftp://ftp.hp.com/pub/softlib/software1/ ... 1488en.exe
$unzip -o lj1488en.exe sihp1000.img
$rm -f lj1488en.exe

因为./getweb命令无效,可能是因为unzip对该exe文件(自解压文件)不能正常解压,所以可以在Windows下先解压出sihp1000.img文件之后,再导入到Linux下使用。
================================

下载sihp1000.img
$wget ftp://ftp.hp.com/pub/softlib/software1/ ... 1488en.exe
在Windows下将其解压后,提取出sihp1000.img文件。之所以要这个文件的原因就是因为该款打印机在断电之后都要重新加载一个firmware才能正常工作。因此你还应该在每次打印机断电之后以root身份载入sihp1000.img
$sudo -s
#cat sihp1000.img > /dev/usb/lp0
在做这一步时,你可以听到打印机被驱动的声音了。

然后将sihp1000.img拷贝到foo2zjs的安装目录下,就可以开始安装了
#make install
你应该在/usr/share/foo2zjs/firmware文件目录下看到sihp1000.dl文件。驱动的源xml文件则被安装到/usr/share/foomatic/db/source下的三个目录内,正是我们需要的!

现在做foomatic编译db就可得到.ppd文件了!
#foomatic-compiledb
然后在你的用户目录的PPD目录中就可以看到是否得到了HP LaserJet 1000的ppd文件了。

将其中的HP-LaserJet_1000*.ppd文件拷至/usr/share/cups/model/目录下
然后重启CUPS服务

#/etc/init.d/cupsys restart

由于是命令行,因为毕竟是用作Server,当然不会去用X桌面了,所以
#lpadmin -p HP-LJ1000 -E -v usb:/dev/usb/lp0 -m HP-LaserJet_1000-foo2zjs.ppd
这样就添加好了一台名为HP-LJ1000的打印机了

然后如果等不及就试试看效果吧
#lp -d HP-LJ1000 -p 90 /etc/network/interfaces
看看是不是可以打印了?祝你好运!!


_________________
我心无畏,源自于我心无知。
图片


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-12-25 16:39 

注册: 2005-07-07 9:13
帖子: 93
送出感谢: 0 次
接收感谢: 0 次
如何把ubuntu下的打印机共享给WINDOWS呢,让WINDOWS下安装ubuntu共享的网络打印机?
我遇到的问题是WINDOWS下能看到ubuntu下的打印机,安装ubuntu共享的打印机,提示用户没有权限,我应该用那个用户呢?


页首
 用户资料  
 
8 楼 
 文章标题 : Re: [分享]Ubuntu下HP LaserJet 1000打印机的安装步骤
帖子发表于 : 2006-02-23 0:26 

注册: 2005-12-12 0:02
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
firehare 写道:
首先安装CUPS系统
$sudo apt-get install cupsys cupsomatic-ppd
$sudo apt-get install cupsys-bsd cupsys-driver-gimpprint


然后如果等不及就试试看效果吧
#lp -d HP-LJ1000 -p 90 /etc/network/interfaces
看看是不是可以打印了?祝你好运!!


能说说如何安装EPSON 1600K打印机吗?


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-02-23 8:26 
头像

注册: 2005-04-10 16:54
帖子: 2625
地址: 温州大学
送出感谢: 0 次
接收感谢: 1
没环境!


_________________
我心无畏,源自于我心无知。
图片


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-07-09 16:26 
头像

注册: 2006-07-09 15:34
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
kan bu dong a


页首
 用户资料  
 
11 楼 
 文章标题 : 疑问
帖子发表于 : 2006-07-17 22:15 

注册: 2006-06-09 9:24
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
我这里有一台hp1000的机器,照上面弄了下。cat sihp1000.img >/dev/usb/lp0 时usb目录不存在只能cat sihp1000.img >/dev/usblp0,这是我确实听到了打印机被驱动的声音了,但是没有办法再往下面做了,make install 出错,无法按你的方法做下去,希望有高人指出条明路


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 疑问
帖子发表于 : 2006-07-18 9:04 

注册: 2005-10-14 22:46
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
Gone 写道:
我这里有一台hp1000的机器,照上面弄了下。cat sihp1000.img >/dev/usb/lp0 时usb目录不存在只能cat sihp1000.img >/dev/usblp0,这是我确实听到了打印机被驱动的声音了,但是没有办法再往下面做了,make install 出错,无法按你的方法做下去,希望有高人指出条明路


6.06里面已经有了HP 1000 的驱动程序了。不需要这么费事了吧?直接添加打印机就可以了


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2006-07-21 17:04 

注册: 2006-07-21 16:15
帖子: 86
送出感谢: 0 次
接收感谢: 0 次
最近我在sharp的板子上配置打印机,用的就是hp 1010的机器。在pc机器正如楼上们说的,都没问题。但是在往开发板里配置cups时就不行了。在解压cupsys的依赖包libc6_2.3.6-0ubuntu20_i386.deb时出现错误:Accessing a corrupted share library,然后输入的一些比如ls,vi等命令都不识别了,重启的话连系统都进不去了,郁闷啊!!好像是解压这个包会破坏的系统的共享库,为什么会这样啊


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2006-08-12 11:53 

注册: 2005-07-18 18:20
帖子: 188
地址: http://www.gdgpi.com.cn
送出感谢: 0 次
接收感谢: 0 次
奇怪我这里并没有 /dev/usb 这样的目录和文件,只有/dev/usblp0

而且执行

代码:
sudo -s
cat sihp1000.img > /dev/usblp0

会有这样的提示:

bash: /dev/usblp0: Device or resource busy

打印机并没有被驱动起来。

如果我用
代码:
lsusb

结果是这样的:

引用:
Bus 004 Device 001: ID 0000:0000
Bus 001 Device 003: ID 03f0:0517 Hewlett-Packard LaserJet 1000
Bus 001 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000


_________________
进门莫问姓名,芳草满庭皆无主;
入室自分雅路,四厢弦歌尽留人。


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-04-01 14:35 

注册: 2007-03-31 22:08
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
$ sudo apt-get install cupsys cupsomatic-ppd
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
cupsys 已经是最新的版本了。
现在没有可用的软件包 cupsomatic-ppd,但是它被其它的软件包引用了。
这可能意味着这个缺失的软件包可能已被废弃,
或者只能在其他发布源中找到
可是下列的软件包取代了它:
foomatic-filters-ppds foomatic-filters
E: 软件包 cupsomatic-ppd 还没有可供安装的候选者

我用的是wiki上推荐的源,找不到cupsomatic-ppd
还有我的机器上也没有这个什么/dev/usb/目录啊
楼上的用的什么版本?
我的是61


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 20 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译