当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]没有找到音量控制插件和设备
帖子发表于 : 2008-03-14 14:37 

注册: 2008-03-09 10:00
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
我装的是7.10,小喇叭上有个红色的禁止标志,双击音量控制会出现“没有找到音量控制插件和/或设备”,我装过声卡驱动试了,找不到modules.conf文件,只有modules和modprobe.conf文件,而且modules文件内容如下:
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

fuse
lp

是不是声卡没有启动?
我刚学,期待高手解决
这个问题我已经解决了,方法如下(我是参考:http://ubuntuforums.org/showthread.php?t=205449)
我的声卡为ATI IXP SB600 Realtek AC97 Audio ,按理说应该容易装,可是我却试了好多种办法,包括oss的驱动我也试过,最后在我绝望的时候,抱着最后一次如果没有装好就不用它的时候,竟然成功了。我的方法是:
1.在终端输入aplay –l,目的是检测声卡
Code:aplay –l
如果成功就会列出所有声卡,说明不需要装驱动,有可能是静音了等。
如果出现:aplay: device_list:221: no soundcard found...
就进行下一步。我的就是这样。
2.列出你的硬件设备
Code:lspci –v
如果你的声卡在它列出的信息内,有救,说明只是声卡驱动没有装好或没有运行。
如果没有被检测出来,麻烦了。
我的检测出来了,进行下一步。
3.到网上查找看有没有支持你的声卡的驱动,每一种类型的声卡都有一个代号snd-xxxxx,比方说我的声卡代号是snd-atiixp,以下是一些常见的声卡代号:
snd-xxxx is the card ID.
-- Azalia controller --ALC880 ALC882 ALC260 ALC262
--- Intel ICH6 ICH7 ---------
snd-hda-intel
--- ATI chipset -----
snd-atiixp
-- AC97 controller --ALC655 ALC650 ALC250 ALC255
--- Intel ICH6 ICH7 , SiS 7012 and NVidia----------
snd-intel8x0
--- Via8233 Via686a -------------------------------
snd-via82xx
--- ATI Chipset -------------------------------
snd-atiixp
4.
Code:sudo modprobe snd-atiixp(这是我的声卡)
如果成功了,就说明你的声卡已经安装了,只是没有加载。我的没有反应,我不知道成功没有,我看了一下edit /etc/modules文件,在后面加了一项:snd-atiixp
5.安装驱动
Code: sudo apt-get install build-essential linux-headers-$(uname -r) module-assistant alsa-source
sudo dpkg-reconfigure alsa-source
You now have a big blue dialog box (left and right keys to choose 'Yes' and 'No', Enter key proceed). Answer yes (for ISA-PNP - recommended by package maintainers), then yes again (for debugging - recommended by package maintainers).
注意,选择驱动的时候,有星号*的是有效的,按空格键去掉或打上*。我选的是atiixp
6.下面的步骤有两种供选择。
a.选择module-assistant
code:sudo module-assistant a-i alsa-source
If the progress bar reaches 100% with no errors, you will have installed the drivers successfully
我的没有成功。我又按下面的方法试了一下。
b.没有选择module-assistant,哪么你需要记住你的声卡的id,我的是snd-atiixp
code: cd /usr/src
sudo tar xjvf alsa-driver.tar.bz2
cd modules/alsa-driver
sudo ./configure --with-kernel=/usr/src/linux-headers-$(uname -r) --with-cards=<enter driver name here e.g. atiixp> --with-oss=yes
sudo make
sudo make install
./snddevices
重启后,我不可思议的听到了声音。


最后由 yuzhouwangqiao 编辑于 2008-03-17 12:39,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-03-14 14:57 

注册: 2007-04-10 16:08
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
我也遇到了同样的问题,帮忙顶一下


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-03-16 10:25 

注册: 2008-03-16 10:16
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
我的情况完全一样 , 定一下


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-03-17 10:07 

注册: 2006-12-16 19:39
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
顶!


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-03-18 20:29 

注册: 2008-03-17 15:15
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
00:14.5 Multimedia audio controller: ATI Technologies Inc SB600 AC97 Audio
Subsystem: Jetway Information Co., Ltd. Unknown device 6801
Flags: bus master, 66MHz, slow devsel, latency 64, IRQ 5
Memory at fe027000 (32-bit, non-prefetchable) [size=256]
Capabilities: [40] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
上面是我lspci –v后 的关于声卡的信息,请教一 下接下来应该怎么弄


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-03-22 15:07 

注册: 2008-03-09 10:00
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
按步骤往下就行了。你可以先不添加snd-xxxx,跳过这一步,往下有一步会列出许多声卡代号,应该有你那样的,


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-03-22 15:11 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 273
http://ubuntuforums.org/showthread.php?t=205449
是这帖子。以前有声卡问题,按照这步骤走。一样无用的。看rp。当时是内核版本的问题。只好hold了内核版本。


_________________
● 鸣学


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-03-22 16:23 

注册: 2008-03-22 14:46
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
弄了半天依然不行,驱动一直都有,可就是没有声音。。。。 :!:


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-04-01 19:43 
头像

注册: 2007-06-27 14:54
帖子: 74
送出感谢: 0 次
接收感谢: 0 次
sudo ./configure --with-kernel=/usr/src/linux-headers-$(uname -r) --with-cards=<hda-intel> --with-oss=yes


bash: hda-intel: No such file or directory


我该怎么办?急死人了


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-04-01 20:29 
头像

注册: 2007-06-27 14:54
帖子: 74
送出感谢: 0 次
接收感谢: 0 次
sudo modprobe snd-hda-intel
[sudo] password for allen:
FATAL: Module snd_hda_intel not found.


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-04-03 15:50 

注册: 2008-03-31 15:38
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
me too :cry:


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-04-04 1:05 

注册: 2007-10-23 11:19
帖子: 87
送出感谢: 0 次
接收感谢: 0 次
384340 写道:
sudo ./configure --with-kernel=/usr/src/linux-headers-$(uname -r) --with-cards=<hda-intel> --with-oss=yes


bash: hda-intel: No such file or directory


我该怎么办?急死人了


<hda-intel>

这个<>是不用的,去掉就可以了。

重启了3次,我的Live0600声卡,也终于安装成功了,晕!


页首
 用户资料  
 
13 楼 
 文章标题 : Re: [问题]没有找到音量控制插件和设备
帖子发表于 : 2008-11-18 0:26 

注册: 2007-07-06 14:40
帖子: 52
送出感谢: 0 次
接收感谢: 0 次
http://ubuntuforums.org/showthread.php?t=205449
这个帖子比较有用。


页首
 用户资料  
 
14 楼 
 文章标题 : Re: [问题]没有找到音量控制插件和设备
帖子发表于 : 2009-02-13 10:15 

注册: 2008-07-21 19:11
帖子: 55
地址: 北京
送出感谢: 0 次
接收感谢: 0 次
Thanks.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Bing [Bot] 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译