[问题]n卡驱动无法安装

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
头像
godduv
帖子: 46
注册时间: 2006-12-22 18:53
送出感谢: 0
接收感谢: 0

[问题]n卡驱动无法安装

#1

帖子 godduv » 2008-03-18 20:52

安装n卡驱动,出现下面的错误。
本来安装ati的卡,今天a卡损坏,所以启用主板集成的n卡。结果发现无法安装。
a卡驱动已全部卸载,compize已卸载。
google未找到解决方法。
期待高人给分析一下问题出在哪里。

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
正在读取扩展状态文件
正在初始化软件包状态... 完成
创建标签数据库... 完成
下列“新”软件包将被安装。
nvidia-glx-new
0 个软件包被升级,新安装1 个, 0 个将被删除, 同时 0 个将不升级。
需要获取 0B/8891kB 的存档。 解包后将要使用 26.6MB。
正在编辑扩展状态信息... 完成
(正在读取数据库 ... 系统当前总共安装有 130625 个文件和目录。)
正在解压缩 nvidia-glx-new (从 .../nvidia-glx-new_100.14.19+2.6.22.4-14.10_amd64.deb) ...
dpkg-divert: “diversion of /usr/X11R6/lib32/libGL.so.1 to /usr/X11R6/lib32/nvidia/libGL.so.1.xlibmesa by nvidia-glx-new” 与 “diversion of /usr/X11R6/lib32/libGL.so.1 to /usr/X11R6/lib32/fglrx/libGL.so.1.xlibmesa by xorg-driver-fglrx” 冲突
dpkg:处理 /var/cache/apt/archives/nvidia-glx-new_100.14.19+2.6.22.4-14.10_amd64.deb (--unpack)时出错:
子进程 pre-installation script 返回了错误号 2
在处理时有错误发生:
/var/cache/apt/archives/nvidia-glx-new_100.14.19+2.6.22.4-14.10_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
软件包安装失败。正在试图恢复:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
正在读取扩展状态文件
正在初始化软件包状态... 完成
创建标签数据库... 完成
头像
godduv
帖子: 46
注册时间: 2006-12-22 18:53
送出感谢: 0
接收感谢: 0

#2

帖子 godduv » 2008-03-18 21:19

搞定
sudo dpkg-divert --remove /usr/lib32/libGL.so.1
sudo dpkg-divert --remove /usr/X11R6/lib32/libGL.so.1

然后重新安装驱动。重启OK
头像
ddffee
帖子: 179
注册时间: 2008-03-10 5:09
送出感谢: 2 次
接收感谢: 0
联系:

Re: [问题]n卡驱动无法安装

#3

帖子 ddffee » 2008-11-04 0:28

我今天也遇到这个问题了
不过按搂主说的无效
:em06
我去下了一个nvdia-glx-new的amd的deb
然后解压
把里面lib32那个文件夹里面的东西放到usr/lib32下面就好了
回复

回到 “常用硬件支持”