当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 23 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 5.1下ATI驱动如何安装?
帖子发表于 : 2006-03-14 0:55 

注册: 2005-10-03 3:30
帖子: 142
送出感谢: 0 次
接收感谢: 0 次
请教一个问题,我的显卡是ATI X300,我用sudo apt-get install xorg-driver-fglrx装了源里面的驱动,没有提示错误信息,安装成功,但是驱动没有生效,硬件加速也没有起来。我用glxinfo查看,里面显示direct rendering: No


请问这个问题如何解决?谢谢


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-03-14 4:29 

注册: 2005-09-15 18:48
帖子: 43
送出感谢: 0 次
接收感谢: 0 次
你还没有设置驱动。安装完成后:
sudo dpkg-reconfigure xserver-xorg
选择驱动的时候选“fglrx”(其他的基本上可以一路回车)。
或者直接用文本编辑器修改/etc/X11/xorg.conf,将其中的“ati”改成“fglrx”。
如果fglrx是dapper中的8.23.7的话,也可以直接用sudo aticonfig --initial来完成对xorg.conf的初始化。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-03-14 22:21 

注册: 2005-10-03 3:30
帖子: 142
送出感谢: 0 次
接收感谢: 0 次
不行啊,我照你的方法,手工修改了xorg.conf,把里面的ati换成了fglrx,之后X就挂掉了,呵呵~~~~~~

这时什么原因啊?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-03-14 22:43 

注册: 2005-10-03 3:30
帖子: 142
送出感谢: 0 次
接收感谢: 0 次
安装成功了,谢谢zhouke的帮助。
我是用下面的方法装的:

1. sudo apt-get install xorg-driver-fglrx

2. echo fglrx | sudo tee -a /etc/modules (水平有限,搞不清楚这个命令是干什么呢的)

3. 修改/etc/X11/xorg.conf,将里面的ati换成fglrx

4. sudo depmod -a; sudo modprobe fglrx (呵呵,这个命令也搞不清楚是干什么)

5. reboot


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-03-14 22:45 

注册: 2005-09-15 18:48
帖子: 43
送出感谢: 0 次
接收感谢: 0 次
有没有从新启动?
如果你用的是5.10的话,我觉得最好还是不要用源里的那个驱动,根据我的经验,我的8500LE在那个驱动下从来都没有用起过,安装完毕后就会死机。源里那个驱动好像是8.16.20吧,估计和官方的8.16.20是一样的,原来也用过官方的8.16.20就是同样的症状。而且不只是在Ubuntu下,其他Linux下也用不起。最好用官方的最新版驱动8.23.7。具体的安装方法可以在主页上搜fglrx。和那个8.18.8的安装方法相同。http://www.ubuntu.org.cn/support/documentation/wiki/ATI-fglrx-driver-8.18.8/?searchterm=fglrx


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-04-14 19:02 
头像

注册: 2006-04-13 23:07
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
谢谢cashlu的方法,我的是ATI X200,我用了得屏幕的刷新率就可以去到85Hz了,真是很感动。为了这个我已经搞了好几天


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-04-14 22:27 

注册: 2005-10-03 3:30
帖子: 142
送出感谢: 0 次
接收感谢: 0 次
培培 写道:
谢谢cashlu的方法,我的是ATI X200,我用了得屏幕的刷新率就可以去到85Hz了,真是很感动。为了这个我已经搞了好几天


呵呵~~~~~成功就好,共同学习!


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-04-15 14:13 
头像

注册: 2005-10-03 15:25
帖子: 335
送出感谢: 0 次
接收感谢: 0 次
我按照做了为何还会
引用:
donny@ubuntu:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)
谢谢


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-04-15 14:13 
头像

注册: 2005-10-03 15:25
帖子: 335
送出感谢: 0 次
接收感谢: 0 次
我按照做了为何还会
引用:
donny@ubuntu:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)
谢谢


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-04-15 14:14 
头像

注册: 2005-10-03 15:25
帖子: 335
送出感谢: 0 次
接收感谢: 0 次
cashlu 写道:
安装成功了,谢谢zhouke的帮助。
我是用下面的方法装的:

1. sudo apt-get install xorg-driver-fglrx

2. echo fglrx | sudo tee -a /etc/modules (水平有限,搞不清楚这个命令是干什么呢的)

3. 修改/etc/X11/xorg.conf,将里面的ati换成fglrx

4. sudo depmod -a; sudo modprobe fglrx (呵呵,这个命令也搞不清楚是干什么)

5. reboot


我按照做了为何还会
引用:
donny@ubuntu:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)
谢谢


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-04-15 15:23 
头像

注册: 2005-08-02 7:23
帖子: 773
地址: 上海
送出感谢: 0 次
接收感谢: 1
donny 写道:
cashlu 写道:
安装成功了,谢谢zhouke的帮助。
我是用下面的方法装的:

1. sudo apt-get install xorg-driver-fglrx

2. echo fglrx | sudo tee -a /etc/modules (水平有限,搞不清楚这个命令是干什么呢的)

3. 修改/etc/X11/xorg.conf,将里面的ati换成fglrx

4. sudo depmod -a; sudo modprobe fglrx (呵呵,这个命令也搞不清楚是干什么)

5. reboot


我按照做了为何还会
引用:
donny@ubuntu:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)
谢谢

别忘了:
代码:
 sudo apt-get install linux-restricted-modules-`uname -r`


_________________
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.


最后由 catinsnow 编辑于 2006-04-16 12:20,总共编辑了 1 次

页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2006-04-16 11:04 
头像

注册: 2005-10-03 15:25
帖子: 335
送出感谢: 0 次
接收感谢: 0 次
catinsnow 写道:
donny 写道:
cashlu 写道:
安装成功了,谢谢zhouke的帮助。
我是用下面的方法装的:

1. sudo apt-get install xorg-driver-fglrx

2. echo fglrx | sudo tee -a /etc/modules (水平有限,搞不清楚这个命令是干什么呢的)

3. 修改/etc/X11/xorg.conf,将里面的ati换成fglrx

4. sudo depmod -a; sudo modprobe fglrx (呵呵,这个命令也搞不清楚是干什么)

5. reboot


我按照做了为何还会
引用:
donny@ubuntu:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)
谢谢

别忘了:
代码:
 sudo apt-get install linux-restricted-modules-`uname -r

哦,不过我已经换成8。24。8了,但似乎问题依旧,不知道大哥的这个提示是否对8.24.8有用,谢了,先试试


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2006-04-16 11:22 
头像

注册: 2005-10-03 15:25
帖子: 335
送出感谢: 0 次
接收感谢: 0 次
catinsnow 写道:
donny 写道:
cashlu 写道:
安装成功了,谢谢zhouke的帮助。
我是用下面的方法装的:

1. sudo apt-get install xorg-driver-fglrx

2. echo fglrx | sudo tee -a /etc/modules (水平有限,搞不清楚这个命令是干什么呢的)

3. 修改/etc/X11/xorg.conf,将里面的ati换成fglrx

4. sudo depmod -a; sudo modprobe fglrx (呵呵,这个命令也搞不清楚是干什么)

5. reboot


我按照做了为何还会
引用:
donny@ubuntu:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)
谢谢

别忘了:
代码:
 sudo apt-get install linux-restricted-modules-`uname -r

试了但下载不了
引用:
donny@ubuntu:~$ sudo apt-get install linux-restricted-modules-`uname -r
>

这样就不动了


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2006-04-16 12:20 
头像

注册: 2005-08-02 7:23
帖子: 773
地址: 上海
送出感谢: 0 次
接收感谢: 1
不好意思,应该这样:
代码:
sudo apt-get install linux-restricted-modules-`uname -r`

最后一个"`"漏掉了.


_________________
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2006-04-21 19:56 
头像

注册: 2005-10-03 15:25
帖子: 335
送出感谢: 0 次
接收感谢: 0 次
catinsnow 写道:
不好意思,应该这样:
代码:
sudo apt-get install linux-restricted-modules-`uname -r`

最后一个"`"漏掉了.
谢谢大哥了,我去试试,但愿能成功。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 23 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译