当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求救!!更新后,系统大面积出错
帖子发表于 : 2008-04-05 9:03 
头像

注册: 2008-04-04 12:32
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
EVA不能用了,一用就注销
显卡被禁用了并且出现

需要安装软件包

linux-restricted-modules-2.6.22-14-generic

以使软件正常工作。

画面延迟严重....

试图重装 linux-restricted-modules-2.6.22-14-generic,但出现

正在读取软件包列表... 完成
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
正在筹划升级... 完成
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
有 3 个软件包没有被完全安装或卸载。
需要下载 0B 的软件包。
解压缩后会消耗掉 0B 的额外空间。
您希望继续执行吗?[Y/n]y
正在设置 linux-image-2.6.22-14-generic (2.6.22-14.52) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.22-14-generic
Not updating initrd symbolic links since we are being updated/reinstalled
(2.6.22-14.46 was configured last, according to dpkg)
Not updating image symbolic links since we are being updated/reinstalled
(2.6.22-14.46 was configured last, according to dpkg)
Running postinst hook script /sbin/update-grub.
[: 25: ==: unexpected operator
exec: 25: -a: not found
User postinst hook script [/sbin/update-grub] exited with value 2
dpkg:处理 linux-image-2.6.22-14-generic (--configure)时出错:
子进程 post-installation script 返回了错误号 2
dpkg:依赖关系问题使得 linux-ubuntu-modules-2.6.22-14-generic 的配置工作不能继续:
linux-ubuntu-modules-2.6.22-14-generic 依赖于 linux-image-2.6.22-14-generic;然而:
软件包 linux-image-2.6.22-14-generic 还没有被配置。
dpkg:处理 linux-ubuntu-modules-2.6.22-14-generic (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 linux-restricted-modules-2.6.22-14-generic 的配置工作不能继续:
linux-restricted-modules-2.6.22-14-generic 依赖于 linux-image-2.6.22-14-generic;然而:
软件包 linux-image-2.6.22-14-generic 还没有被配置。
dpkg:处理 linux-restricted-modules-2.6.22-14-generic (--configure)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
linux-image-2.6.22-14-generic
linux-ubuntu-modules-2.6.22-14-generic
linux-restricted-modules-2.6.22-14-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)



请问达人怎么解决阿....
画面不仅有延迟,还有花频的现象....XP上没出现,且是更新完后才出现的。

PS. 我的版本是7.10,然后昨天更新,都不知道现在成什么版本了。我是用更新管理器更新的。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-04-05 9:19 
头像

注册: 2007-01-15 17:15
帖子: 3766
送出感谢: 0 次
接收感谢: 0 次
这个就不需要琢磨,过两天再 update dist-upgrade 一次,或者改源,


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-04-06 20:54 
头像

注册: 2008-04-04 12:32
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
iblicf 写道:
这个就不需要琢磨,过两天再 update dist-upgrade 一次,或者改源,


没看懂你的代码...执行不了,等下次更新要等多久阿~~


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-04-06 21:23 
头像

注册: 2007-11-22 10:20
帖子: 3406
地址: 北京
送出感谢: 0 次
接收感谢: 1
St.GruB 写道:
iblicf 写道:
这个就不需要琢磨,过两天再 update dist-upgrade 一次,或者改源,


没看懂你的代码...执行不了,等下次更新要等多久阿~~

说一个方法,是我就会这么解决:

代码:
sudo gedit /etc/apt/sources.list

换成官方源,速度不行就晚上再更新。

代码:
sudo apt-get autoremove

把没有用的库文件给咔嚓了,怕升级出麻烦。

代码:
sudo apt-get update
sudo apt-get dist-upgrade


_________________
lenovo Thinkpad R60i 0657 LHC
windowsXP……准备换回ubuntu了。

Twitter: @carbont


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-04-06 21:26 
头像

注册: 2007-11-22 10:20
帖子: 3406
地址: 北京
送出感谢: 0 次
接收感谢: 1
我也是升了两次才升好,升的时候还不能用GUI的管理器,一用就程序死机……
用终端升级好了。[/code]


_________________
lenovo Thinkpad R60i 0657 LHC
windowsXP……准备换回ubuntu了。

Twitter: @carbont


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-04-07 11:34 
头像

注册: 2008-04-04 12:32
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
我现在无论用什么方式去更新,或者删除。总会出现同样的问题
在处理时有错误发生:
linux-image-2.6.22-14-generic
linux-ubuntu-modules-2.6.22-14-generic
linux-restricted-modules-2.6.22-14-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)


每次都是这个,无论怎么換源~~都是这个问题阿!~~


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译