[讨论]有谁搞定了今天新出的xf86-video-radeonhd-1.2.0的

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
BooBio
帖子: 4
注册时间: 2007-10-04 21:11
送出感谢: 0
接收感谢: 0

[讨论]有谁搞定了今天新出的xf86-video-radeonhd-1.2.0的

#1

帖子 BooBio » 2008-04-13 0:24

我的硬件环境是e2140 +p35 +ati radeon hd 3650 +杂牌17‘ LCD 宽屏
软件环境是ubuntu 7.10 gusty +Xorg 7.3

显卡太新了,ati 8.3的驱动还只支持到2600 series,就只好一直用vesa的驱动。看到今天放出来xf86-video-radeonhd-1.2.0,readme中明明说“Added support for RV620, RV635, and R680”,那么应该是支持3650核心的。结果浪费了一天时间也没有搞定。

有哪位达人是搞好了的,看看跟我的方法有什么不同。

我的操作步骤如下:
1. 编译
1.1 我没有用git download sources,是直接下载的zip包。
1.2 解压后没有autogen.sh,用的是configure.sh。diff了一下,感觉两者是一致的。期间装了一大堆configure要求的包,如protofonts,xserver,pciutils之类。这里有点问题,就是gusty gibbson中应该是xorg 7.3才对,但是在/usr/lib中xorg的目录不是xorgR7而是xorgR6。包都是在新立得上down的,xserver的版本好像是1.3.1。
1.3 然后就是make的过程,用的是全compile,把contents和utils下的也全编译了

2. 发布
2.1 虽然对xorg的版本有点怀疑,但是安装的还是很顺利,最后生成了radeonhd_drv.la和radeonhd.so两个。

3. 修改xorg.conf
修改xorg.conf中的driver为radeonhd後
3.1 在xorg.0.log中发现压根就没找到radeonhd驱动,发现install的时候默认是将驱动cp到/usr/local/lib/xorg/modules/drivers中,于是向usr/lib/xorg/modules/drivers又拷了一份。结果能找到驱动了,但是在modeline中dumpcore
3.2 因为我在windows下用的是1400x900的分辨率,以为是Vertical timing的问题,用gft看了一下,改成1440x900@35,结果还是不行
3.3 在phonorix上看到说要禁用aglrx之类的扩展,我照办了,重启x,结果还是挂了。

现在只能在800x600下用,dept也只能到16,哭~~~
发现radeonhd是骗人的。有哪位达人搞定了的,教教我吧,保证双手奉上鲜花无数~~
头像
jarryson
帖子: 4002
注册时间: 2005-08-14 19:53
送出感谢: 1 次
接收感谢: 2 次
联系:

#2

帖子 jarryson » 2008-04-13 12:59

3650?确实听得少,难道比3850还新?8.*支持3850的。这个开源驱动一直想试试看,但是没有试过。

官方上面确实没有写3000系列的显卡,但是确实是支持的,因为好像有人用的就是这些显卡,你还是试试看官方驱动把。
BooBio
帖子: 4
注册时间: 2007-10-04 21:11
送出感谢: 0
接收感谢: 0

#3

帖子 BooBio » 2008-04-13 15:07

多谢,改成ati8.3,发现真的可以呢。不过就是不能启动compiz,否则马上崩溃,进一步研究中
回复

回到 “常用硬件支持”